Libfontconfig1-dev unresolvable dependency [SOLVED]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

Libfontconfig1-dev unresolvable dependency [SOLVED]

Postby L551 on Mon Jan 10, 2011 3:50 pm

Trying to install that package via synaptic, but it tells me that it has an unresolvable dependency, with the error:
Code: Select all
 Depends: libfontconfig1 (=2.8.0-2.1) but 2.8.0-2ubuntu1 is to be installed


Fully updated LMDE 2011-01
Last edited by L551 on Thu Jan 13, 2011 11:00 am, edited 1 time in total.
L551
Level 1
Level 1
 
Posts: 13
Joined: Mon Nov 08, 2010 5:55 am

Linux Mint is funded by ads and donations.
 

Re: Libfontconfig1-dev unresolvable dependency

Postby joutlan on Mon Jan 10, 2011 7:34 pm

I got the exact same thing trying to install that library. Haven't read 'yet' about a bug :roll:
Last edited by joutlan on Mon Jan 10, 2011 8:36 pm, edited 1 time in total.
DΞLL Precision M6600: "Big Dog" i7-820QM, 8.0GB DDR3-1333, RGBLED, nVidia Quadro 4000M 2.0GB DDR3, Intel 6250//ScientificLinux x64/Win7Pro x64
DΞLL Vostro 3350 "Nirvana" Linux Mint 13 MATE//Win764Pro
User avatar
joutlan
Level 3
Level 3
 
Posts: 168
Joined: Sat Dec 29, 2007 4:16 am
Location: Orlando, FL

Re: Libfontconfig1-dev unresolvable dependency

Postby drzoo2 on Mon Jan 10, 2011 8:10 pm

https://bugs.launchpad.net/linuxmint/+bug/697968

Library is required to compile XBMC.
drzoo2
Level 1
Level 1
 
Posts: 19
Joined: Fri Dec 24, 2010 11:13 am

Re: Libfontconfig1-dev unresolvable dependency

Postby L551 on Tue Jan 11, 2011 5:27 pm

Not sure what I should be doing...?
L551
Level 1
Level 1
 
Posts: 13
Joined: Mon Nov 08, 2010 5:55 am

Re: Libfontconfig1-dev unresolvable dependency

Postby joutlan on Tue Jan 11, 2011 5:29 pm

I force installed the debian version of this library as it totally messed up my dependencies. This cause an upgrade of 4 other packages. All is well now, be careful with that...
DΞLL Precision M6600: "Big Dog" i7-820QM, 8.0GB DDR3-1333, RGBLED, nVidia Quadro 4000M 2.0GB DDR3, Intel 6250//ScientificLinux x64/Win7Pro x64
DΞLL Vostro 3350 "Nirvana" Linux Mint 13 MATE//Win764Pro
User avatar
joutlan
Level 3
Level 3
 
Posts: 168
Joined: Sat Dec 29, 2007 4:16 am
Location: Orlando, FL

Re: Libfontconfig1-dev unresolvable dependency

Postby L551 on Tue Jan 11, 2011 5:32 pm

theZoid wrote:I force installed the debian version of this library as it totally messed up my dependencies. This cause an upgrade of 4 other packages. All is well now, be careful with that...


How would I force install the debian version? Forcing a version from synaptic doesn't work - it just reverts w/o allowing me to apply changes
L551
Level 1
Level 1
 
Posts: 13
Joined: Mon Nov 08, 2010 5:55 am

Re: Libfontconfig1-dev unresolvable dependency

Postby joutlan on Tue Jan 11, 2011 6:55 pm

L551 wrote:
theZoid wrote:I force installed the debian version of this library as it totally messed up my dependencies. This cause an upgrade of 4 other packages. All is well now, be careful with that...


How would I force install the debian version? Forcing a version from synaptic doesn't work - it just reverts w/o allowing me to apply changes


I downloaded the debian version of that file, and did:

dpkg -i <packagename> --force

I then went into synaptic and selected the package that showed up in Synaptic, and went to >Package>--force version. Synaptic showed me as having a broken package. I had a heck of time getting this right, and when I finally did synaptic removed the broken package and showed 4 programs that needed to updated, that went thru fine and all is well.

I'd wait for someone to chime in on this, as I may have done this the hard way. While I had a broken package, synaptic wanted basically to uninstall all of gnome plus some! to correct it. It was a problem! All is great _now_, but I can't remember exactly what I did so be careful out there! And, I'm not sure how I got that ubuntu package in there in the first place as I won't use Ubuntu repos!
DΞLL Precision M6600: "Big Dog" i7-820QM, 8.0GB DDR3-1333, RGBLED, nVidia Quadro 4000M 2.0GB DDR3, Intel 6250//ScientificLinux x64/Win7Pro x64
DΞLL Vostro 3350 "Nirvana" Linux Mint 13 MATE//Win764Pro
User avatar
joutlan
Level 3
Level 3
 
Posts: 168
Joined: Sat Dec 29, 2007 4:16 am
Location: Orlando, FL

Re: Libfontconfig1-dev unresolvable dependency

Postby drzoo2 on Tue Jan 11, 2011 10:32 pm

Like already posted,To get around this I installed fontconfig-config_2.8.0-2.1_all.deb
found at
http://packages.debian.org/sid/fontconfig-config

and libfontconfig1_2.8.0-2.1_i386.deb found at
http://packages.debian.org/sid/libfontconfig1


If you have a broken package just remove via apt.
Then install both of these via dpkg -i

You shouldn't have to force the install.
fontconfig-config_2.8.0-2.1 is what libfontconfig1_2.8.0-2.1_i386.deb was chocking on for a dependency. Once this was resolved there was no need to force it.

z
drzoo2
Level 1
Level 1
 
Posts: 19
Joined: Fri Dec 24, 2010 11:13 am

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 5 guests