<SOLVED> cannot install xserver-xorg-dev

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

<SOLVED> cannot install xserver-xorg-dev

Postby xieu90 on Thu Jan 13, 2011 9:06 am

Hi
I cannot install xserver-xorg-dev
I need it to install the wizardpen driver (for tablet )
in synaptic I get this error:
xserver-xorg-dev:
Depends: libpixman-1-dev but it is not going to be installed

in terminal I get this:
The following packages have unmet dependencies:
xserver-xorg-dev : Depends: libpixman-1-dev (>= 0.15.20) but it is not going to be installed
E: Broken packages

what should I do to be able to install that one ?

I managed to install wizardpen driver in old LMDE with this tut: (I use method 2)
https://help.ubuntu.com/community/TabletSetupWizardpen
and now I'm doing it again in new LMDE and got that error


PS: solved.
just click on reload in synapstic and install xserver-xorg-dev like normal.
it works now thanks for Clem's hardwork ^^
Last edited by xieu90 on Wed Jan 26, 2011 9:50 am, edited 2 times in total.
xieu90
Level 2
Level 2
 
Posts: 85
Joined: Fri Dec 05, 2008 12:43 pm

Linux Mint is funded by ads and donations.
 

Re: cannot install xserver-xorg-dev

Postby Kiranos on Wed Jan 19, 2011 9:36 am

I have this same error:

xorg-dev:

The following packages have unmet dependencies:
xorg-dev : Depends: libxft-dev but it is not going to be installed
xorg-dev : Depends: xserver-xorg-dev but it is not going to be installed
E: Broken packages

also using LinuxMint Debian edition, it's a pretty nasty bug, not able to install xorg-dev :(

added bugreport here:

https://bugs.launchpad.net/linuxmint/+bug/704911
Kiranos
Level 1
Level 1
 
Posts: 3
Joined: Mon Dec 27, 2010 9:58 am

Re: cannot install xserver-xorg-dev

Postby palemoon on Wed Jan 19, 2011 1:06 pm

I have the same problem with trying to install libgtk2.0-dev.

Basically, the problem is the Ubuntu packages that were used to make the font rendering look pretty. It's never a good idea to mix Debian and Ubuntu packages, IMHO. I emailed Clem about this, but haven't heard anything.

Ed
HEKA OS - Where Window Maker meets LMDE
User avatar
palemoon
Level 1
Level 1
 
Posts: 2
Joined: Wed Dec 24, 2008 3:31 am
Location: Louisville, KY USA

Re: cannot install xserver-xorg-dev

Postby Kiranos on Wed Jan 19, 2011 3:08 pm

palemoon wrote:I have the same problem with trying to install libgtk2.0-dev.

Basically, the problem is the Ubuntu packages that were used to make the font rendering look pretty. It's never a good idea to mix Debian and Ubuntu packages, IMHO. I emailed Clem about this, but haven't heard anything.

Ed


Hi yes I had that issue aswell, it's talked about in this thread: viewtopic.php?f=141&t=62311&start=0

and bugtracker here: https://bugs.launchpad.net/linuxmint/+bug/695621

seems to be recoginzed as High importance, hopefully this will aswell
Kiranos
Level 1
Level 1
 
Posts: 3
Joined: Mon Dec 27, 2010 9:58 am


Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 4 guests