Mintdesktop 3.22... (Solved)

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Mintdesktop 3.22... (Solved)

Postby tenfoot on Fri Jan 14, 2011 10:23 pm

Using LMDE2919 on a Thinkpad T60.

Did an update today and got the following error message:

Code: Select all
/var/cache/apt/archives/mintdesktop_3.2.2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:


Clicked on Details and the following was returned:

Code: Select all
E:/var/cache/apt/archives/mintdesktop_3.2.2_all.deb: there is no script in the new version of the package - giving up
(Reading database ... 185941 files and directories currently installed.)
Preparing to replace mintdesktop 3.2.1 (using .../mintdesktop_3.2.2_all.deb) ...
/var/lib/dpkg/info/mintdesktop.prerm: 32: cannot create /etc/gdm/PostLogin/mintDesktop.tmp: Directory nonexistent
dpkg: warning: subprocess old pre-removal script returned error exit status 2
dpkg - trying script from the new package instead ...
dpkg: error processing /var/cache/apt/archives/mintdesktop_3.2.2_all.deb (--unpack):
 there is no script in the new version of the package - giving up
configured to not write apport reports
                                      Errors were encountered while processing:


Any assistance in how I can update Mintdesktop would be much appreciated.
Last edited by tenfoot on Sat Jan 15, 2011 1:24 am, edited 1 time in total.
User avatar
tenfoot
Level 5
Level 5
 
Posts: 550
Joined: Sun Jun 03, 2007 4:12 am
Location: Waipapa, Bay of Islands, New Zealand

Linux Mint is funded by ads and donations.
 

Re: Mintdesktop 3.22...

Postby zerozero on Fri Jan 14, 2011 10:31 pm

from the blog:

http://blog.linuxmint.com/?p=1595

Because of a problem in mintdesktop 3.2.1, you’ll need to run the following commands to ensure a smooth upgrade:

apt update

sudo rm /var/lib/dpkg/info/mintdesktop.prerm

apt install mintdesktop

This hiccup with mintdesktop is fixed in the version you’re upgrading to and a reminiscence of the previous version. Please accept our apologies for this little problem.

User avatar
zerozero
Level 16
Level 16
 
Posts: 6435
Joined: Tue Jul 07, 2009 2:29 pm

Re: Mintdesktop 3.22...

Postby tenfoot on Sat Jan 15, 2011 1:24 am

Thank you zerozero. All is now well with my world :)
User avatar
tenfoot
Level 5
Level 5
 
Posts: 550
Joined: Sun Jun 03, 2007 4:12 am
Location: Waipapa, Bay of Islands, New Zealand

Re: Mintdesktop 3.22... (Solved)

Postby zerozero on Sat Jan 15, 2011 7:46 am

you're welcome :)
User avatar
zerozero
Level 16
Level 16
 
Posts: 6435
Joined: Tue Jul 07, 2009 2:29 pm

Re: Mintdesktop 3.22...

Postby RavanH on Thu Feb 24, 2011 5:51 am

zerozero wrote:from the blog:

http://blog.linuxmint.com/?p=1595

Because of a problem in mintdesktop 3.2.1, you’ll need to run the following commands to ensure a smooth upgrade:

apt update

sudo rm /var/lib/dpkg/info/mintdesktop.prerm

apt install mintdesktop

This hiccup with mintdesktop is fixed in the version you’re upgrading to and a reminiscence of the previous version. Please accept our apologies for this little problem.



zero, THANK you :)
RavanH
Level 2
Level 2
 
Posts: 53
Joined: Sun Jan 17, 2010 6:24 am

Re: Mintdesktop 3.22... (Solved)

Postby zerozero on Thu Feb 24, 2011 8:22 am

glad it helped you 8)
User avatar
zerozero
Level 16
Level 16
 
Posts: 6435
Joined: Tue Jul 07, 2009 2:29 pm

Re: Mintdesktop 3.22... (Solved)

Postby kansasnoob on Mon Mar 07, 2011 11:26 am

Far out! I was just trying to decide if I should reinstall LMDE because I started with '201009'. With this resolved I see no need to reinstall using '201012'.

Great forum search tool :D
kansasnoob
Level 4
Level 4
 
Posts: 294
Joined: Sun Jul 20, 2008 1:45 pm

Re: Mintdesktop 3.22... (Solved)

Postby Pythzor on Mon Mar 14, 2011 11:42 am

Thank you, zerozero (I googled first and found this thread).
AMD Athlon II X2 220, 2.8 GHz, 6 GB, Geforce 6150SE, 1 TB hdd: Windows 7 Ultimate; Nadia/Mate; Ultimate Edition 3.4.
Pythzor
Level 3
Level 3
 
Posts: 155
Joined: Fri Jul 09, 2010 7:05 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 5 guests