[SOLVED] embedded desktop using gnome-terminal and devilspie

All Gurus once were Newbies
Forum rules

[SOLVED] embedded desktop using gnome-terminal and devilspie

Postby Habitual on Mon Jan 17, 2011 1:04 am

Well, first off, this problem does NOT occur on my "other" install of LM10/32, just LMDE/32
Dual boot LM10/32 bit and LMDE/32.

I have Devil's Pie 0.22 installed from REPO(s)
I have used the same .ds file and devilspie to embed a gnome-terminal on my desktop.
I have done this for years and literally across dozens of distros.

This issue is if I change focus using either mouse or keyboard to another window, I cannot get the focus back into the embedded desktop.
I can right mouse click the terminal and select "Show Menubar" and that does get shown, or "Close Window" and it does, but no focus.
Now, if i select any menu choice from any menu option, the terminal does get focus, but ONLY while the menu is down. The second I select something and it rolls up, I have no more focus.
Oddly enough, full screen doesn't work either using F11 when it's embedded.
All of these features work on LM10/32bit

Please, DO NOT TELL ME ABOUT OTHER TERMINALS that do the same thing, blah blah blah. Don't waste my time or yours. Thank You.
Here's my trans.ds (devilspie script) for this exercise.
Code: Select all
; generated_rule trans
( if
( and
( matches ( window_name ) "trans" )
)
( begin
( undecorate )
( skip_pager )
( skip_tasklist )
( wintype "dock" )
( set_workspace 1 )
( center )
( geometry "796x800+296+33" )
( below )
( println "match" )
)
)


and the instructions for modifying a profile for gnome-terminal and devilspie
Now, to tweak the gnome-terminal settings...I use these...
File Menu > New Profile > "Profile Name": trans
General tab:
"Show menu bar by default in new terminals": De-selected

Title and command tab:
"Initial Title": trans
"When terminal commands set their own titles": Keep Intial Title
"When command exits": Restart the command
"Update login records when command is launched": is Checked.

Colors tab:
De-Select "use colors from system scheme".
Text color: #EFF50B - Yellow
Background color: #190E6F - Blue (Should be ignored if Transparency is "None")

Background tab:
Transparent: (Slider to) "None"

Scrolling tab:
Scrollbar is Disabled
Unlimited is selected.
Scroll on output is Selected.

Start "devilspie" as an Application Autostart and "gnome-terminal --profile=trans" also.

Thank you for your time.

Update:
Seems to be ok with
( wintype "normal" ) instead of "dock".
If you can't find an answer at Google, you must be typing in Braille.
User avatar
Habitual
Level 10
Level 10
 
Posts: 3477
Joined: Sun Nov 21, 2010 8:31 pm
Location: Youngstown, Ohio

Linux Mint is funded by ads and donations.
 

Re: [SOLVED] embedded desktop using gnome-terminal and devil

Postby Oscar799 on Fri Jan 28, 2011 9:29 am

Glad you found a solution :P
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789
User avatar
Oscar799
Level 19
Level 19
 
Posts: 9299
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom


Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 5 guests