ACPI wakeup state lost after reboot

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

ACPI wakeup state lost after reboot

Postby joefidler on Mon Jan 17, 2011 6:52 pm

I like to use my keyboard to wake up the machine after a (S3) suspend to ram. To enable this I use
"cat /proc/acpi/wakeup" to see which devices I have.

For me the keyboard is PS2K device.

I then do:
sudo su
echo PS2K > /proc/acpi/wakeup

to toggle the state of the PS2K device to "enabled".

I then do a "cat /proc/acpi/wakeup" again to confirm. I can then suspend / resume with the keyboard and it all works.
But... the wakeup setting is lost after a re-boot, and PS2K goes back to being disabled.

With Ubuntu the ACPI wakeup stays set after a re-boot so I suspect that this may be a bug or suggestions - am I setting this up the wrong way?

LInux Mint LMDE, Kernel 2.6.32-5 amd64.

Cheers, Joe.
joefidler
Level 1
Level 1
 
Posts: 1
Joined: Mon Jan 17, 2011 6:32 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 6 guests