how to disable touchpad click without use of xorg.conf?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

how to disable touchpad click without use of xorg.conf?

Postby blm14 on Fri Jan 21, 2011 12:01 pm

Just installed LMDE and loving it so far. Fast boot time, nice clean interface, yay!!

But the machine I've installed it on is a dell inspiron N5030 which has one of those lovely little trackpads and I cannot figure out how to disable the tap-to-click function, which means I am constantly creating false-positive mouse clicks (I did three just while typing this paragraph, argh!)

Doing some searching, most of the solutions to this problem involve customizing xorg.conf which I believe is completely deprecated now. So I can't use that!

A little info:

Code: Select all
uname -a
Linux maybeinnovations 2.6.32-5-amd64 #1 SMP Wed Jan 12 03:40:32 UTC 2011 x86_64 GNU/Linux


Code: Select all
xinput -list
⎡ Virtual core pointer                       id=2   [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                 id=4   [slave  pointer  (2)]
⎜   ↳ PS/2 Generic Mouse                         id=12   [slave  pointer  (2)]
⎜   ↳ Macintosh mouse button emulation           id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                      id=3   [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                id=5   [slave  keyboard (3)]
    ↳ Video Bus                                  id=6   [slave  keyboard (3)]
    ↳ Video Bus                                  id=7   [slave  keyboard (3)]
    ↳ Power Button                               id=8   [slave  keyboard (3)]
    ↳ Sleep Button                               id=9   [slave  keyboard (3)]
    ↳ Laptop_Integrated_Webcam_0.3M              id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard               id=11   [slave  keyboard (3)]


Now first of all I was a little worried that LMDE is not recognizing my mouse as a touchpad and is treating it as a generic PS/2 mouse and when I run gpointing-device-settings I see only "generic PS/2 mouse"

So, how can disable the annoying tap-to-click function without using xorg.conf? Will I need to first convice linux that i REALLY REALLY do have a touchpad and not some PS/2 mouse? If it thinks I have a generic PS/2 mouse then why is tapping working at all!? HALP!

TIA
blm14
Level 1
Level 1
 
Posts: 6
Joined: Thu Jan 20, 2011 6:39 am

Linux Mint is funded by ads and donations.
 

Re: how to disable touchpad click without use of xorg.conf?

Postby blm14 on Fri Jan 21, 2011 12:28 pm

Ugh

It's not a problem with LDME or even Debian. It's a kernel bug:

https://bugzilla.kernel.org/show_bug.cgi?id=23502

Anyone have a clue how long these things take to resolve? Will I be able to turn off tap clicking in a month? A year?

Yuck
blm14
Level 1
Level 1
 
Posts: 6
Joined: Thu Jan 20, 2011 6:39 am

Re: how to disable touchpad click without use of xorg.conf?

Postby blm14 on Sat Jan 22, 2011 8:55 am

Bump. Is there a way to resurrect xorg.conf and use that solution?
blm14
Level 1
Level 1
 
Posts: 6
Joined: Thu Jan 20, 2011 6:39 am

Re: how to disable touchpad click without use of xorg.conf?

Postby viking777 on Sat Jan 22, 2011 10:21 am

blm14 wrote:Bump. Is there a way to resurrect xorg.conf and use that solution?


Yes.
Open terminal:

Code: Select all
sudo telinit 1


type password again (it says root password but it means sudo password)

Code: Select all
X -configure


Code: Select all
mv /root/xorg.conf.new /etc/X11/xorg.conf


This will only work if there is no xorg.conf already in /etc/X11, if there is rename it first.

Code: Select all
init 5


To bring you back to the desktop again.

Of course what you do with the new xorg.conf is up to you, I don't know the solution you speak about.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: how to disable touchpad click without use of xorg.conf?

Postby mudpie on Sun Jan 23, 2011 12:49 pm

Does your laptop have a key-combination that disables the touchpad?

I have an Dell/Alienware laptop, and struggled with disabling the touchpad white running Ubuntu, and also ran down the confusing xorg path... then realized the controls are on the keyboard.

heh.

For me it's FN + F12 (function and F12). This quickly toggles the touchpad completely on or off for me.

Good luck, I hope you find a solution.

-Laura
mudpie
Level 1
Level 1
 
Posts: 24
Joined: Thu Jan 13, 2011 4:40 pm

Re: how to disable touchpad click without use of xorg.conf?

Postby Aging Technogeek on Sun Jan 23, 2011 1:17 pm

There is an applet available for installation that puts an icon on the panel which will toggle the touchpad on and off when clicked. Get it here:

http://www.webupd8.org/2010/11/touchpad-indicator-lets-you-quickly.html
Image

Registered Linux User 483387
User avatar
Aging Technogeek
Level 13
Level 13
 
Posts: 4605
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here

Re: how to disable touchpad click without use of xorg.conf?

Postby sgosnell on Sun Jan 23, 2011 2:25 pm

On my system the mouse preferences has a touchpad tab which has a checkbox for that. Open the Mintmenu, and in the search box type mouse, and you should get the applet opened.
Asus eee-pc 900 w/ 32GB SSD.
sgosnell
Level 5
Level 5
 
Posts: 686
Joined: Fri Sep 10, 2010 9:32 pm
Location: Baja Oklahoma

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 7 guests