Need help with sound for Virtualbox

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

Need help with sound for Virtualbox

Postby k4ever on Sat Jan 22, 2011 2:51 pm

I'm running LMDE with the latest updates (as of this post) on my Gateway 7510gx laptop. I installed the non-free version of Virtualbox from the repository and set up Windows 7 as a guest OS. I cannot get sound to work under Windows 7. I even upgraded to the latest version of Virtualbox for Debian from the website and still can't get sound for my Windows 7 guest. I've tried every sound configuration for the guest machine. Is there a problem with Virtualbox on LMDE?
k4ever
Level 1
Level 1
 
Posts: 9
Joined: Tue Sep 14, 2010 10:55 pm

Linux Mint is funded by ads and donations.
 

Re: Need help with sound for Virtualbox

Postby vincent on Sun Jan 23, 2011 7:51 am

http://www.virtualbox.org/wiki/Guest_OSes

According to the link above, you'd have to manually install sound drivers within Windows 7.
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm
vincent
Level 8
Level 8
 
Posts: 2220
Joined: Tue Feb 09, 2010 4:10 am

Re: Need help with sound for Virtualbox

Postby k4ever on Mon Jan 24, 2011 6:59 am

Vincent. I've done that. I downloaded drivers from the Realtek site, with no luck. I wish they would provide a link to audio drivers that work, since they (vbox) only allows you to use one of 3 (Intel HD, Intel AC97, or Creative Soundblaster).
k4ever
Level 1
Level 1
 
Posts: 9
Joined: Tue Sep 14, 2010 10:55 pm

Re: Need help with sound for Virtualbox

Postby k4ever on Mon Jan 24, 2011 7:46 am

Vincent et al, please disregard. The sound is working great now. I had to reinstall Windows 7. Apparently I had a bad install. The sound works automatically now in Windows 7 with Virtualbox 4.
k4ever
Level 1
Level 1
 
Posts: 9
Joined: Tue Sep 14, 2010 10:55 pm


Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 2 guests