Need advice xorg-server-core + fglrx

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Need advice xorg-server-core + fglrx

Postby blowtorch on Thu Feb 24, 2011 9:40 am

How does one properly upgrade xorg-server-core without losing their fglrx drivers?

I have fglrx is installed the debian way according to their wiki http://wiki.debian.org/ATIProprietary

I am always using the latest stable liquorix kernel

thanks
User avatar
blowtorch
Level 3
Level 3
 
Posts: 101
Joined: Sun Sep 05, 2010 10:03 pm

Linux Mint is funded by ads and donations.
 

Re: Need advice xorg-server-core + fglrx

Postby twa on Fri Feb 25, 2011 6:10 am

blowtorch,
install smxi from here:
http://smxi.org/
it will take care of everything..i.e. system update/upgrade and drivers
reinstall.
read carefully the on-screen displays
:mrgreen:
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread.
User avatar
twa
Level 4
Level 4
 
Posts: 231
Joined: Fri Sep 17, 2010 8:11 am
Location: Somewhere in the sky

Re: Need advice xorg-server-core + fglrx

Postby blowtorch on Fri Feb 25, 2011 9:56 am

twa wrote:blowtorch,
install smxi from here:
http://smxi.org/
it will take care of everything..i.e. system update/upgrade and drivers
reinstall.
read carefully the on-screen displays
:mrgreen:



Thanks man! I will give smxi another shot ... i've had problems with it in the past ...
User avatar
blowtorch
Level 3
Level 3
 
Posts: 101
Joined: Sun Sep 05, 2010 10:03 pm

Re: Need advice xorg-server-core + fglrx

Postby Roken on Fri Feb 25, 2011 6:37 pm

Don't bother upgrading to xorg in updates - it breaks fglrx and there's no way back (2:1.7.7.11 is the problem one).
Kernel Linux Tex 3.2.2-1 (64 bit) xfce , burg
Arch
ATI Radeon HD 4670, 1GB
OSS4
AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked)
8Gb RAM
Image
User avatar
Roken
Level 5
Level 5
 
Posts: 747
Joined: Fri Nov 19, 2010 4:55 pm
Location: Oldham, UK


Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 6 guests