LMDE 64-Bit Error Messages

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

LMDE 64-Bit Error Messages

Postby kwisher on Thu Mar 03, 2011 9:44 am

Hello All,

I hope someone can provide some insight into what all these error messages I am receiving when doing an apt-get dist-upgrade. This is fresh install on a raid-5 server I built for a customer about 18 months ago. The primary O/S hard drive was starting to fail. I originally installed Mint-7 64-bit on the system when I built it.
Code: Select all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
29 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]?
Setting up udev (166-1) ...
dpkg: error processing udev (--configure):
 failed to read on buffer copy for md5hash: Input/output error
configured to not write apport reports
                                      dpkg: dependency problems prevent configuration of initramfs-tools:
 initramfs-tools depends on udev (>= 0.086-1); however:
  Package udev is not configured yet.
dpkg: error processing initramfs-tools (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-2.6.32-5-amd64:
 linux-image-2.6.32-5-amd64 depends on initramfs-tools (>= 0.55) | linux-initramfs-tool; however:
  Package initramfs-tools is not configured yet.
  Package linux-initramfs-tool is not installed.
  Package initramfs-tools which provides linux-initramfs-tool is not configured yet.
configured to not write apport reports
                                      configured to not write apport reports
                                                                            configured to not write apport reports
                                                                                                                  dpkg: error processing linux-image-2.6.32-5-amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of usb-modeswitch-data:
 usb-modeswitch-data depends on udev (>= 0.140) | not+linux-gnu; however:
  Package udev is not configured yet.
  Package not+linux-gnu is not installed.
dpkg: error processing usb-modeswitch-data (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of usb-modeswitch:
 usb-modeswitch depends on usb-modeswitch-data-packed | usb-modeswitch-data; however:
  Package usb-modeswitch-data-packed is not installed.
  Package usb-modeswitch-data is not configured yet.
dpkg: error processing usb-modeswitch (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of bluez:
 bluez depends on udev | makedev; however:
  Package udev is not configured yet.
  Package makedev is not installed.
dpkg: error processing bluez (--confconfigured to not write apport reports
                                                                          configured to not write apport reports
                                                                                                                configured to not write apport reports
                                                                                                                                                      igure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of upower:
 upower depends on udev; however:
  Package udev is not configured yet.
dpkg: error processing upower (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gdm3:
 gdm3 depends on upower; however:
  Package upower is not configured yet.
dpkg: error processing gdm3 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of hal:
 hal depends on udev (>= 143); however:
  Package udev is not configured yet.
dpkg: error processing hal (--configure):
 dependency problems - leaving unconfigured
configured to not write apport reports
                                      configured to not write apport reports
                                                                            dpkg: dependency problems prevent configuration of pcscd:
 pcscd depends on hal; however:
  Package hal is not configured yet.
dpkg: error processing pcscd (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libpcsclite1:
 libpcsclite1 depends on pcscd; however:
  Package pcscd is not configured yet.
dpkg: error processing libpcsclite1 (--configure):
 dependency problems - leaving unconfigured
configured to not write apport reports
                                      configured to not write apport reports
                                                                            dpkg: dependency problems prevent configuration of libccid:
 libccid depends on libpcsclite1; however:
  Package libpcsclite1 is not configured yet.
dpkg: error processing libccid (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libsane:
 libsane depends on udev (>= 0.88-1) | makedev (>= 2.3.1-58); however:
  Package udev is not configured yet.
  Package makedev is not installed.
dpkg: error processing libsane (--configure):
 dependency problems - leaving unconfiguredconfigured to not write apport reports
                                                                                 configured to not write apport reports

dpkg: dependency problems prevent configuration of libsensors4:
 libsensors4 depends on makedev (>= 2.3.1-45) | udev; however:
  Package makedev is not installed.
  Package udev is not configured yet.
dpkg: error processing libsensors4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-2.6-amd64:
 linux-image-2.6-amd64 depends on linux-image-2.6.32-5-amd64; however:
  Package linux-image-2.6.32-5-amd64 is not configured yet.
dpkg: error processing linux-image-2.6-amd64 (--configure):
configured to not write apport reports
                                      configured to not write apport reports
                                                                             dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of mdadm:
 mdadm depends on udev | makedev; however:
  Package udev is not configured yet.
  Package makedev is not installed.
dpkg: error processing mdadm (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of media-player-info:
 media-player-info depends on udev; however:
  Package udev is not configured yet.
dpkg: error processing media-player-info (--configure):
 dependency problems - leaving unconfigured
configured to not write apport reports
                                      configured to not write apport reports
                                                                            dpkg: dependency problems prevent configuration of network-manager:
 network-manager depends on udev; however:
  Package udev is not configured yet.
dpkg: error processing network-manager (--configure):
 dependency problems - leaving unconfigured
configured to not write apport reports
                                      dpkg: dependency problems prevent configuration of pulseaudio:
 pulseaudio depends on udev (>= 143); however:
  Package udev is not configured yet.
dpkg: error processing pulseaudio (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pulseaudio-esound-compat:
 pulseaudio-esound-compat depends on pulseaudio; however:
  Package pulseaudio is not configured yet.
dpkg: error processing pulseaudio-esound-compat (--configure):
 dependency problems - leaving unconfigured
configured to not write apport reports
                                      configured to not write apport reports
                                                                            dpkg: dependency problems prevent configuration of pulseaudio-module-gconf:
 pulseaudio-module-gconf depends on pulseaudio; however:
  Package pulseaudio is not configured yet.
dpkg: error processing pulseaudio-module-gconf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pulseaudio-module-x11:
 pulseaudio-module-x11 depends on pulseaudio; however:
  Package pulseaudio is not configured yet.
dpkg: error processing pulseaudio-module-x11 (--configure):
 dependency problems - leaving unconfigured
configured to not write apport reports
                                      configured to not write apport reports
                                                                            dpkg: dependency problems prevent configuration of pulseaudio-module-zeroconf:
 pulseaudio-module-zeroconf depends on pulseaudio; however:
  Package pulseaudio is not configured yet.
dpkg: error processing pulseaudio-module-zeroconf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of sane-utils:
 sane-utils depends on libsane (>= 1.0.11-3); however:
  Package libsane is not configured yet.
configured to not write apport reports
                                      configured to not write apport reports
                                                                            dpkg: error processing sane-utils (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xserver-xorg-core:
 xserver-xorg-core depends on udev (>= 149); however:
  Package udev is not configured yet.
dpkg: error processing xserver-xorg-core (--configure):
 dependency problems - leaving unconfigured
configured to not write apport reports
                                      dpkg: dependency problems prevent configuration of xserver-xorg-video-cirrus:
 xserver-xorg-video-cirrus depends on xorg-video-abi-6.0; however:
  Package xorg-video-abi-6.0 is not installed.
  Package xserver-xorg-core which provides xorg-video-abi-6.0 is not configured yet.
 xserver-xorg-video-cirrus depends on xserver-xorg-core (>= 2:1.7.6.901); however:
  Package xserver-xorg-core is not configured yet.
dpkg: error processing xserver-xorg-video-cirrus (--configure):
 dependency problems - leaving unconfigured
configured to not write apport reports
                                      dpkg: dependency problems prevent configuration of xserver-xorg-video-intel:
 xserver-xorg-video-intel depends on xorg-video-abi-6.0; however:
  Package xorg-video-abi-6.0 is not installed.
  Package xserver-xorg-core which provides xorg-video-abi-6.0 is not configured yet.
 xserver-xorg-video-intel depends on xserver-xorg-core (>= 2:1.7.6.901); however:
  Package xserver-xorg-core is not configured yet.
dpkg: error processing xserver-xorg-video-intel (--configure):
 dependency problems - leaving unconfigured
configured to not write apport reports
                                      dpkg: dependency problems prevent configuration of xserver-xorg-video-mga:
 xserver-xorg-video-mga depends on xorg-video-abi-6.0; however:
  Package xorg-video-abi-6.0 is not installed.
  Package xserver-xorg-core which provides xorg-video-abi-6.0 is not configured yet.
 xserver-xorg-video-mga depends on xserver-xorg-core (>= 2:1.7.6.901); however:
  Package xserver-xorg-core is not configured yet.
dpkg: error processing xserver-xorg-video-mga (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of lm-sensors:
 lm-sensors depends on libsensors4 (>= 1:3.1.1); however:
  Package libsensors4 is not configured yet.
dpkg: error processing lm-sensors (--configure):
 dependency problems - leaving unconfigured
configured to not write apport reports
                                      configured to not write apport reports
                                                                            Errors were encountered while processing:
 udev
 initramfs-tools
 linux-image-2.6.32-5-amd64
 usb-modeswitch-data
 usb-modeswitch
 bluez
 upower
 gdm3
 hal
 pcscd
 libpcsclite1
 libccid
 libsane
 libsensors4
 linux-image-2.6-amd64
 mdadm
 media-player-info
 network-manager
 pulseaudio
 pulseaudio-esound-compat
 pulseaudio-module-gconf
 pulseaudio-module-x11
 pulseaudio-module-zeroconf
 sane-utils
 xserver-xorg-core
 xserver-xorg-video-cirrus
 xserver-xorg-video-intel
 xserver-xorg-video-mga
 lm-sensors
E: Sub-process /usr/bin/dpkg returned an error code (1)

Please let me know if I need to provide further details.
TIA
The instructions suggested Windows XP or better, so I installed Linux :)
User avatar
kwisher
Level 5
Level 5
 
Posts: 650
Joined: Wed Mar 05, 2008 12:54 pm
Location: Greentown, Indiana USA

Linux Mint is funded by ads and donations.
 

Re: LMDE 64-Bit Error Messages

Postby jack.herbert on Thu Mar 03, 2011 3:45 pm

Dependency issues might have to do with the fact that the repos changed since the LMDE-64 dvd was released (something about sid/testing). I couldn't update after a fresh install on a friends laptop. If you try mint-update, do you get a error saying "fix broken packages first"?
If that's the case, search for exactly that "*" on this forum and you'll find ways to update the repositories addresses (I can't find the exact post anymore).
I don't fully understand any of this but hope it might help you.

edit: and since you mention "customer" it might be better/trouble-free to install the standard mint 10.
The light at the end of the tunnel is just the light of an oncoming train.
Robert Lowell
User avatar
jack.herbert
Level 1
Level 1
 
Posts: 40
Joined: Sun Jun 28, 2009 5:25 pm

Re: LMDE 64-Bit Error Messages

Postby kwisher on Fri Mar 04, 2011 9:17 am

jack.herbert wrote:Dependency issues might have to do with the fact that the repos changed since the LMDE-64 dvd was released (something about sid/testing). I couldn't update after a fresh install on a friends laptop. If you try mint-update, do you get a error saying "fix broken packages first"?
If that's the case, search for exactly that "*" on this forum and you'll find ways to update the repositories addresses (I can't find the exact post anymore).
I don't fully understand any of this but hope it might help you.

edit: and since you mention "customer" it might be better/trouble-free to install the standard mint 10.


Since this is a headless home file server, I wanted to move to a rolling release to avoid the distro "dying" after it stopped receiving support and updates. I ended up installing Ubuntu 10.10 64-bit Server on it and it is now back up and running.

Ikey, can you please advise on this issue?
The instructions suggested Windows XP or better, so I installed Linux :)
User avatar
kwisher
Level 5
Level 5
 
Posts: 650
Joined: Wed Mar 05, 2008 12:54 pm
Location: Greentown, Indiana USA


Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 4 guests