LMDE problem or my problem?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

LMDE problem or my problem?

Postby viking777 on Sat Mar 12, 2011 1:33 pm

I just installed LMDE onto an old computer of mine using the same install disk that I installed to my main computer. LMDE runs perfectly on my main computer and I use it in preference to anything else I have installed, but on the old machine OMG what a difference!

First of all let me define 'old computer'. This is an AMD Athlon 2000 processor with 1Gb of sdr memory, so it is in no way out of date I would say.

The results are HORRIBLE!.

It has so much lag that I can hardly do anything at all on it. I saw this when running it from the live cd, but I put it down to the cd drive which groans and squeals like a dying dog. But I was wrong, it was not the cd drive, because after install it was exactly the same.

I obviously investigated this and found out through 'top' that a process called "events/0" was using 60% - 65% of my cpu resources continuously (and I later found out that the live cd was the same).

I attempted to kill the process both through a root terminal and a root instance of gnome-system-momitor. The result was the same in both cases - it refused to die (or if it did die it respawned immediately - and with the same pid, which is doubt is likely).

Anyway I have no need of LMDE on this particular machine, it is very rarely used and therefore very rarely updated, a situation that LMDE would not tolerate I think, so it will probably be erased sometime tomorrow, but I feel if this sort of problem is endemic within the release it will not win any friends and maybe the developers of LMDE may need to look into this. I have no idea (yet, because I will google it later) what "events/0" does, but a process that monopolises your cpu to such an extent and refuses to be killed is not user friendly.

I will repeat here that the same disk was used to install to my main computer and that install is faultless so this is not a 'bad dowwnload' problem.

Incidentally at the moment this machine is running Mint 8 without any problems at all.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Linux Mint is funded by ads and donations.
 

Re: LMDE problem or my problem?

Postby Roken on Sat Mar 12, 2011 2:02 pm

The most common reason I have found for this is the network drivers in laptops (I don;t use a laptop so can't experiment myself). However, manually restarting the network interface (ifdown/ifup) has been reported to stop the CPU hogging.
Kernel Linux Tex 3.2.2-1 (64 bit) xfce , burg
Arch
ATI Radeon HD 4670, 1GB
OSS4
AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked)
8Gb RAM
Image
User avatar
Roken
Level 5
Level 5
 
Posts: 747
Joined: Fri Nov 19, 2010 4:55 pm
Location: Oldham, UK

Re: LMDE problem or my problem?

Postby viking777 on Sat Mar 12, 2011 2:09 pm

Well, I found a workround for it anyway.

Code: Select all
sudo killall NetworkManager


The system works perfectly normally after that command, but I still don't think that is acceptable.

Strangely enough after doing this my network still connects (though I obviously can't manage it in any way)
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: LMDE problem or my problem?

Postby viking777 on Sat Mar 12, 2011 2:14 pm

Roken wrote:The most common reason I have found for this is the network drivers in laptops (I don;t use a laptop so can't experiment myself). However, manually restarting the network interface (ifdown/ifup) has been reported to stop the CPU hogging.


Thanks Roken I will have a look at that as an alternative to my method. Obviously networks are the problem, but this is a desktop, not a laptop (don't know it that makes a difference though).

My point though is that new users should not have to face this kind of in depth trouble shooting. I have used a Mint 10 live cd on this machine and it does not exhibit the same problems so it is a fault with LMDE.

Edit. ifdown eth1 just reports "eth1 not configured" (same with eth2 which is wireless according to ifconfig) Strange thing is that NetworkManager does not show any wireless connections at all, only the wired eth1.

Edit2. Just noticed from ifconfig that 'killall NetworkManager' kills eth2 but leaves eth1 running. This is obviously the root of the problem but as I say I do not intend to run LMDE on this machine so it is only of academic interest to me really.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: LMDE problem or my problem?

Postby viking777 on Sun Mar 13, 2011 8:11 am

Did some more investigations into this today and found that it is indeed a debian problem. Mint8, Mint10 and pclos all run normally. But LMDE and now Debian Stable (that I replaced LMDE with) both freeze until I do something with networking. The easiest way to unfreeze it is to disable wireless from within the network manager applet, but killing network manager also works (as does "ifdown eth0" on debian stable, although it didn't on LMDE). The strange thing is that Network Manager applet has an X on the outside of it and has no network interfaces shown inside it, and when clicked on it claims that eth0 (the wired network) is "not managed". Well if NM applet is not managing it then what is? I don't have any other network manager installed.

I should say at this stage that it matters not a jot what I do with NetworkManager, I remain connected to the internet at all times even if I kill NM.

It is kind of ironic that with so many people screaming about not being able to connect to the internet with Linux I cant stop it connecting :!:

I suppose I could blacklist the wireless driver or possibly disable wireless from the bios as this machine does not use a wireless connection, but I would really like to get to the bottom of what is happening here before I do that, it is like a little challenge! On the other hand, this machine is rarely used and when it is, it is usually just for experimentation purposes so it is not a big deal for me - don't strain your brains thinking up a solution for me, if the problem interests you then by all means give me some input, but this is not a high priority issue.

EDIT. I seem to have found a reasonable work round for it. I just selected "disable networking" in NM applet (this setting was preserved through one reboot at least) and it now starts and runs normally, including an internet connection. But HOW :?: There is only one instance of NetworkManager running and like I say it doesn't even matter if I kill that since it isn't controlling the networking anyway. :?
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: LMDE problem or my problem?

Postby rekik on Sun Mar 13, 2011 9:35 am

So Debian is not always "better" than Ubuntu and the Ubuntu team seems to do, sometimes at least, a good job.
rekik
Level 3
Level 3
 
Posts: 198
Joined: Wed May 06, 2009 5:24 pm

Re: LMDE problem or my problem?

Postby viking777 on Sun Mar 13, 2011 11:20 am

rekik wrote:So Debian is not always "better" than Ubuntu and the Ubuntu team seems to do, sometimes at least, a good job.


It seems to be the case on this machine certainly.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: LMDE problem or my problem?

Postby kwisher on Sun Mar 13, 2011 1:33 pm

You might try installing a replacement app for Network Manger called Wicd from Synaptic.
The instructions suggested Windows XP or better, so I installed Linux :)
User avatar
kwisher
Level 5
Level 5
 
Posts: 633
Joined: Wed Mar 05, 2008 12:54 pm
Location: Greentown, Indiana USA

Re: LMDE problem or my problem?

Postby viking777 on Sun Mar 13, 2011 2:14 pm

kwisher wrote:You might try installing a replacement app for Network Manger called Wicd from Synaptic.


You are quite right, I could, but my situation is not that I can't start an internet connection, it is that I can't prevent one from starting. If I couldn't connect to the internet I might try wicd but that is not the issue, so I don't see how installing another network manager is going to help.

At the present moment in time I have completely disabled NetworkManager and even prevented it from starting (confirmed by both system monitor and the ps command), but I still get a fully working internet connection on every boot and I cannot understand how that is happening. I could understand perhaps that if you start off with an internet connection and then shut down Network Manager maybe the internet connection might persist, but I don't understand how you can get an internet connection after a cold boot when you prevent the program that initiates that connection from even starting up.

Maybe there is some command line program that underlies NetworkManager and still runs even when it doesn't. But if there is I don't think I have ever heard of it. The nearest I have got in my processes that even sounds like it could initiate an internet connection is called "modem-manager", and I am pretty sure that isn't doing it.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: LMDE problem or my problem?

Postby sgosnell on Sun Mar 13, 2011 6:29 pm

You have to have something strange in your settings, somewhere, either running multiple instances of NM in startup programs, or something. I see nothing like this, and I've seen no other reports of it. If it were truly a Debian problem, it would have been reported as a bug at some time. It has to be something specific to your machine or its settings, but I don't know where to start looking, since I've never seen nor heard of anything like it.
Asus eee-pc 900 w/ 32GB SSD.
sgosnell
Level 5
Level 5
 
Posts: 686
Joined: Fri Sep 10, 2010 9:32 pm
Location: Baja Oklahoma

Re: LMDE problem or my problem?

Postby viking777 on Mon Mar 14, 2011 6:43 am

sgosnell wrote:You have to have something strange in your settings, somewhere, either running multiple instances of NM in startup programs, or something. I see nothing like this, and I've seen no other reports of it. If it were truly a Debian problem, it would have been reported as a bug at some time. It has to be something specific to your machine or its settings, but I don't know where to start looking, since I've never seen nor heard of anything like it.


Thanks for that sgosnell, it is good to hear, because I thought it was just me being stupid and missing something blindingly obvious, but maybe not :lol:

Two instances of NetworkManager is the first thing I thought of, but as I said, both the ps command and the system monitor deny that is the case. Like yourself I have never heard of it or been able to find out anything about it online, so it probably is just my problem. But if it is a "settings" problem why does it only affect Debian based distros? This machine has had a lot of distros thrown at it over the years, and it has never occurred before, neither have I altered any settings for a long time (except grub which has been altered quite a lot recently, but I don't see how that will affect it).

I have even thought that perhaps my understanding that NetworkManager instigates the internet connection on Gnome is wrong. Maybe there is a startup script somewhere that starts the connection and NetworkManager only 'manages' it once started (thinking ifupdown for example). But even it that is the case, it would be the case on every other Gnome distro as well and I have never had this problem anywhere else, only on this machine with these two distros.

It will probably always remain a mystery, but at least the workround is simple and effective.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: LMDE problem or my problem?

Postby sgosnell on Mon Mar 14, 2011 10:51 am

You might want to check your Startup Applications and see what is being run at startup.
Asus eee-pc 900 w/ 32GB SSD.
sgosnell
Level 5
Level 5
 
Posts: 686
Joined: Fri Sep 10, 2010 9:32 pm
Location: Baja Oklahoma

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 4 guests