Dependency problems with gstreamer0.10-pitfdll.

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Dependency problems with gstreamer0.10-pitfdll.

Postby elav on Fri Mar 18, 2011 4:06 pm

Greetings. Apparently this package comes with the installation of LMDE, but Synaptic puts me at local or obsolete. This package is only found in the repositories of Debian Lenny and Debian Sid, and yesterday I inadvertently uninstalled it, deleting it mint-meta-debian and mint-meta-codecs.

Is it necessary to include this package into the repository LMDE? I think so.
User avatar
elav
Level 2
Level 2
 
Posts: 97
Joined: Tue Oct 26, 2010 11:27 am
Location: /var/www/mint-forum

Linux Mint is funded by ads and donations.
 

Re: Dependency problems with gstreamer0.10-pitfdll.

Postby rivenathos on Fri Mar 18, 2011 4:13 pm

This package was removed by the Debian folks just before Squeeze was released as stable. It conflicted with something else, but I do not remember what it was. Since LMDE was released before this happened, the gstreamer0.10-pitfdll package was already included. It is not found in the stable release of Debian 6 at all. This is a 32-bit package only.
Debian 7 with GNOME 64-bit
User avatar
rivenathos
Level 6
Level 6
 
Posts: 1066
Joined: Wed May 06, 2009 7:32 am
Location: USA

Re: Dependency problems with gstreamer0.10-pitfdll.

Postby elav on Fri Mar 18, 2011 4:19 pm

rivenathos wrote:This package was removed by the Debian folks just before Squeeze was released as stable. It conflicted with something else, but I do not remember what it was. Since LMDE was released before this happened, the gstreamer0.10-pitfdll package was already included. It is not found in the stable release of Debian 6 at all. This is a 32-bit package only.


Thus it would be good to include in the repositories of LMDE or otherwise, is removed as a dependency of packages mint-meta-debian and mint-meta-codecs
User avatar
elav
Level 2
Level 2
 
Posts: 97
Joined: Tue Oct 26, 2010 11:27 am
Location: /var/www/mint-forum

Re: Dependency problems with gstreamer0.10-pitfdll.

Postby rivenathos on Fri Mar 18, 2011 4:26 pm

Yes, you have experienced one of the drawbacks to using metapackages. That issue has been discussed a few times already in the forum. There are workarounds.

As for the gstreamer codec, one of the Mint developers will need to express a view on what to do with this discrepancy. The next spin (x3) of LMDE will certainly have this sorted out.

I had not noticed this in my LMDE since I only use 64-bit, but I was aware that the gstreamer codec had been removed in 32-bit Debian 6.
Debian 7 with GNOME 64-bit
User avatar
rivenathos
Level 6
Level 6
 
Posts: 1066
Joined: Wed May 06, 2009 7:32 am
Location: USA

Re: Dependency problems with gstreamer0.10-pitfdll.

Postby elav on Fri Mar 18, 2011 4:32 pm

Well, then we can only hope that some developer or team repositories, hear our prayer. :D
User avatar
elav
Level 2
Level 2
 
Posts: 97
Joined: Tue Oct 26, 2010 11:27 am
Location: /var/www/mint-forum

Re: Dependency problems with gstreamer0.10-pitfdll.

Postby hzsolt94 on Fri Apr 08, 2011 11:45 am

hzsolt94
Level 1
Level 1
 
Posts: 5
Joined: Fri Apr 01, 2011 11:00 am


Return to Newbie Questions

Who is online

Users browsing this forum: Google Adsense [Bot] and 9 guests