[SOLVED] shutdown not working?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

[SOLVED] shutdown not working?

Postby mockturtl on Sun Mar 27, 2011 11:37 pm

2.6.32-5-amd64, plain old wheezy

Since a recent upgrade (Thursday 3/24/2011, early evening EDT/-0400 UTC), restarting from mintmenu "Quit" does not fully reboot the system. X stops, and I see the runlevel 6 shutdown messages... and then services immediately restart, without kicking me back to the BIOS splash and GRUB.

I get the same behavior with
Code: Select all
# shutdown -r now


I have to power down to see a "full" reboot.

Any guesses what might be responsible? Are other people seeing it?
Last edited by mockturtl on Mon Mar 28, 2011 10:09 am, edited 1 time in total.
Image
User avatar
mockturtl
Level 4
Level 4
 
Posts: 442
Joined: Sat Oct 09, 2010 8:51 pm

Linux Mint is funded by ads and donations.
 

Re: shutdown not working?

Postby richyrich on Mon Mar 28, 2011 2:13 am

Nope, won't even guess. You may find something related by seeing which files were updated on that date. Either view>history in Mint's Update Manger, or file>history in Synaptic. Anything look suspicious ?
User avatar
richyrich
Level 13
Level 13
 
Posts: 4779
Joined: Mon May 04, 2009 8:31 pm
Location: Pirating somewhere along the North Saskatchewan River, Canada

Re: shutdown not working?

Postby lepadatu.lucian on Mon Mar 28, 2011 3:46 am

Look for "kexec" in Synaptic to see whether you have it installed or not. I use the unstable(sid) repositories and a few weeks ago it was automatically installed during an update. Kexec allows "live" booting of a new kernel "over" the currently running kernel, avoiding a full reboot.

So you can simply remove it and the restart button will work like before.
lepadatu.lucian
Level 1
Level 1
 
Posts: 10
Joined: Sat Jan 08, 2011 4:03 am
Location: Romania

Re: shutdown not working?

Postby exploder on Mon Mar 28, 2011 4:22 am

Thanks lepadatu.lucian! I just installed Mint Debian and put on over 700 updates... I could reboot but it was slow and showed gdm before rebooting, removing kexec solved the problem. Thanks again! :)
exploder
Level 15
Level 15
 
Posts: 5913
Joined: Tue Feb 13, 2007 10:50 am
Location: HartfordCity, Indiana USA

Re: shutdown not working?

Postby lepadatu.lucian on Mon Mar 28, 2011 5:56 am

You welcome :)
lepadatu.lucian
Level 1
Level 1
 
Posts: 10
Joined: Sat Jan 08, 2011 4:03 am
Location: Romania

Re: shutdown not working?

Postby mockturtl on Mon Mar 28, 2011 10:08 am

There she is, right on schedule.

Fix:
Code: Select all
# apt-get remove kexec-tools


Thanks guys!
Image
User avatar
mockturtl
Level 4
Level 4
 
Posts: 442
Joined: Sat Oct 09, 2010 8:51 pm


Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 4 guests