LMDE mintMenu shortcut issue

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

LMDE mintMenu shortcut issue

Postby feffer on Mon Apr 11, 2011 7:30 pm

A few months ago, I installed LMDE 32-bit on a newish desktop. Mostly everything worked and was configured as I liked. Not being one to leave well enough alone, I installed LMDE 64-bit over it, but kept the /home and it's config files from the earlier install. Now I'm finding it impossible to change the mintMenu shortcut to <Alt>Space (which I like for personal reasons). This worked on the 32-bit version but I can't get it to work on LMDE 64-bit even after a reboot.

I thought maybe there was an issue with the config files pulled from the 32-bit version, so I deleted ".linuxmint" and let it rebuild, but that did not help. I do not see any shortcut conflicts in compiz or metacity with <Alt>Space either.

Are there other config files that I should delete/rebuild? Could this be a 64-bit version issue? I doubt this, but if someone running 64-bit LMDE can change his/her mintMenu shortcut, please let me know. Any other ideas about this?

thx,
feffer
feffer
Level 3
Level 3
 
Posts: 147
Joined: Mon Jul 07, 2008 7:49 pm

Linux Mint is funded by ads and donations.
 

Re: LMDE mintMenu shortcut issue

Postby Silent Warrior on Tue Apr 12, 2011 12:36 pm

Have you tried right-clicking the menu and going into Properties? It gives you the option to change the keyboard shortcut.
Silent Warrior
Level 4
Level 4
 
Posts: 464
Joined: Mon Aug 24, 2009 1:10 pm
Location: Göteborg, Sverige

Re: LMDE mintMenu shortcut issue

Postby feffer on Tue Apr 12, 2011 4:34 pm

Have you tried right-clicking the menu and going into Properties? It gives you the option to change the keyboard shortcut.
Yes. My desired shortcut <Alt>Space is accepted and remains the "preference" after rebooting, but does nothing. As I mentioned in the first post, doing this on the 32-bit LMDE activated my desired shortcut properly, but for some reason does not work on the 64-bit version.

I might add that going back to the default <Ctl>Super_L and rebooting DOES get mintMenu to pop up. So why not just use the default? I work on several different OSes -- 3-4 linux ones, Mac OS X, and 2 versions of Windows -- so keeping many different sets of shortcuts straight is an issue. The <Atl>Space keys are in the same place on Mint and Mac (Cmd-Space on the Mac, but the same physical location). So using this shortcut really does make sense to me. And it ought to work -- so I'd like to figure out why it doesn't.

If anyone who's running LMDE 64-bit could test this on his/her system, it would be greatly appreciated. It would tell me whether this is a specific issue with my system, or a general bug with mintMenu on 64-bit LMDE.

thx,
feffer
feffer
Level 3
Level 3
 
Posts: 147
Joined: Mon Jul 07, 2008 7:49 pm

Re: LMDE mintMenu shortcut issue

Postby Silent Warrior on Wed Apr 13, 2011 4:24 pm

I've tested this, and I verify the issue. I don't know if this has anything to do with anything, but with a window open, Alt-Space tends to open the windowmanager menu. The one you get when you right-click the titlebar.
It's possible I didn't enter the shortcut correctly, though - but maybe you could try specifying that you want the left Alt-key in the shortcut?
Silent Warrior
Level 4
Level 4
 
Posts: 464
Joined: Mon Aug 24, 2009 1:10 pm
Location: Göteborg, Sverige

Re: LMDE mintMenu shortcut issue

Postby feffer on Wed Apr 13, 2011 4:52 pm

thx for testing it. On my LMDE system, if the mintMenu default <Ctl>Super_L is used, then <Alt>Space does NOT open the window menu -- it does nothing (indicating there is no conflict with an existing action). On Ubuntu <Atl>Space by default DOES open the window menu.

In any case, perhaps there really IS an issue with mintMenu, or at least the key-binding code on the 64-bit edition. Guess a bug-report is the next step.

thx again.
feffer
Level 3
Level 3
 
Posts: 147
Joined: Mon Jul 07, 2008 7:49 pm


Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 3 guests