Failed to fetch

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

Failed to fetch

Postby tec_wiz on Wed Apr 13, 2011 9:12 am

Hello,

When i run mint update I get hte follwing error:

W: Failed to fetch http://packages.ikey-doherty.com/dists/debian/Inrelease

W: Failed to fetch http://packages.ikey-doherty.com/dists/ ... elease.gpg Could not resolve 'packages.ikey-doherty.com'

W: Some index files failed to download. They have been ignored, or old ones used instead.


Can someone please help me get rid of this issue.

Thnaks.
tec_wiz
Level 1
Level 1
 
Posts: 38
Joined: Tue Oct 12, 2010 8:43 am

Linux Mint is funded by ads and donations.
 

Re: Failed to fetch

Postby mzsade on Wed Apr 13, 2011 9:32 am

Maybe some dependency issue. Don't use Mint update, if at all you have this compulsion to update :wink: do it from Synaptic. The upgradable packages will be marked with a star. It could be a little tedious marking them one by one (unless you have a Mark all upgrades button), but it's a lot safer that way.
Linux User #481272 Reg: 15th Sept., 2008
mzsade
Level 5
Level 5
 
Posts: 617
Joined: Sun Jul 19, 2009 4:36 am

Re: Failed to fetch

Postby tec_wiz on Wed Apr 13, 2011 10:13 am

I get the same error in Synaptic and the terminal.
tec_wiz
Level 1
Level 1
 
Posts: 38
Joined: Tue Oct 12, 2010 8:43 am

Re: Failed to fetch

Postby mzsade on Wed Apr 13, 2011 11:21 am

Okay, something like this has been posted here somewhere, open Update Manager>>View>>History of Updates. Write down the names of all the packages that you last updated, close update manager. Then open Synaptic and remove the packages that you had written the names of. Then reinstall them again from Synaptic. Hopefully, they will be installed correctly with all the dependencies. Hope it works for you.
Linux User #481272 Reg: 15th Sept., 2008
mzsade
Level 5
Level 5
 
Posts: 617
Joined: Sun Jul 19, 2009 4:36 am

Re: Failed to fetch

Postby CiaW on Wed Apr 13, 2011 11:34 am

I would suspect it means that you've enabled a repo that no longer exists, or added it to your /etc/apt/sources.list file. I opened mint update and got an error about an md5 mismatch but nonetheless, for your issue what you can do after the error is let it bring up mint update, click on >Edit and select >software sources then select the third party software tab and see if there's one selected that matches packages.ikey-doherty.com and unselect it. Hopefully that fixes it, then you can refresh and it'll hopefully work.

If not, try a search of the forums for something like packages.ikey and it should bring up the thread where someone else had that issue.
CiaW
Level 3
Level 3
 
Posts: 170
Joined: Fri Sep 10, 2010 11:39 am
Location: Spokane Wash, USA

Re: Failed to fetch

Postby tec_wiz on Wed Apr 13, 2011 1:37 pm

mzsade wrote:
CiaW wrote:I would suspect it means that you've enabled a repo that no longer exists, or added it to your /etc/apt/sources.list file. I opened mint update and got an error..

Mod: Edited for foul-language content..



I have to say this is by far the most unneccessary post I have ever seen and I don't know why you felt the need to attack me that way. I'm going to assume you're having a bad day and leave it at that.

Second, thanks CiaW on that. i should have thought about that, but I didn't think I have added any additional repos and were using the stock LMDE repos. But yes, it does seem that there is an issue with this repo now. I will look through it and see why I might have added it, it's possible that this repo just stopped working for whatever reason. I might have added it to get my Nvidia card working back in September, I don't remember.

Thanks for the help, I really appreciate it. I'll post if this isn't a good fix.
tec_wiz
Level 1
Level 1
 
Posts: 38
Joined: Tue Oct 12, 2010 8:43 am

Re: Failed to fetch

Postby tec_wiz on Wed Apr 13, 2011 1:49 pm

I remembered why I added the repo. It was to get emerald. Here is the original posting by ikey that got me to add it.

viewtopic.php?f=141&t=55342
tec_wiz
Level 1
Level 1
 
Posts: 38
Joined: Tue Oct 12, 2010 8:43 am

Re: Failed to fetch

Postby mzsade on Wed Apr 13, 2011 2:17 pm

I most humbly thank the mods for the leniency they have shown me and apologize to tec_wtz for my profane language, it was in no way personal, i don't know what to say, i am a pathetic and bitter bitter man..i hope not to be taking such liberties in future.

Thanks,
mzsade
Linux User #481272 Reg: 15th Sept., 2008
mzsade
Level 5
Level 5
 
Posts: 617
Joined: Sun Jul 19, 2009 4:36 am

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 2 guests