Hibernation (Again)

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Hibernation (Again)

Postby Skinnx86 on Wed Apr 13, 2011 3:21 pm

Hello Mint Lovers,

I had a small issue with Hibernation and Suspend not working, but looking through the forums and using google I have managed to get hibernation to work fully (including resuming the graphics). I did this by adding

Code: Select all
/dev/sda5 swap   swap   pri=42   0 0

to fstab. But now when I boot, I notice that I get "Activating swap... Failed" but further down "Activating Swapfile Swap...... Done" in the boot sequence messages (before the Logon Screen). If I remove the above line from fstab I then get "Loading Swap...Done" at boot, but then I can not hibernate.

I have tried
Code: Select all
sudo gedit /var/log/boot

but the file was blank and
Code: Select all
sudo gedit /var/log/messages

does not have the boot sequence messages to study. What makes this an odd issue is that my swapfile is working ok as I have checked the System Monitor.

I guess this means there is no point in worrying, but I thought that I would share this with the community and with any luck some one will fill me in and some others may be able to fix their hibernation issues. :mrgreen:

On the other hand this has not solved Suspend not working. I have looked into uswsusp but have not implemented it, as I now have hibernation working fully. I have included lspci and lsusb in case anyone needs it.

Code: Select all
skinna@mintdebianskinna ~ $ lspci
00:00.0 Host bridge: Intel Corporation 82855PM Processor to I/O Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 82855PM Processor to AGP Controller (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 01)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV250 [Mobility FireGL 9000] (rev 02)
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5705M Gigabit Ethernet (rev 01)
02:01.0 CardBus bridge: O2 Micro, Inc. OZ711EC1 SmartCardBus Controller (rev 20)
02:01.1 CardBus bridge: O2 Micro, Inc. OZ711EC1 SmartCardBus Controller (rev 20)
02:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)


Code: Select all
skinna@mintdebianskinna ~ $ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 045e:071f Microsoft Corp.
Bus 001 Device 003: ID 0bb4:0ff9 High Tech Computer Corp. Desire / Hero
My partner banned me dual booting linux on her desktop due to it being too much hassle. Stuck LMDE in a VM, now she has no choice...;-)
Skinnx86
Level 1
Level 1
 
Posts: 15
Joined: Wed Apr 13, 2011 2:31 pm

Linux Mint is funded by ads and donations.
 

Re: Hibernation (Again)

Postby mads on Thu Apr 14, 2011 10:08 am

Hi Skinnx86

Check if Resume line in "/etc/initramfs-tools/conf.d/resume" file is commented out:
gksudo gedit /etc/initramfs-tools/conf.d/resume
If yes, like this
#RESUME=UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
then add the following line
RESUME=/dev/sda5

Then run:
sudo update-initramfs -u
followed by reboot.

See if you can suspend.

PS! You also said: "I have tried sudo gedit /var/log/boot but the file was blank".
This is because boot logging is off by default. To enable it:
gksudo gedit /etc/default/bootlogd
change
BOOTLOGD_ENABLE=No
to
BOOTLOGD_ENABLE=Yes
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: Hibernation (Again)

Postby Skinnx86 on Thu Apr 14, 2011 4:03 pm

Thanks mads,

I now have boot log working but unfortunately still no suspend, even after initramfs update and reboot. :(
My partner banned me dual booting linux on her desktop due to it being too much hassle. Stuck LMDE in a VM, now she has no choice...;-)
Skinnx86
Level 1
Level 1
 
Posts: 15
Joined: Wed Apr 13, 2011 2:31 pm

Re: Hibernation (Again)

Postby mads on Thu Apr 14, 2011 5:10 pm

Skinnx86 wrote:I now have boot log working but unfortunately still no suspend, even after initramfs update and reboot. :(

If you are willing to change "/dev/sda5 swap swap pri=42 0 0" (which only makes sense for systems having multiple swaps),
you could try the following sequence (I cannot guarantee but if successful will make both hibernate and suspend work):
1) sudo swapoff /dev/sda5

2) sudo mkswap /dev/sda5
The output also shows the UUID for your swap
... UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

3) gksudo gedit /etc/fstab
Your swap line should look like this (comment out the old entry)
UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx swap swap sw 0 0

4) gksudo gedit /etc/initramfs-tools/conf.d/resume
Your Resume line should look like this (comment out the old entry/entries)
RESUME=UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

5) sudo swapon UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

6) sudo update-initramfs -u

7) Reboot
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: Hibernation (Again)

Postby Skinnx86 on Fri Apr 15, 2011 1:51 pm

It worked to some degree. As in, "Activating Swap...Failed" at boot is now replaced with "Activating Swap...Done". But I still can not suspend. Hibernate still works though. FYI when I Hibernate my machine's screen goes black (but not off) for a while - I presume it is saving the current state - then turns off. When I choose to put my machine into suspend it does not seam to do this, but to turn off the machine nearly instantly. When I switch it on the screen comes on but stays black and all I can do it hold the power button until it switches off.

I did realize that "pri=42 0 0" was for multiple swaps but seaming as it worked for hibernation (and I like the idea of the ultimate answer to Life, The Universe and Everything in my fstab file 8) ), I left it alone.
My partner banned me dual booting linux on her desktop due to it being too much hassle. Stuck LMDE in a VM, now she has no choice...;-)
Skinnx86
Level 1
Level 1
 
Posts: 15
Joined: Wed Apr 13, 2011 2:31 pm

Re: Hibernation (Again)

Postby mads on Fri Apr 15, 2011 3:23 pm

Skinnx86 wrote:It worked to some degree. As in, "Activating Swap...Failed" at boot is now replaced with "Activating Swap...Done". But I still can not suspend. Hibernate still works though. FYI when I Hibernate my machine's screen goes black (but not off) for a while - I presume it is saving the current state - then turns off. When I choose to put my machine into suspend it does not seam to do this, but to turn off the machine nearly instantly. When I switch it on the screen comes on but stays black and all I can do it hold the power button until it switches off.

I did realize that "pri=42 0 0" was for multiple swaps but seaming as it worked for hibernation (and I like the idea of the ultimate answer to Life, The Universe and Everything in my fstab file 8) ), I left it alone.

In other words, back to the very beginning. :lol:

Sorry Skinnx86, I had great hopes for this. It must be a model specific issue, very strange.

The ultimate answer to Life is the best. Me and a few friends had great fun with '42' for quite a long time.
Please please make every thing exactly as it was in the beginning, ... pri=42 0 0 :lol:
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: Hibernation (Again)

Postby Skinnx86 on Fri Apr 15, 2011 7:27 pm

:D I glad I made someones day! And thank you for the quick and precise responses. It is and old - at least 5 or 6 years - Dell D600, I'm just glad it bested my mates M$:W7 / Quad Core / 3GB RAM in loading Engadget. And tied it in overall boot time, but that is only because I had to select LMDE in Grub. As I said in my initial post,
I guess this means there is no point in worrying, but I thought that I would share this with the community and with any luck some one will fill me in and some others may be able to fix their hibernation issues. :mrgreen:


In other words, back to the very beginning. :lol:

Ah. Not quite. I don't have "Activating Swap...Failed" any more, so i'm not sure I should change it back (I still have "pri=42 0 0 "
commented out! although admittedly it does not have as much "geek-cred" 8) ) Do you really think it would be better though?
I may change it if anything breaks - or I could change back, backup, the switch back again, in case of a fault.
My partner banned me dual booting linux on her desktop due to it being too much hassle. Stuck LMDE in a VM, now she has no choice...;-)
Skinnx86
Level 1
Level 1
 
Posts: 15
Joined: Wed Apr 13, 2011 2:31 pm

Re: Hibernation (Again)

Postby mads on Fri Apr 15, 2011 10:42 pm

Skinnx86 wrote:Ah. Not quite. I don't have "Activating Swap...Failed" any more, so i'm not sure I should change it back (I still have "pri=42 0 0 "
commented out! although admittedly it does not have as much "geek-cred" 8) ) Do you really think it would be better though?
I may change it if anything breaks - or I could change back, backup, the switch back again, in case of a fault.

I was afraid that you had deleted pri=42 from fstab. If it is commented out, then leave it as it is until someone comes with
the ultimate answer. (Sorry, couldn't help myself.) :lol:
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: Hibernation (Again)

Postby Skinnx86 on Sat Apr 16, 2011 6:13 am

No need to apologise, I probably would of said something simalar! :D.

Sent using my HTC Wildfire and Dolphin HD Browser.
No tapatalk for me! (yet), just full LM Forum goodness!! :mrgreen:
My partner banned me dual booting linux on her desktop due to it being too much hassle. Stuck LMDE in a VM, now she has no choice...;-)
Skinnx86
Level 1
Level 1
 
Posts: 15
Joined: Wed Apr 13, 2011 2:31 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 6 guests