FAT32 in fstab and changing permissions [SOLVED]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

FAT32 in fstab and changing permissions [SOLVED]

Postby caris_mere on Thu May 12, 2011 4:31 am

I installed LMDE and added my FAT32 during installation. My problem is that I can't write to the FAT32 partition in LMDE as a normal user. Only root can make changes. I tried using chmod to change the permission, with no avail (permissions remained unchanged). I tried using chown to change the owner or add my user to the groups, but nothing changed there either (said the operation wasn't permitted). I don't know how to the change fstab to mount the partition so that it can be accessed and changed by users other than root. Here is the fstab entry for the partition.

UUID=F950-B4CD /media/shared vfat rw,errors=remount-ro 0 0

Thanks for your help.

Scott
Last edited by caris_mere on Mon May 16, 2011 2:33 pm, edited 1 time in total.
caris_mere
Level 2
Level 2
 
Posts: 88
Joined: Tue May 20, 2008 8:49 am
Location: Texan in Switzerland

Linux Mint is funded by ads and donations.
 

Re: FAT32 in fstab and changing permissions

Postby altair4 on Thu May 12, 2011 6:24 am

That line in fstab is doing exactly what you told it to. By default vfat will mount with owner = root and permissions allowing root to read / write and everyone else to read only. To fix that:

Code: Select all
UUID=F950-B4CD /media/shared vfat defaults,utf8,umask=000 0 0


umask=000 will enable everyone to read and write to the partition.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6131
Joined: Tue Feb 03, 2009 10:27 am

Re: FAT32 in fstab and changing permissions

Postby caris_mere on Thu May 12, 2011 10:33 am

I figured it was doing what it said, but that was what was set up by default and not by me. Thanks for the tip to get it fixed.
caris_mere
Level 2
Level 2
 
Posts: 88
Joined: Tue May 20, 2008 8:49 am
Location: Texan in Switzerland


Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 6 guests