LMDE: How do I reset to default font scheme?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

LMDE: How do I reset to default font scheme?

Postby r2rX on Sun Jun 05, 2011 7:15 pm

Hey guys,

There was a tweak to "better improve" the default font scheme of LMDE. The code was pasted into a document called .font.conf placed in the Home folder. Suffice to say, I didn't like it. However, I do not know how to restore the default font scheme. I erased the document and tried setting the fonts in the Fonts section...didn't help.

Is there a way to reset this? I know alot of people might not find the default scheme good, but I like it.

All the help is appreciated.

r2rX :)
r2rX
Level 1
Level 1
 
Posts: 36
Joined: Thu Dec 31, 2009 4:36 pm

Linux Mint is funded by ads and donations.
 

Re: LMDE: How do I reset to default font scheme?

Postby vrkalak on Sun Jun 05, 2011 7:35 pm

If you removed/delete the ~/.font.config file > it is gone.

The only way would be to have someone give you the default ~/.font.config script, then you could add it back to the proper place.

Remember, in the future, always make a back-up file of every file/script you change.

I'm not using LMDE, at the moment, or I'd send it to you.
Image
:: LinuxMint-Debian-Edition (Fluxbox) :: Manjaro/Arch (Xfce) ::
Registered Linux User: #497031 :: DeviantART Page
User avatar
vrkalak
Level 10
Level 10
 
Posts: 3381
Joined: Mon Jul 20, 2009 5:53 pm
Location: Santa Fe, NM, USA

Re: LMDE: How do I reset to default font scheme?

Postby r2rX on Mon Jun 06, 2011 5:24 am

That's the thing.....there wasn't a .font.conf file initially. That's why I thought that, perhaps, after deleting the file I made, it would restore the fonts. Maybe a live boot might produce one that I can use...i'll test.

r2rX :)
r2rX
Level 1
Level 1
 
Posts: 36
Joined: Thu Dec 31, 2009 4:36 pm

Re: LMDE: How do I reset to default font scheme?

Postby r2rX on Wed Jun 08, 2011 12:47 pm

Alright, I tried copying the fonts.conf from a live boot and replacing all of them on my installation...it didn't work. But I ended up reinstalling LMDE anyway....so i'm not messing around with this again.

Although, if anyone knows how to correct such an issue it'll be good to post it.

Thanks, vrkalak.

r2rX :)
r2rX
Level 1
Level 1
 
Posts: 36
Joined: Thu Dec 31, 2009 4:36 pm

Re: LMDE: How do I reset to default font scheme?

Postby r2rX on Thu Jun 16, 2011 4:03 pm

Hey guys,

I don't know if this is a bug (or my incompetence) but the font scheme is messed up again.

On the desktop, I went to 'Change Desktop Background'- > 'Font'. At the bottom is a series of 'Rendering' options; Monochrome, Best shapes, Best contrast and Subixel smoothing (LCDs). None of them were enabled, so I clicked on Subpixel smoothing. The moment I did that, it chaned my font scheme....and I can't seem to set it back. I haven't changed any of the fonts, didn't touch any scripts....it's really unpleasent now.

Any advice on how to get it to root/default Mint font settings?

I really wanna fix this....

r2rX :(
r2rX
Level 1
Level 1
 
Posts: 36
Joined: Thu Dec 31, 2009 4:36 pm

Re: LMDE: How do I reset to default font scheme?

Postby lasm2000 on Tue Jun 21, 2011 6:52 pm

I offer no solution. Just stating that I have the same problem as above's post. I selected subpixel hinting in the gnome options and inmediately got a set of thin and not so nice looking fonts. :(

Any way to restore the default font rendering? Other than the gnome panel that I mentioned I haven't touched to fonts config files.
lasm2000
Level 1
Level 1
 
Posts: 4
Joined: Fri Jun 17, 2011 4:06 pm

Re: LMDE: How do I reset to default font scheme?

Postby like45ninjas on Thu Mar 08, 2012 2:59 am

r2rX wrote:Hey guys,

I don't know if this is a bug (or my incompetence) but the font scheme is messed up again.

On the desktop, I went to 'Change Desktop Background'- > 'Font'. At the bottom is a series of 'Rendering' options; Monochrome, Best shapes, Best contrast and Subixel smoothing (LCDs). None of them were enabled, so I clicked on Subpixel smoothing. The moment I did that, it chaned my font scheme....and I can't seem to set it back. I haven't changed any of the fonts, didn't touch any scripts....it's really unpleasent now.

Any advice on how to get it to root/default Mint font settings?

I really wanna fix this....

r2rX :(

I hate to revive an old thread... but this is exactly what happened to me right now on the most recent version of lmde. Does anbody know a solution to his problem?
like45ninjas
Level 1
Level 1
 
Posts: 3
Joined: Thu Mar 08, 2012 1:06 am

Re: LMDE: How do I reset to default font scheme?

Postby alanmoore on Thu May 31, 2012 4:44 am

Hey, guys! A related question was posted and discussed in this forums and it helped me solve this issue. Credit to Nathan from Programhalla for finding the solution and Mint forum member 'squeezy' for posting it.

viewtopic.php?f=201&t=94378&p=544407&hilit=fonts#p544407

You basically have to follow this tutorial:

http://noz3001.wordpress.com/2011/07/01 ... an-wheezy/

but downloading the .deb file you have to extract directly from LMDE repositories instead of Ubuntu's. Here's the download link:

http://packages.linuxmint.com/pool/upst ... u3_all.deb

Configuring your fonts as in the screenshot is particularly important, especially the slight hinting part.

And that's it. It worked for me after I screwed up.

Regards.
alanmoore
Level 1
Level 1
 
Posts: 14
Joined: Sun Oct 18, 2009 9:19 am

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 7 guests