LMDE Acting strange

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

LMDE Acting strange

Postby godsotherhand on Thu Jun 30, 2011 1:33 pm

I am having some problems with my LMDE.. dont know when they started, as i dont usually go in my computer directory, but these problems werent there when i first installed it!

When i dowble-click on my Computer icon on the desktop, my desktop freezes for almost 1 minute, and only after that my file manager kicks in, and everything is fine.
Aplications that are opened work fine, just that my desktop freezes. Also i see that my hdd is not working to fetch data, so no idea why this freeze..


Also, it seems that LMDE sees a floppy and a CDrom drive even though my laptop does not have a floppy or a cdrom. Also, when i attach a USB drive, it doesnt show up..

After a reboot, my Computer loads just fine, my USB drives show up, and there is no floppy/cdrom drive anymore.
godsotherhand
Level 4
Level 4
 
Posts: 271
Joined: Tue Mar 22, 2011 12:43 pm

Linux Mint is funded by ads and donations.
 

Re: LMDE Acting strange

Postby godsotherhand on Mon Jul 18, 2011 4:17 am

Bump..
godsotherhand
Level 4
Level 4
 
Posts: 271
Joined: Tue Mar 22, 2011 12:43 pm

Re: LMDE Acting strange

Postby SimonTS on Mon Jul 18, 2011 4:47 am

Didn't catch this first time round.

All I can suggest at the moment is that, when it freezes and then unfreezes itself, you load up the "Log file viewer" under "System tools" and have a look in there to see if there is anything strange logged. Also, have a look at your /etc/fstab file and see if there are any references in there to a floppy or CD drive.
User avatar
SimonTS
Level 6
Level 6
 
Posts: 1272
Joined: Thu Feb 24, 2011 5:19 pm
Location: Bristol, United Kingdom

Re: LMDE Acting strange

Postby Dr.m0x on Mon Jul 18, 2011 6:18 am

Yes for some unknown reason the lmde installer creates references to /dev/sr0 and /dev/fd0 (cd drive and floppy) even if they are not present.
You can safely delete these two lines from /etc/fstab

Sent from my Cyanogenmod 7 phone.
Image
User avatar
Dr.m0x
Level 3
Level 3
 
Posts: 117
Joined: Thu Nov 25, 2010 4:12 am

Re: LMDE Acting strange

Postby SimonTS on Mon Jul 18, 2011 6:55 am

Mine didn't put an entry to floppy, although it did for my CD drive correctly. It did, however, put double entries (different) for 'proc' as well as creating 2nd entried for both / and swap on sda1 and 2 (both incorrect for my system). I assumed this is just part of the generic Debian installer issue that Clem has been working on and which also affected Liquid Lemur's installer if you chose not to let the installer create GRUB on the MBR.
Annoying, but not fatl to my install. Not so good for a newbie though.
User avatar
SimonTS
Level 6
Level 6
 
Posts: 1272
Joined: Thu Feb 24, 2011 5:19 pm
Location: Bristol, United Kingdom

Re: LMDE Acting strange

Postby godsotherhand on Mon Jul 18, 2011 8:14 am

I did delete the entryes for the cd and floppy, but the problem is the same: my computer takes ages to load up, it wont recognise USB and it even wont see the second partition (it has windows installed on that), only difference is i dont see floppy + cdrom anymore.

After that, i tryed booting without my 3G modem and it works ok(abit tricky to get modem to work this way tho).. Tryed with an older kernel and it works ok even with the device pluged in.. So it's abit confusing for me, but it might be a kernel problem?

Tryed reinstalling the driver, and during the installation, i get a "NDIS driver failed" error.. Google only returned to me results regarding windows.. :(

The modem is a Huawei E173.

Anyway i can get it to work good under the new kernel? Or im gonna have to stick to the old one?
godsotherhand
Level 4
Level 4
 
Posts: 271
Joined: Tue Mar 22, 2011 12:43 pm

Re: LMDE Acting strange

Postby Dr.m0x on Mon Jul 18, 2011 10:19 pm

Best to keep on the old one if it works for you. Sometimes regressions happen, unfortunately.

Sent from my Cyanogenmod 7 phone.
Image
User avatar
Dr.m0x
Level 3
Level 3
 
Posts: 117
Joined: Thu Nov 25, 2010 4:12 am

Re: LMDE Acting strange

Postby Roken on Tue Jul 19, 2011 7:24 am

There's a common misconception amongst new users that you [i]must[i] be running the latest kernel for full functionality, though this is not the case. Kernel versions 2.6.37 onwards represent some quite significant changes to the kernel that do inevitably break some hardware in some combinations. Following some discussions on IRC the consensus seems to be that kernel 2.6.36 is the last fully stable kernel (and in fact, for similar reasons, is the kernel that I use on a day to day basis). I can patch later kernels to remove some of the problems, but not all of them.

The bottom line is, if you have found a kernel that works with your system, use that one. There's nothing to stop you installing updated kernels alongside the working kernel as they come along to see if your problems are fixed. If not, then simply continue using the working kernel.
Kernel Linux Tex 3.2.2-1 (64 bit) xfce , burg
Arch
ATI Radeon HD 4670, 1GB
OSS4
AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked)
8Gb RAM
Image
User avatar
Roken
Level 5
Level 5
 
Posts: 747
Joined: Fri Nov 19, 2010 4:55 pm
Location: Oldham, UK

Re: LMDE Acting strange

Postby ukbrian on Tue Jul 19, 2011 10:54 pm

@Roken +1
the consensus seems to be that kernel 2.6.36 is the last fully stable kernel (and in fact, for similar reasons, is the kernel that I use on a day to day basis).
I've got one LMDE install left with the 2.6.37 kernel :D
Unfortunately If you do a fresh install now you can only upgrade to the 2.6.39 kernel, do you know of a way to get the .36/.37 kernels?

I just tried out pclinuxpc running KDE which I've never taken to but it surprised me, well impressed which is odd as I like basic functional things not bling.

It installed with 2.6.39 on it but it was simple to go back to the earlier kernels, it seems to be very solid & stable and I am able to customize the menus and desktop to my liking. KDE doesn't have the drop down launchers you can put in the panel like on Xfce but I can live with that.

I don't understand why folk are still using Gnome!!!, I only used Gnome until quite recently but with gnome possibly becoming very unstable during the transition from 2. to 3. and not liking the direction it's going in at all I tried Xfce and really liked it but this pclinuxos looks like the one I'm going to run as my stable OS and as a bonus you can make an installable ISO of your OS and easily transfer to another machine.

Whoops! I'm beginning to sound like a fanboy :oops:
ukbrian
User avatar
ukbrian
Level 4
Level 4
 
Posts: 276
Joined: Thu Jul 29, 2010 6:03 am
Location: Cheltenham, UK

Re: LMDE Acting strange

Postby Roken on Tue Jul 19, 2011 11:16 pm

You can pick up some of the previous kernels here - http://www.icewalkers.com/Linux/Softwar ... l-2.6.html
Kernel Linux Tex 3.2.2-1 (64 bit) xfce , burg
Arch
ATI Radeon HD 4670, 1GB
OSS4
AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked)
8Gb RAM
Image
User avatar
Roken
Level 5
Level 5
 
Posts: 747
Joined: Fri Nov 19, 2010 4:55 pm
Location: Oldham, UK

Re: LMDE Acting strange

Postby godsotherhand on Wed Jul 20, 2011 3:34 am

Roken wrote:There's a common misconception amongst new users that you [i]must[i] be running the latest kernel for full functionality

I thought the newer kernel would have better power management, faster boot time, and so on..
godsotherhand
Level 4
Level 4
 
Posts: 271
Joined: Tue Mar 22, 2011 12:43 pm

Re: LMDE Acting strange

Postby ukbrian on Wed Jul 20, 2011 4:53 am

check this out
Without further ado, the biggest cause of the 2.6.38 power issue (according to my testing software and the hardware I've been running) is due to a change in behavior regarding ASPM. ASPM is the Active-State Power Management for PCI Express. Namely, to blame is commit 2f671e2dbff6eb5ef4e2600adbec550c13b8fe72 that is titled "PCI: Disable ASPM if BIOS asks us to."
http://www.phoronix.com/scan.php?page=article&item=linux_2638_aspm&num=2
User avatar
ukbrian
Level 4
Level 4
 
Posts: 276
Joined: Thu Jul 29, 2010 6:03 am
Location: Cheltenham, UK

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 6 guests