[SOLVED] Clock shifted by timezone value

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

[SOLVED] Clock shifted by timezone value

Postby bikrus on Sat Jul 16, 2011 12:57 pm

Hello!

I am new to LMDE. One of my problems is clock.
Every time I boot in - the clock is shifted back for 3 hours - my timezone is GMT-3.
If I don't touch it and reboot - the clock is shifted again. So, with 1 reboot I have -3 hours. With 2: -6, with 3: -9 hours and so on.
If PC is shutdowned and then powered on - same situation.
My bios clock is set to local time. I can't change it to UTC because of other OSes installed.
I set UTC=no in /etc/defaults/rcS.
Other OSes (Win7, Ubuntu) works correctly.

Please help. If I can provide any helpful information - please, tell me.

Thanks.

<Edit>Oh, sorry. My LMDE is based on "Linux Mint Debian Latest".</Edit>
Last edited by bikrus on Sun Jul 17, 2011 3:31 am, edited 1 time in total.
bikrus
Level 1
Level 1
 
Posts: 25
Joined: Sat Jul 16, 2011 6:43 am

Linux Mint is funded by ads and donations.
 

Re: Clock shifted by timezone value

Postby xenopeek on Sat Jul 16, 2011 1:40 pm

Instead of having Linux use local time, you can also switch Windows to use UTC: https://help.ubuntu.com/community/UbuntuTime#Make%20Windows%20use%20UTC

And I suggest you install NTP to keep Linux time synchronized with internet servers. There is a front-end to NTP you can use to configure it:
Code: Select all
sudo apt-get install gnome-time-admin

Then go to Menu -> Control Center -> Time and Date, unlock, and change Configuration to "Keep synchronized with Internet servers." You can add servers local to your country, look them up at http://www.pool.ntp.org.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15280
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Clock shifted by timezone value

Postby bikrus on Sat Jul 16, 2011 1:51 pm

Thanks, xenopeek for advices. But...

xenopeek wrote:Instead of having Linux use local time, you can also switch Windows to use UTC: https://help.ubuntu.com/community/UbuntuTime#Make%20Windows%20use%20UTC


Why Ubuntu doesn't need it? Because it can work with bios local time.
I'll not change "outside world". I want to make LMDE to live by "outside rules". Sorry, this advice not for me.

xenopeek wrote:And I suggest you install NTP to keep Linux time synchronized with internet servers. There is a front-end to NTP you can use to configure it:
Code: Select all
sudo apt-get install gnome-time-admin

Then go to Menu -> Control Center -> Time and Date, unlock, and change Configuration to "Keep synchronized with Internet servers." You can add servers local to your country, look them up at http://www.pool.ntp.org.


I don't want NTP because I want to minimize network activity. Sorry, this advice is not for me too.

What I want - to understand is it bug or is it something else. Anybody could be in same situation. If I, with your good help, will find the answer - it will save time for other.

Anyway - thanks.

PS: I what to understand: why LMDE works incorrectly with bios local time, without NTP.
bikrus
Level 1
Level 1
 
Posts: 25
Joined: Sat Jul 16, 2011 6:43 am

Re: Clock shifted by timezone value

Postby xenopeek on Sat Jul 16, 2011 2:29 pm

Okay :) Perhaps somebody else can help on UTC=no not working... That should work.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15280
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Clock shifted by timezone value

Postby bikrus on Sun Jul 17, 2011 3:30 am

Solved!

When I was playing with USB automount I turned on "udev" service in "/usr/bin/services-admin". In my XFCE menu it is under "Menu -> System -> Services". This was the cause of my problem. After turning off this service in same way in "/usr/bin/services-admin" - everything is fine: Clock doesn't shift on reboot and my USB flash drive is still automounted - I think udev is started elsewhere. udevd still in "ps aux".
I investigated this by turning on VERBOSE messages for logging and turning on Boot logging.
So. The problem is solved for me. But why if I turn on "udev" in "/usr/bin/services-admin" the clock is shifted - is still a question.

Thanks everybody for advices. Still use LMDE with hope it will be great Rolling Release distribution.
bikrus
Level 1
Level 1
 
Posts: 25
Joined: Sat Jul 16, 2011 6:43 am


Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 3 guests