Error messages when installing wine unstable

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

Error messages when installing wine unstable

Postby pythonscript on Fri Jan 13, 2012 6:41 pm

I just downloaded and installed LMDE and upgraded to Update Pack 3. Now I'm trying to install wine using this link:
http://dev.carbon-project.org/debian/wine-unstable/

I downloaded every package under i386 (my architecture) and ran

Code: Select all
sudo dpkg -i *.deb


However, I get this set of error messages:

Code: Select all
Selecting previously deselected package libwine-alsa-unstable.
(Reading database ... 261600 files and directories currently installed.)
Unpacking libwine-alsa-unstable (from libwine-alsa-unstable_1.3.35-0.1_i386.deb) ...
Selecting previously deselected package libwine-bin-unstable.
Unpacking libwine-bin-unstable (from libwine-bin-unstable_1.3.35-0.1_i386.deb) ...
Selecting previously deselected package libwine-capi-unstable.
Unpacking libwine-capi-unstable (from libwine-capi-unstable_1.3.35-0.1_i386.deb) ...
Selecting previously deselected package libwine-cms-unstable.
Unpacking libwine-cms-unstable (from libwine-cms-unstable_1.3.35-0.1_i386.deb) ...
Selecting previously deselected package libwine-dbg-unstable.
Unpacking libwine-dbg-unstable (from libwine-dbg-unstable_1.3.35-0.1_i386.deb) ...
Selecting previously deselected package libwine-dev-unstable.
Unpacking libwine-dev-unstable (from libwine-dev-unstable_1.3.35-0.1_i386.deb) ...
Selecting previously deselected package libwine-gl-unstable.
Unpacking libwine-gl-unstable (from libwine-gl-unstable_1.3.35-0.1_i386.deb) ...
Selecting previously deselected package libwine-gphoto2-unstable.
Unpacking libwine-gphoto2-unstable (from libwine-gphoto2-unstable_1.3.35-0.1_i386.deb) ...
Selecting previously deselected package libwine-ldap-unstable.
Unpacking libwine-ldap-unstable (from libwine-ldap-unstable_1.3.35-0.1_i386.deb) ...
Selecting previously deselected package libwine-openal-unstable.
Unpacking libwine-openal-unstable (from libwine-openal-unstable_1.3.35-0.1_i386.deb) ...
Selecting previously deselected package libwine-oss-unstable.
Unpacking libwine-oss-unstable (from libwine-oss-unstable_1.3.35-0.1_i386.deb) ...
Selecting previously deselected package libwine-print-unstable.
Unpacking libwine-print-unstable (from libwine-print-unstable_1.3.35-0.1_i386.deb) ...
Selecting previously deselected package libwine-sane-unstable.
Unpacking libwine-sane-unstable (from libwine-sane-unstable_1.3.35-0.1_i386.deb) ...
Selecting previously deselected package libwine-unstable.
Unpacking libwine-unstable (from libwine-unstable_1.3.35-0.1_i386.deb) ...
Selecting previously deselected package wine-bin-unstable.
Unpacking wine-bin-unstable (from wine-bin-unstable_1.3.35-0.1_i386.deb) ...
Selecting previously deselected package wine-unstable.
Unpacking wine-unstable (from wine-unstable_1.3.35-0.1_i386.deb) ...
dpkg: dependency problems prevent configuration of libwine-bin-unstable:
 libwine-bin-unstable depends on libtinfo5; however:
  Package libtinfo5 is not installed.
dpkg: error processing libwine-bin-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-capi-unstable:
 libwine-capi-unstable depends on libcapi20-3; however:
  Package libcapi20-3 is not installed.
dpkg: error processing libwine-capi-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-openal-unstable:
 libwine-openal-unstable depends on libopenal1; however:
  Package libopenal1 is not installed.
dpkg: error processing libwine-openal-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-unstable:
 libwine-unstable depends on libmpg123-0 (>= 1.6.2); however:
  Package libmpg123-0 is not installed.
dpkg: error processing libwine-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wine-bin-unstable:
 wine-bin-unstable depends on libwine-bin-unstable (= 1.3.35-0.1); however:
  Package libwine-bin-unstable is not configured yet.
dpkg: error processing wine-bin-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wine-unstable:
 wine-unstable depends on wine-bin-unstable (= 1.3.35-0.1); however:
  Package wine-bin-unstable is not configured yet.
 wine-unstable depends on libwine-openal-unstable (= 1.3.35-0.1); however:
  Package libwine-openal-unstable is not configured yet.
dpkg: error processing wine-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-alsa-unstable:
 libwine-alsa-unstable depends on libwine-unstable (= 1.3.35-0.1); however:
  Package libwine-unstable is not configured yet.
dpkg: error processing libwine-alsa-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-cms-unstable:
 libwine-cms-unstable depends on libwine-unstable (= 1.3.35-0.1); however:
  Package libwine-unstable is not configured yet.
dpkg: error processing libwine-cms-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-dbg-unstable:
 libwine-dbg-unstable depends on libwine-unstable (= 1.3.35-0.1); however:
  Package libwine-unstable is not configured yet.
dpkg: error processing libwine-dbg-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-dev-unstable:
 libwine-dev-unstable depends on libwine-unstable (= 1.3.35-0.1); however:
  Package libwine-unstable is not configured yet.
dpkg: error processing libwine-dev-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-gl-unstable:
 libwine-gl-unstable depends on libwine-unstable (= 1.3.35-0.1); however:
  Package libwine-unstable is not configured yet.
dpkg: error processing libwine-gl-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-gphoto2-unstable:
 libwine-gphoto2-unstable depends on libwine-unstable (= 1.3.35-0.1); however:
  Package libwine-unstable is not configured yet.
dpkg: error processing libwine-gphoto2-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-ldap-unstable:
 libwine-ldap-unstable depends on libwine-unstable (= 1.3.35-0.1); however:
  Package libwine-unstable is not configured yet.
dpkg: error processing libwine-ldap-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-oss-unstable:
 libwine-oss-unstable depends on libwine-unstable (= 1.3.35-0.1); however:
  Package libwine-unstable is not configured yet.
dpkg: error processing libwine-oss-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-print-unstable:
 libwine-print-unstable depends on libwine-unstable (= 1.3.35-0.1); however:
  Package libwine-unstable is not configured yet.
dpkg: error processing libwine-print-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-sane-unstable:
 libwine-sane-unstable depends on libwine-unstable (= 1.3.35-0.1); however:
  Package libwine-unstable is not configured yet.
dpkg: error processing libwine-sane-unstable (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db ...
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Errors were encountered while processing:
 libwine-bin-unstable
 libwine-capi-unstable
 libwine-openal-unstable
 libwine-unstable
 wine-bin-unstable
 wine-unstable
 libwine-alsa-unstable
 libwine-cms-unstable
 libwine-dbg-unstable
 libwine-dev-unstable
 libwine-gl-unstable
 libwine-gphoto2-unstable
 libwine-ldap-unstable
 libwine-oss-unstable
 libwine-print-unstable
 libwine-sane-unstable


This is the complete list of files I downloaded, which appears to be the complete list. How can I correctly install wine?
pythonscript
Level 2
Level 2
 
Posts: 53
Joined: Wed Nov 09, 2011 3:49 pm

Linux Mint is funded by ads and donations.
 

Re: Error messages when installing wine unstable

Postby tdockery97 on Fri Jan 13, 2012 6:48 pm

Now you need to resolve dependencies. Run:

Code: Select all
sudo dpkg -f install


It should install the dependencies that are missing.
Image

HP Pavilion 17 Notebook, 8GB DDR3, 2.5GHZ A10-APU, Radeon HD 8650G
User avatar
tdockery97
Level 13
Level 13
 
Posts: 4909
Joined: Sun Jan 10, 2010 8:54 am
Location: Salem, Oregon

Re: Error messages when installing wine unstable

Postby pythonscript on Sat Jan 14, 2012 12:30 pm

Running that command gives me this error message:

Code: Select all
dpkg-deb: error: failed to read archive `install': No such file or directory


Is there a dash or other flag missing in the command?
pythonscript
Level 2
Level 2
 
Posts: 53
Joined: Wed Nov 09, 2011 3:49 pm

Re: Error messages when installing wine unstable

Postby droth542 on Fri Jan 27, 2012 8:24 pm

I am in exactly the same boat. I tried to use APT to install and got
Code: Select all
david@davidoffice ~ $ sudo apt-get -f install wine-unstable
Reading package lists... Done
Building dependency tree       
Reading state information... Done
wine-unstable is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libwine-cms-unstable : Depends: ia32-libs (>= 20111001) but it is not going to be installed
 libwine-dev-unstable : Depends: libc6-dev-i386 but it is not going to be installed
 libwine-gl-unstable : Depends: ia32-libs (>= 20111001) but it is not going to be installed
 libwine-gphoto2-unstable : Depends: ia32-libs (>= 20111001) but it is not going to be installed
 libwine-ldap-unstable : Depends: ia32-libs (>= 20111001) but it is not going to be installed
 libwine-openal-unstable : Depends: ia32-libs (>= 20111001) but it is not going to be installed
 libwine-unstable : Depends: ia32-libs (>= 20111001) but it is not going to be installed
                    Depends: lib32z1 (>= 1:1.1.4) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


So I downloaded all the dependancies and tried to install manualling and got
Code: Select all
david@davidoffice ~/Downloads $ sudo dpkg -i *.deb
(Reading database ... 157406 files and directories currently installed.)
Preparing to replace libwine-alsa-unstable 1.3.37-0.3 (using libwine-alsa-unstable_1.3.37-0.3_amd64.deb) ...
Unpacking replacement libwine-alsa-unstable ...
Preparing to replace libwine-bin-unstable 1.3.37-0.3 (using libwine-bin-unstable_1.3.37-0.3_amd64.deb) ...
Unpacking replacement libwine-bin-unstable ...
Preparing to replace libwine-capi-unstable 1.3.37-0.3 (using libwine-capi-unstable_1.3.37-0.3_amd64.deb) ...
Unpacking replacement libwine-capi-unstable ...
Preparing to replace libwine-cms-unstable 1.3.37-0.3 (using libwine-cms-unstable_1.3.37-0.3_amd64.deb) ...
Unpacking replacement libwine-cms-unstable ...
Preparing to replace libwine-dbg-unstable 1.3.37-0.3 (using libwine-dbg-unstable_1.3.37-0.3_amd64.deb) ...
Unpacking replacement libwine-dbg-unstable ...
Preparing to replace libwine-dev-unstable 1.3.37-0.3 (using libwine-dev-unstable_1.3.37-0.3_amd64.deb) ...
Unpacking replacement libwine-dev-unstable ...
Preparing to replace libwine-gl-unstable 1.3.37-0.3 (using libwine-gl-unstable_1.3.37-0.3_amd64.deb) ...
Unpacking replacement libwine-gl-unstable ...
Preparing to replace libwine-gphoto2-unstable 1.3.37-0.3 (using libwine-gphoto2-unstable_1.3.37-0.3_amd64.deb) ...
Unpacking replacement libwine-gphoto2-unstable ...
Preparing to replace libwine-ldap-unstable 1.3.37-0.3 (using libwine-ldap-unstable_1.3.37-0.3_amd64.deb) ...
Unpacking replacement libwine-ldap-unstable ...
Preparing to replace libwine-openal-unstable 1.3.37-0.3 (using libwine-openal-unstable_1.3.37-0.3_amd64.deb) ...
Unpacking replacement libwine-openal-unstable ...
Preparing to replace libwine-oss-unstable 1.3.37-0.3 (using libwine-oss-unstable_1.3.37-0.3_amd64.deb) ...
Unpacking replacement libwine-oss-unstable ...
Preparing to replace libwine-print-unstable 1.3.37-0.3 (using libwine-print-unstable_1.3.37-0.3_amd64.deb) ...
Unpacking replacement libwine-print-unstable ...
Preparing to replace libwine-sane-unstable 1.3.37-0.3 (using libwine-sane-unstable_1.3.37-0.3_amd64.deb) ...
Unpacking replacement libwine-sane-unstable ...
Preparing to replace libwine-unstable 1.3.37-0.3 (using libwine-unstable_1.3.37-0.3_amd64.deb) ...
Unpacking replacement libwine-unstable ...
Preparing to replace wine-bin-unstable 1.3.37-0.3 (using wine-bin-unstable_1.3.37-0.3_amd64.deb) ...
Unpacking replacement wine-bin-unstable ...
Preparing to replace wine-unstable 1.3.37-0.3 (using wine-unstable_1.3.37-0.3_amd64.deb) ...
Unpacking replacement wine-unstable ...
dpkg: dependency problems prevent configuration of libwine-cms-unstable:
 libwine-cms-unstable depends on ia32-libs (>= 20111001); however:
  Package ia32-libs is not installed.
dpkg: error processing libwine-cms-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-dev-unstable:
 libwine-dev-unstable depends on libc6-dev-i386; however:
  Package libc6-dev-i386 is not installed.
dpkg: error processing libwine-dev-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-gl-unstable:
 libwine-gl-unstable depends on ia32-libs (>= 20111001); however:
  Package ia32-libs is not installed.
dpkg: error processing libwine-gl-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-gphoto2-unstable:
 libwine-gphoto2-unstable depends on ia32-libs (>= 20111001); however:
  Package ia32-libs is not installed.
dpkg: error processing libwine-gphoto2-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-ldap-unstable:
 libwine-ldap-unstable depends on ia32-libs (>= 20111001); however:
  Package ia32-libs is not installed.
dpkg: error processing libwine-ldap-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-openal-unstable:
 libwine-openal-unstable depends on ia32-libs (>= 20111001); however:
  Package ia32-libs is not installed.
dpkg: error processing libwine-openal-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-unstable:
 libwine-unstable depends on ia32-libs (>= 20111001); however:
  Package ia32-libs is not installed.
 libwine-unstable depends on lib32z1 (>= 1:1.1.4); however:
  Package lib32z1 is not installed.
dpkg: error processing libwine-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wine-unstable:
 wine-unstable depends on libwine-gl-unstable (= 1.3.37-0.3); however:
  Package libwine-gl-unstable is not configured yet.
 wine-unstable depends on libwine-cms-unstable (= 1.3.37-0.3); however:
  Package libwine-cms-unstable is not configured yet.
 wine-unstable depends on libwine-gphoto2-unstable (= 1.3.37-0.3); however:
  Package libwine-gphoto2-unstable is not configured yet.
 wine-unstable depends on libwine-ldap-unstable (= 1.3.37-0.3); however:
  Package libwine-ldap-unstable is not configured yet.
 wine-unstable depends on libwine-openal-unstable (= 1.3.37-0.3); however:
  Package libwine-openal-unstable is not configured yet.
dpkg: error processing wine-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-alsa-unstable:
 libwine-alsa-unstable depends on libwine-unstable (= 1.3.37-0.3); however:
  Package libwine-unstable is not configured yet.
dpkg: error processing libwine-alsa-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-bin-unstable:
 libwine-bin-unstable depends on libwine-unstable (= 1.3.37-0.3); however:
  Package libwine-unstable is not configured yet.
dpkg: error processing libwine-bin-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-capi-unstable:
 libwine-capi-unstable depends on libwine-unstable (= 1.3.37-0.3); however:
  Package libwine-unstable is not configured yet.
dpkg: error processing libwine-capi-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-dbg-unstable:
 libwine-dbg-unstable depends on libwine-unstable (= 1.3.37-0.3); however:
  Package libwine-unstable is not configured yet.
dpkg: error processing libwine-dbg-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-oss-unstable:
 libwine-oss-unstable depends on libwine-unstable (= 1.3.37-0.3); however:
  Package libwine-unstable is not configured yet.
dpkg: error processing libwine-oss-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-print-unstable:
 libwine-print-unstable depends on libwine-unstable (= 1.3.37-0.3); however:
  Package libwine-unstable is not configured yet.
dpkg: error processing libwine-print-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-sane-unstable:
 libwine-sane-unstable depends on libwine-unstable (= 1.3.37-0.3); however:
  Package libwine-unstable is not configured yet.
dpkg: error processing libwine-sane-unstable (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wine-bin-unstable:
 wine-bin-unstable depends on libwine-bin-unstable (= 1.3.37-0.3); however:
  Package libwine-bin-unstable is not configured yet.
dpkg: error processing wine-bin-unstable (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db ...
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Errors were encountered while processing:
 libwine-cms-unstable
 libwine-dev-unstable
 libwine-gl-unstable
 libwine-gphoto2-unstable
 libwine-ldap-unstable
 libwine-openal-unstable
 libwine-unstable
 wine-unstable
 libwine-alsa-unstable
 libwine-bin-unstable
 libwine-capi-unstable
 libwine-dbg-unstable
 libwine-oss-unstable
 libwine-print-unstable
 libwine-sane-unstable
 wine-bin-unstable


Truly at a loss...
droth542
Level 1
Level 1
 
Posts: 2
Joined: Fri Jan 27, 2012 8:17 pm

Re: Error messages when installing wine unstable

Postby itemonhold on Wed Feb 01, 2012 9:00 am

Me too - exactly the same error message as pythonscript when trying to install in the same manner. I looked for the missing libtinfo5 in Synaptic and tried installing again. Now I can launch winecfg from the terminal (not showing in the start menu) and use a windows application but it isn't very stable.
itemonhold
Level 1
Level 1
 
Posts: 18
Joined: Thu Nov 11, 2010 3:20 pm

Re: Error messages when installing wine unstable

Postby pythonscript on Sat Jul 28, 2012 8:36 am

Not to reopen an old thread, but since no solution was ever figured out for this, it seemed sensible. I'm now using update pack 4, and I downloaded all the amd64 files from here:
http://dev.carbon-project.org/debian/wine-unstable/

I ran
Code: Select all
sudo dpkg -i *.deb


but that just gives me this:

Selecting previously unselected package libwine-alsa-unstable.
(Reading database ... 295239 files and directories currently installed.)
Unpacking libwine-alsa-unstable (from libwine-alsa-unstable_1.5.5-0.1_amd64.deb) ...
Selecting previously unselected package libwine-bin-unstable.
Unpacking libwine-bin-unstable (from libwine-bin-unstable_1.5.5-0.1_amd64.deb) ...
Selecting previously unselected package libwine-capi-unstable.
Unpacking libwine-capi-unstable (from libwine-capi-unstable_1.5.5-0.1_amd64.deb) ...
Selecting previously unselected package libwine-cms-unstable.
Unpacking libwine-cms-unstable (from libwine-cms-unstable_1.5.5-0.1_amd64.deb) ...
Selecting previously unselected package libwine-dbg-unstable.
Unpacking libwine-dbg-unstable (from libwine-dbg-unstable_1.5.5-0.1_amd64.deb) ...
Selecting previously unselected package libwine-dev-unstable.
Unpacking libwine-dev-unstable (from libwine-dev-unstable_1.5.5-0.1_amd64.deb) ...
Selecting previously unselected package libwine-gl-unstable.
Unpacking libwine-gl-unstable (from libwine-gl-unstable_1.5.5-0.1_amd64.deb) ...
Selecting previously unselected package libwine-gphoto2-unstable.
Unpacking libwine-gphoto2-unstable (from libwine-gphoto2-unstable_1.5.5-0.1_amd64.deb) ...
Selecting previously unselected package libwine-ldap-unstable.
Unpacking libwine-ldap-unstable (from libwine-ldap-unstable_1.5.5-0.1_amd64.deb) ...
Selecting previously unselected package libwine-openal-unstable.
Unpacking libwine-openal-unstable (from libwine-openal-unstable_1.5.5-0.1_amd64.deb) ...
Selecting previously unselected package libwine-oss-unstable.
Unpacking libwine-oss-unstable (from libwine-oss-unstable_1.5.5-0.1_amd64.deb) ...
Selecting previously unselected package libwine-print-unstable.
Unpacking libwine-print-unstable (from libwine-print-unstable_1.5.5-0.1_amd64.deb) ...
Selecting previously unselected package libwine-sane-unstable.
Unpacking libwine-sane-unstable (from libwine-sane-unstable_1.5.5-0.1_amd64.deb) ...
dpkg: regarding libwine-unstable_1.5.5-0.1_amd64.deb containing libwine-unstable, pre-dependency problem:
libwine-unstable pre-depends on libc6-i386 (>= 2.9-18)
dpkg: error processing libwine-unstable_1.5.5-0.1_amd64.deb (--install):
pre-dependency problem - not installing libwine-unstable
Selecting previously unselected package wine-bin-unstable.
Unpacking wine-bin-unstable (from wine-bin-unstable_1.5.5-0.1_amd64.deb) ...
Selecting previously unselected package wine-unstable.
Unpacking wine-unstable (from wine-unstable_1.5.5-0.1_amd64.deb) ...
dpkg: dependency problems prevent configuration of libwine-alsa-unstable:
libwine-alsa-unstable depends on lib32asound2 (>> 1.0.25); however:
Package lib32asound2 is not installed.
libwine-alsa-unstable depends on libc6-i386 (>= 2.1.3); however:
Package libc6-i386 is not installed.
libwine-alsa-unstable depends on libwine-unstable (= 1.5.5-0.1); however:
Package libwine-unstable is not installed.
dpkg: error processing libwine-alsa-unstable (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-bin-unstable:
libwine-bin-unstable depends on libc6-i386 (>= 2.7); however:
Package libc6-i386 is not installed.
libwine-bin-unstable depends on libwine-unstable (= 1.5.5-0.1); however:
Package libwine-unstable is not installed.
dpkg: error processing libwine-bin-unstable (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-capi-unstable:
libwine-capi-unstable depends on libc6-i386 (>= 2.1.3); however:
Package libc6-i386 is not installed.
libwine-capi-unstable depends on libwine-unstable (= 1.5.5-0.1); however:
Package libwine-unstable is not installed.
dpkg: error processing libwine-capi-unstable (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-cms-unstable:
libwine-cms-unstable depends on ia32-libs (>= 20120102); however:
Package ia32-libs is not installed.
libwine-cms-unstable depends on libc6-i386 (>= 2.1.3); however:
Package libc6-i386 is not installed.
libwine-cms-unstable depends on libwine-unstable (= 1.5.5-0.1); however:
Package libwine-unstable is not installed.
dpkg: error processing libwine-cms-unstable (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-dbg-unstable:
libwine-dbg-unstable depends on libwine-unstable (= 1.5.5-0.1); however:
Package libwine-unstable is not installed.
dpkg: error processing libwine-dbg-unstable (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-dev-unstable:
libwine-dev-unstable depends on libc6-i386 (>= 2.11); however:
Package libc6-i386 is not installed.
libwine-dev-unstable depends on libwine-unstable (= 1.5.5-0.1); however:
Package libwine-unstable is not installed.
libwine-dev-unstable depends on libc6-dev-i386; however:
Package libc6-dev-i386 is not installed.
dpkg: error processing libwine-dev-unstable (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-gl-unstable:
libwine-gl-unstable depends on ia32-libs (>= 20120102); however:
Package ia32-libs is not installed.
libwine-gl-unstable depends on libc6-i386 (>= 2.7); however:
Package libc6-i386 is not installed.
libwine-gl-unstable depends on libwine-unstable (= 1.5.5-0.1); however:
Package libwine-unstable is not installed.
dpkg: error processing libwine-gl-unstable (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-gphoto2-unstable:
libwine-gphoto2-unstable depends on ia32-libs (>= 20120102); however:
Package ia32-libs is not installed.
libwine-gphoto2-unstable depends on libc6-i386 (>= 2.1.3); however:
Package libc6-i386 is not installed.
libwine-gphoto2-unstable depends on libwine-unstable (= 1.5.5-0.1); however:
Package libwine-unstable is not installed.
dpkg: error processing libwine-gphoto2-unstable (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-ldap-unstable:
libwine-ldap-unstable depends on ia32-libs (>= 20120102); however:
Package ia32-libs is not installed.
libwine-ldap-unstable depends on libc6-i386 (>= 2.3); however:
Package libc6-i386 is not installed.
libwine-ldap-unstable depends on libwine-unstable (= 1.5.5-0.1); however:
Package libwine-unstable is not installed.
dpkg: error processing libwine-ldap-unstable (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-openal-unstable:
libwine-openal-unstable depends on ia32-libs (>= 20120102); however:
Package ia32-libs is not installed.
libwine-openal-unstable depends on libc6-i386 (>= 2.1.3); however:
Package libc6-i386 is not installed.
libwine-openal-unstable depends on libwine-unstable (= 1.5.5-0.1); however:
Package libwine-unstable is not installed.
dpkg: error processing libwine-openal-unstable (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-oss-unstable:
libwine-oss-unstable depends on libc6-i386 (>= 2.1.3); however:
Package libc6-i386 is not installed.
libwine-oss-unstable depends on libwine-unstable (= 1.5.5-0.1); however:
Package libwine-unstable is not installed.
dpkg: error processing libwine-oss-unstable (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-print-unstable:
libwine-print-unstable depends on libc6-i386 (>= 2.3); however:
Package libc6-i386 is not installed.
libwine-print-unstable depends on libwine-unstable (= 1.5.5-0.1); however:
Package libwine-unstable is not installed.
dpkg: error processing libwine-print-unstable (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwine-sane-unstable:
libwine-sane-unstable depends on libc6-i386 (>= 2.1.3); however:
Package libc6-i386 is not installed.
libwine-sane-unstable depends on libwine-unstable (= 1.5.5-0.1); however:
Package libwine-unstable is not installed.
dpkg: error processing libwine-sane-unstable (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wine-bin-unstable:
wine-bin-unstable depends on libwine-bin-unstable (= 1.5.5-0.1); however:
Package libwine-bin-unstable is not configured yet.
dpkg: error processing wine-bin-unstable (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wine-unstable:
wine-unstable depends on wine-bin-unstable (= 1.5.5-0.1); however:
Package wine-bin-unstable is not configured yet.
wine-unstable depends on libwine-alsa-unstable (= 1.5.5-0.1) | libwine-oss-unstable (= 1.5.5-0.1); however:
Package libwine-alsa-unstable is not configured yet.
Package libwine-oss-unstable is not configured yet.
wine-unstable depends on libwine-gl-unstable (= 1.5.5-0.1); however:
Package libwine-gl-unstable is not configured yet.
wine-unstable depends on libwine-print-unstable (= 1.5.5-0.1); however:
Package libwine-print-unstable is not configured yet.
wine-unstable depends on libwine-sane-unstable (= 1.5.5-0.1); however:
Package libwine-sane-unstable is not configured yet.
wine-unstable depends on libwine-cms-unstable (= 1.5.5-0.1); however:
Package libwine-cms-unstable is not configured yet.
wine-unstable depends on libwine-gphoto2-unstable (= 1.5.5-0.1); however:
Package libwine-gphoto2-unstable is not configured yet.
wine-unstable depends on libwine-ldap-unstable (= 1.5.5-0.1); however:
Package libwine-ldap-unstable is not configured yet.
wine-unstable depends on libwine-openal-unstable (= 1.5.5-0.1); however:
Package libwine-openal-unstable is not configured yet.
dpkg: error processing wine-unstable (--install):
dependency problems - leaving unconfigured
Processing triggers for man-db ...
Processing triggers for mime-support ...
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Errors were encountered while processing:
libwine-unstable_1.5.5-0.1_amd64.deb
libwine-alsa-unstable
libwine-bin-unstable
libwine-capi-unstable
libwine-cms-unstable
libwine-dbg-unstable
libwine-dev-unstable
libwine-gl-unstable
libwine-gphoto2-unstable
libwine-ldap-unstable
libwine-openal-unstable
libwine-oss-unstable
libwine-print-unstable
libwine-sane-unstable
wine-bin-unstable
wine-unstable



Someone suggested running
Code: Select all
sudo dpkg -f install


but that returns an error message:
Code: Select all
dpkg-deb: error: failed to read archive `install': No such file or directory


since install isn't actually a command. I hesitate to use
Code: Select all
sudo apt-get -f install

because I normally use aptitude to install packages and I have had major problems on LMDE when I mixed these two.

How can I install wine on 64-bit LMDE? Is there something I'm missing? The instructions I've received seem quite straightforward, except they don't work.
pythonscript
Level 2
Level 2
 
Posts: 53
Joined: Wed Nov 09, 2011 3:49 pm

Re: Error messages when installing wine unstable

Postby pythonscript on Mon Jul 30, 2012 9:30 pm

Anyone? Does LMDE simply not support Wine?
pythonscript
Level 2
Level 2
 
Posts: 53
Joined: Wed Nov 09, 2011 3:49 pm

Re: Error messages when installing wine unstable

Postby mcg00sh on Tue Jul 31, 2012 4:47 pm

I have 1.5.5 through the same link you posted. Running x64 + Wine 1.5.5 + Diablo III. I had some minor issues when I installed 1.4 through the default repository. Are you sure the old version is completely gone?

Code: Select all
sudo apt-get --purge -remove wine
mcg00sh
Level 1
Level 1
 
Posts: 10
Joined: Tue Jul 31, 2012 4:05 pm

Re: Error messages when installing wine unstable

Postby pythonscript on Tue Jul 31, 2012 11:36 pm

I ran

Code: Select all
sudo aptitude purge wine


and that did nothing. I very much hesitate to run apt-get commands because I've had serious trouble mixing apt-get and aptitude in the past, which is I prefer to only use aptitude (long story short, apt-get began removing hundreds of packages from my system, including the linux mint base desktop packages...)
pythonscript
Level 2
Level 2
 
Posts: 53
Joined: Wed Nov 09, 2011 3:49 pm

Re: Error messages when installing wine unstable

Postby mcg00sh on Wed Aug 01, 2012 10:09 am

I believe the issue you are referring to is the need to have wine-gecko1.x installed as well. As I know it will remove the gnome-common, mate-common, gettext..etc. Sorry your having so much trouble with it as I can confirm it does indeed work.
mcg00sh
Level 1
Level 1
 
Posts: 10
Joined: Tue Jul 31, 2012 4:05 pm

Re: Error messages when installing wine unstable

Postby pythonscript on Sun Aug 05, 2012 8:24 pm

Exactly what package are you referring to? Running this command:
Code: Select all
apt-cache search wine


shows these packages:

Code: Select all
winetricks - package manager for WINE to install software easily
gnome-colors - set of GNOME icon themes
gnome-wine-icon-theme - red variation of the GNOME-Colors icon theme
libkwineffects1abi2 - library used by effects for the KDE window manager
shiki-colors - set of Metacity/GTK-2+ themes
shiki-wine-theme - red variation of the Shiki-Colors theme
tellico - collection manager for books, videos, music
tellico-data - collection manager for books, videos, music [data]
tellico-scripts - collection manager for books, videos, music [scripts]
unmass - Extract game archive files
wine-doc - Windows API implementation - documentation
libwine-gecko-dbg-unstable - Windows API implementation - web browser debug build
libwine-gecko-unstable - Windows API implementation - web browser module
ia32-libs-libtxc-dxtn0 - libtxc-dxtn0 ia32 shared libraries


Which of these, if any, do I need to install before the packages from the previously mentioned links will work?
pythonscript
Level 2
Level 2
 
Posts: 53
Joined: Wed Nov 09, 2011 3:49 pm

Re: Error messages when installing wine unstable

Postby pythonscript on Sun Aug 12, 2012 10:49 pm

Does LMDE simply not support Wine? So far, the instructions have not helped, but the problem still occurs. Is there any other information that I can provide that might help the problem? Has anyone gotten Wine to work properly on LMDE 64-bit at all?
pythonscript
Level 2
Level 2
 
Posts: 53
Joined: Wed Nov 09, 2011 3:49 pm

Re: Error messages when installing wine unstable

Postby mcg00sh on Thu Aug 30, 2012 6:52 pm

-It does work: Linux version 3.2.0-2-amd64 (Debian 3.2.9-1)

-It doesn't appear that you have everything installed.

$ apt-cache search wine
gnome-colors - set of GNOME icon themes
gnome-wine-icon-theme - red variation of the GNOME-Colors icon theme
libkwineffects1abi2 - library used by effects for the KDE window manager
shiki-colors - set of Metacity/GTK-2+ themes
shiki-wine-theme - red variation of the Shiki-Colors theme
tellico - collection manager for books, videos, music
tellico-data - collection manager for books, videos, music [data]
tellico-scripts - collection manager for books, videos, music [scripts]
unmass - Extract game archive files
wine-doc - Windows API implementation - documentation
libwine-gecko-dbg-unstable - Windows API implementation - web browser debug build
libwine-gecko-unstable - Windows API implementation - web browser module
ia32-libs-libtxc-dxtn0 - libtxc-dxtn0 ia32 shared libraries
libwine-gl-unstable - Windows API implementation - OpenGL module
libwine-ldap-unstable - Windows API implementation - LDAP module
libwine-oss-unstable - Windows API implementation - OSS sound module
wine-bin-unstable - Windows API implementation - binary loader
libwine-gphoto2-unstable - Windows API implementation - camera module
libwine-dev-unstable - Windows API implementation - development files
libwine-sane-unstable - Windows API implementation - scanner module
libwine-bin-unstable - Windows API implementation - system services
libwine-capi-unstable - Windows API implementation - ISDN module
winetricks - Microsoft Windows Compatibility Layer (winetricks)
wine-unstable - Windows API implementation - standard suite
libwine-print-unstable - Windows API implementation - printing module
libwine-openal-unstable - Windows API implementation - OpenAL module
libwine-cms-unstable - Windows API implementation - color management module
libwine-alsa-unstable - Windows API implementation - ALSA sound module
libwine-dbg-unstable - Windows API implementation - debugging symbols
libwine-unstable - Windows API implementation - library

-In the end I had to download and install these one at a time using dpkg -i.
mcg00sh
Level 1
Level 1
 
Posts: 10
Joined: Tue Jul 31, 2012 4:05 pm

Re: Error messages when installing wine unstable

Postby seppalta on Fri Aug 31, 2012 2:24 pm

To install Wine in LMDE 64-bit, see Section 7 of http://lxlinux.com/debian.html.
seppalta
Level 4
Level 4
 
Posts: 390
Joined: Wed Jun 08, 2011 12:08 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 8 guests