Cannot add languages or formats in the new LMDE 201403

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help

Cannot add languages or formats in the new LMDE 201403

Postby Martificiam on Tue Mar 04, 2014 3:53 pm

When I go to the regional settings and try to add new languages and formats nothing happens. I've therefore issued sudo dpkg-reconfigure locale and added my preferred languages. Then, I've edited the /etc/default/locale file like this:

Code: Select all
LANG=en_US.UTF-8
LC_TIME="lt_LT.UTF-8"
LC_PAPER="lt_LT.UTF-8"
LC_MEASUREMENT="lt_LT.UTF-8"



I'd like to use english as the system language, but use the lithuanian time and date format. After rebooting the computer it seems that it does indeed use the lt_LT charset for date and time, HOWEVER, the clock is still displayed in 12-hour format in the cinnamon panel. When I go to the date and time settings the time is shown in 24 hour format. How do I make the clock applet use the 24 hour format?
Martificiam
Level 1
Level 1
 
Posts: 11
Joined: Sun Sep 12, 2010 3:31 am

Linux Mint is funded by ads and donations.
 

Re: Cannot add languages or formats in the new LMDE 201403

Postby GeneBenson on Tue Mar 04, 2014 6:20 pm

Hi Martificiam,

If you go to this site and scroll down to "A complete list of FORMAT control characters ..." you will find a list of all the characters you can use. For a 24 hour clock you want %R.

I'm not using Cinnamon but usually you can right click on an applet in the panel and choose "Properties". Then "Custom Format" and use whatever you want.

Hope this helps. :D
GeneBenson
Level 3
Level 3
 
Posts: 182
Joined: Fri Sep 17, 2010 9:55 pm

Re: Cannot add languages or formats in the new LMDE 201403

Postby Martificiam on Tue Mar 04, 2014 8:27 pm

Thanks, right clicking on the clock applet and selecting 'Configure...' displayed the custom date format option. I used the default, which was %A %B %e, %H:%M. It works perfectly. However, the bug in the regional settings still remains - formats and languages cannot be added.
Martificiam
Level 1
Level 1
 
Posts: 11
Joined: Sun Sep 12, 2010 3:31 am


Return to Other Topics

Who is online

Users browsing this forum: No registered users and 3 guests