LMDE (Gnome and Xfce) "Login screen set..." issue? (Solved)

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help

LMDE (Gnome and Xfce) "Login screen set..." issue? (Solved)

Postby Eko_taas on Sun Sep 11, 2011 2:30 pm

I tried to put my LMDE (201108 RC of both types) to have login automatically to user account.

1. Installed fresh LMDE (and updated all packages, now up to date) (HD got broken :( )
2. created normal user (yyy)
3. locked in and out as normal (yyy) user (to make sure it exists)
4. re-started PC and locked in as main user (xxxadmin)
5. Started "Login Screen Settings" and tried to activate editing from "lock". Nothing happens.
(everything else seems OK in my favorate system)

Same "feature" in both editions :shock:

Bug or newbee issue :?: (was working on my 201012 edition, last update 2Ms back)...

If bug, I hope will be corrected before official release.
Last edited by Eko_taas on Mon Sep 12, 2011 2:12 am, edited 1 time in total.
Eko_taas
Level 2
Level 2
 
Posts: 75
Joined: Sat Jul 03, 2010 3:04 am

Linux Mint is funded by ads and donations.
 

Re: LMDE (Gnome and Xfce) "Login screen settings" issue?

Postby xenopeek on Sun Sep 11, 2011 3:26 pm

The lock/unlock icon not working on LMDE is a known bug: https://bugs.launchpad.net/linuxmint/+bug/830409

Workaround from terminal (at least for GNOME):
Code: Select all
gksudo gedit /etc/gdm3/daemon.conf

Change the following lines under the [daemon] section (or add these three lines if they are not there):
Code: Select all
[daemon]
AutomaticLoginEnable=true
AutomaticLogin=YOURUSERNAME

And replace YOURUSERNAME with your user name. Then save & close the file. Next time it should automatically login.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15437
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: LMDE (Gnome and Xfce) "Login screen settings" issue?

Postby Eko_taas on Mon Sep 12, 2011 2:11 am

Code: Select all
gksudo gedit /etc/gdm3/daemon.conf
(gksudo:2731): GLib-CRITICAL **: g_str_has_prefix: assertion `str != NULL' failed


No worry, when used root-terminal, and "gedit /etc/gdm3/daemon.conf", edit was OK. But after change of /etc/gdm3/daemon.cnf (with pref. username) and save / recheck, still no result.

Anyhow, as said, known bug, so also OK to wait bug-fix....

Changed as solved....
Eko_taas
Level 2
Level 2
 
Posts: 75
Joined: Sat Jul 03, 2010 3:04 am

Re: LMDE (Gnome and Xfce) "Login screen set..." issue? (Solv

Postby wayne128 on Mon Sep 12, 2011 2:15 am

I did not fix this. But this is the issue for many Debian distros I have tracking testing
Mine is tracking SID, once upgraded, this issue resolved itself.
so you can wait for a while until some packages from Sid filter down to Testing.
wayne128
Level 10
Level 10
 
Posts: 3325
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE (Gnome and Xfce) "Login screen set..." issue? (Solv

Postby alan0kerns on Mon Oct 31, 2011 3:34 pm

As of 2011-11-01 I needed to access /etc/gdm3/daemon.conf.dpkg-dist [not /etc/gdm3/daemon.conf] in order to make the recommended changes.
Thanks Vince.
Alan Kerns
alan0kerns
Level 1
Level 1
 
Posts: 2
Joined: Mon Oct 31, 2011 3:22 pm

Re: LMDE (Gnome and Xfce) "Login screen set..." issue? (Solv

Postby alan0kerns on Tue Nov 01, 2011 9:36 pm

2011-11-02 what I posted yesterday did not work.
So I entered the recommended info into /etc/gdm3/daemon.conf as recommended originally by Vince, and it worked.
That file previously contained no entries under any of the headings, but relevant entries were in the adjacent file: daemon.conf.dpkg-dist.
Thanks again, Vince.
Alan Kerns
alan0kerns
Level 1
Level 1
 
Posts: 2
Joined: Mon Oct 31, 2011 3:22 pm

Re: LMDE (Gnome and Xfce) "Login screen set..." issue? (Solv

Postby mirghany on Fri Jan 20, 2012 12:11 pm

Hi,
Auto login can be configured ( If editing /etc/gdm3/daemon.conf or /etc/gdm3/daemon.conf.dpkg-distails to do any effect ) throught editing /usr/share/gdm/gdm.schemas there are some useful parameters , if you would like to get auto login without time delay and choose edit paragraph AutomaticLoginEnable . If you would like to get a choose login screen and delaied login edit paragraph TimedLoginEnable , In all cases you have to fill the usermane in the next line.
Regards
mirghany
Level 1
Level 1
 
Posts: 1
Joined: Fri Jan 20, 2012 11:56 am

Linux Mint is funded by ads and donations.
 

Return to Other Topics

Who is online

Users browsing this forum: No registered users and 3 guests