LMDE Fonts - Too Bold in Some Places

Discuss non-support related topics related to LMDE.
Forum rules
Before you post please read this

LMDE Fonts - Too Bold in Some Places

Postby TBABill on Tue Jun 21, 2011 9:54 pm

I scanned through all the font posts and I only have issue with one font but I cannot figure out where to change it. When I go to http://news.google.com or within the forums, the "headlines" or the forum subject lines are a very bold font. I like the fonts and the rendering is fine, but I want something a bit more subtle like in Ubuntu. Can anyone tell me where Chromium pulls its fonts from for those particular spots? Changing fonts in Chromium does not fix it nor does changing desktop font settings.
TBABill
Level 6
Level 6
 
Posts: 1368
Joined: Wed Dec 30, 2009 1:02 pm
Location: Leonardtown, MD

Linux Mint is funded by ads and donations.
 

Re: LMDE Fonts - Too Bold in Some Places

Postby karashata on Wed Jun 22, 2011 1:38 pm

Just a suggestion that may or may not fix the problem: Try installing the ttf-mscorefonts-installer package (using 'sudo apt-get --install ttf-mscorefonts-installer' in a terminal window, since Synaptic seems to have problems displaying the EULA for acceptance) to install the MS fonts. A lot of websites use fonts provided in that package, and the replacement/fallback fonts sometimes don't look right, work very well, or are the wrong type of font (one site I use uses a sans-serif font when the MS fonts are installed, the fallback font ends up being a serif font for some reason...).

If that doesn't help, I'm not sure what might.
Linux Mint user since 2010, fluffy dragon forever!
Registered Linux User #473695
Image
User avatar
karashata
Level 4
Level 4
 
Posts: 441
Joined: Tue May 10, 2011 2:53 pm
Location: Stratford, Ontario, Canada

Re: LMDE Fonts - Too Bold in Some Places

Postby TBABill on Wed Jun 22, 2011 2:07 pm

I'll sure give it a look. Overall LMDE has nice fonts, but there are a few places where they just look large, thick and bold. I'll keep experimenting, but I think I need to get into my Ubuntu partition and start comparing font configs to see where the differences lie.
TBABill
Level 6
Level 6
 
Posts: 1368
Joined: Wed Dec 30, 2009 1:02 pm
Location: Leonardtown, MD

Re: LMDE Fonts - Too Bold in Some Places

Postby GeneC on Thu Jun 23, 2011 9:04 am

TBABill wrote:I scanned through all the font posts and I only have issue with one font but I cannot figure out where to change it. When I go to http://news.google.com or within the forums, the "headlines" or the forum subject lines are a very bold font. I like the fonts and the rendering is fine, but I want something a bit more subtle like in Ubuntu. Can anyone tell me where Chromium pulls its fonts from for those particular spots? Changing fonts in Chromium does not fix it nor does changing desktop font settings.


I can verify that this just happened to me also with todays updates. Font appearance has changed most everywhere, but most apparant in Chrome (and of course, Chromium). Very bold there.

Image

Not as "crisp" looking in all other aps.
Font settings remain the same, both in LMDE settings, and in Chrome settings?
I assume its from the font related updates downloaded today.

Code: Select all
Commit Log for Thu Jun 23 08:38:05 2011


Upgraded the following packages:
fontconfig-config (2.8.0-2ubuntu1) to 2.8.0-2.2
gtk2-engines-aurora (1.5.1~pablo1-1mint1) to 1.5.1-1
gtk2-engines-murrine (0.90.3+git20100323-0ubuntu3) to 0.98.1.1-2
libcairo-gobject2 (1.10.0-1ubuntu2) to 1.10.2-6
libcairo2 (1.10.0-1ubuntu2) to 1.10.2-6
libfontconfig1 (2.8.0-2ubuntu1) to 2.8.0-2.2
libpixman-1-0 (0.18.4-1) to 0.21.8-1

Installed the following packages:
murrine-themes (0.98.1)


All was perfect before todays updates.
Going to try to revert to "pre-update"
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon/XFCE)
Sparky XFCE (Debian Testing)
Sparky Cin 2.2 (SID)
OpenSUSE 13.1 (Gnome)
Evolve OS (Budgie)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1559
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE Fonts - Too Bold in Some Places

Postby GeneC on Thu Jun 23, 2011 9:41 am

Now isn't that odd!

I just reinstalled a recent (6-20-11) clone of my LMDE partition and have the good looking fonts back again. The odd part is when I just did a full update the seemingly offending packages = (may not be all of these, but something in the below update broke my fonts)

Code: Select all
Upgraded the following packages:
fontconfig-config (2.8.0-2ubuntu1) to 2.8.0-2.2
gtk2-engines-aurora (1.5.1~pablo1-1mint1) to 1.5.1-1
gtk2-engines-murrine (0.90.3+git20100323-0ubuntu3) to 0.98.1.1-2
libcairo-gobject2 (1.10.0-1ubuntu2) to 1.10.2-6
libcairo2 (1.10.0-1ubuntu2) to 1.10.2-6
libfontconfig1 (2.8.0-2ubuntu1) to 2.8.0-2.2
libpixman-1-0 (0.18.4-1) to 0.21.8-1

Installed the following packages:
murrine-themes (0.98.1)


Were no longer available for update?

I did all the updates that were presently available (around 72 packages), and all is still fine. Fonts are back nice and neat, like they had been for months.


Go figure! :cry: :?:
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon/XFCE)
Sparky XFCE (Debian Testing)
Sparky Cin 2.2 (SID)
OpenSUSE 13.1 (Gnome)
Evolve OS (Budgie)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1559
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE Fonts - Too Bold in Some Places

Postby TBABill on Thu Jun 23, 2011 7:50 pm

Mine look better, but Xubuntu and Ubuntu look far superior to LMDE's fonts overall. But LMDE looks much better than Kubuntu's fonts. Odd, but I know Ubuntu spends a great deal of effort on fonts so it's probably to be expected.
TBABill
Level 6
Level 6
 
Posts: 1368
Joined: Wed Dec 30, 2009 1:02 pm
Location: Leonardtown, MD


Return to Open Discussion

Who is online

Users browsing this forum: No registered users and 3 guests