problems with network shares[solved]

Discuss non-support related topics related to LMDE.
Forum rules
Before you post please read this

problems with network shares[solved]

Postby arta on Mon Mar 12, 2012 2:53 pm

I am using LMDE and have a problem mounting cifs network shares. I have tried the following commands without any luck.
sudo mount -t cifs -o username=art, password=****** //Freenas40/fn40drive2 /home/art/fn40drive2
and
sudo mount -t cifs //Freenas40/fn40drive2 -o username=art, password=****** /home/art/fn40drive2

The message I get with either of these commands is the same thing you get if you type "mount -V" which I think indicates a syntax error but I can't see any error. I can mount the share using the file manager but I want to make the connection in the /Home directory rather than on the desktop. I have install cifs-utils, smbclient and samba is installed.

Any insight will be appreciated,
If this message shows up twice I apologize. I thought I posted it before lunch but I searched and couldn't find it.

Thanks
Arta
Last edited by arta on Tue Mar 13, 2012 8:56 am, edited 1 time in total.
I have fought reality for forty years. I have finally beaten it into submission, but it's fighting back with vigor.
arta
Level 1
Level 1
 
Posts: 29
Joined: Tue Feb 26, 2008 8:28 pm
Location: Louisville, KY

Linux Mint is funded by ads and donations.
 

Re: problems with network shares

Postby DrHu on Mon Mar 12, 2012 3:14 pm

http://ubuntuforums.org/showthread.php?t=288534
Code: Select all
sudo mount -t cifs //netbiosname/sharename /media/sharename -o username=winusername,password=winpassword,iocharset=utf8,file_mode=0777,dir_mode=0777

    --from link above..
    You may also need a mode= command to be included: password protected method given above..
Same link, if you might want an icon to switch to the remote directory mount point, you could use /media mount location
    By creating the mount point in the /media folder, you will get a nifty icon to appear on your desktop like when a cdrom mounts.

Also as I understand it, Gnome uses a gfvs connection as the mount location for remote directories..

And if you want it (remote share..) permanently available, you need to setup in /etc/fstab to include that connection
User avatar
DrHu
Level 17
Level 17
 
Posts: 7093
Joined: Wed Jun 17, 2009 8:20 pm

Re: problems with network shares

Postby altair4 on Mon Mar 12, 2012 3:33 pm

I can mount the share using the file manager but I want to make the connection in the /Home directory rather than on the desktop.

It already is mounted in your home directory. It's at: /home/art/.gvfs/fn40drive2 on Freenas40
If you have nothing in the .gvfs folder then you didn't add a package that debian does not have by default:
Linux Mint Debian Edition Prerequisites

You need to install one package:
Code: Select all
sudo apt-get install gvfs-fuse

You need to add yourself to the fuse group:
Code: Select all
sudo gpasswd -a your_user_name fuse

You need to logoff and login again for the group to actually change.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6267
Joined: Tue Feb 03, 2009 10:27 am

Re: problems with network shares[solved]

Postby arta on Tue Mar 13, 2012 9:37 am

Thanks for the help, Both methods worked. My next question may be how to structure the entry in fstab but I'll work on that before I bother you all again.

Again thanks for the help
Arta
I have fought reality for forty years. I have finally beaten it into submission, but it's fighting back with vigor.
arta
Level 1
Level 1
 
Posts: 29
Joined: Tue Feb 26, 2008 8:28 pm
Location: Louisville, KY

Re: problems with network shares[solved]

Postby altair4 on Tue Mar 13, 2012 10:12 am

Since 2 mount methods were presented to you there are 2 methods to have this automounted. One requires fstab and the other does not.

If you are going with something like this as a manual mount:
sudo mount -t cifs //netbiosname/sharename /media/sharename -o username=winusername,password=winpassword,iocharset=utf8,file_mode=0777,dir_mode=0777

Then the syntax changes a bit in fstab:
Code: Select all
//netbiosname/sharename /media/sharename cifs username=winusername,password=winpassword,iocharset=utf8,file_mode=0777,dir_mode=0777,_netdev 0 0

Note: you will need the _netdev option present to prevent the system from attemping to mount the remote share before your network is up.

If you are using the Nautilus method of mounting your remote shares there is a way to automount this process:

[1] The harder way: Auto Mount Samba Shares on Boot ( GVFS Method ): viewtopic.php?f=42&t=42713

[2] The easiest way: Using Gigolo to Mount Remote Samba Shares: viewtopic.php?f=42&t=52144

I would argue that Gigolo has a lot of advantages in that it solves the 2 big issues with automounting remote shares - the target share is on a box that is not running when fstab is executed, and the target box is shut down before the client system shuts down and hence shutdown is stalled. The fstab method though is the traditional way.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6267
Joined: Tue Feb 03, 2009 10:27 am


Return to Open Discussion

Who is online

Users browsing this forum: No registered users and 2 guests