Audio player problems

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Audio player problems

Postby caris_mere on Thu Sep 09, 2010 3:54 am

I have installed both exaile and decibel-audio-player, and they start up just fine. I add the music, ok. I try to play, they both close immediately.

Here is the output for exaile:

--------------------

(exaile.py:3030): GStreamer-CRITICAL **:
Trying to dispose object "sink", but it still has a parent "bin0".
You need to let the parent manage the object instead of unreffing the object directly.


(exaile.py:3030): GStreamer-CRITICAL **:
Trying to dispose object "gconfaudiosink0", but it still has a parent "bin0".
You need to let the parent manage the object instead of unreffing the object directly.


(exaile.py:3030): GStreamer-CRITICAL **:
Trying to dispose object "rgvolume0", but it still has a parent "bin0".
You need to let the parent manage the object instead of unreffing the object directly.

Traceback (most recent call last):
File "/usr/lib/exaile/xl/gui/main.py", line 1241, in as_play_track
int(track.duration), track.track)
File "/usr/lib/exaile/lib/scrobbler.py", line 149, in now_playing
raise AuthError("Please 'login()' first. (No session available)")
lib.scrobbler.AuthError: Please 'login()' first. (No session available)
Segmentation fault

---------------------

Thanks for the help,
Scott
caris_mere
Level 2
Level 2
 
Posts: 88
Joined: Tue May 20, 2008 8:49 am
Location: Texan in Switzerland

Linux Mint is funded by ads and donations.
 

Re: Audio player problems

Postby kei84 on Sun Sep 12, 2010 1:28 pm

I had the same problem with Exaile.
Exaile has been my default audio player for a while but I wasn't able to make it work on LXDE.
I tried compiling Exaile 3.1.1 and 3.2, but none of them worked. I was able to import the audio files but when I tried to play them, it crashed.

For now, I'm using Banshee.
kei84
Level 3
Level 3
 
Posts: 186
Joined: Tue Apr 14, 2009 8:54 pm
Location: Brazil

Re: Audio player problems

Postby caris_mere on Wed Sep 15, 2010 10:29 am

I guess it is a Gstreamer problem, but I don't know how to fix it.
caris_mere
Level 2
Level 2
 
Posts: 88
Joined: Tue May 20, 2008 8:49 am
Location: Texan in Switzerland

Re: Audio player problems

Postby Oscar799 on Wed Sep 15, 2010 12:08 pm

Thread moved here at OP's request.
oscar799
Forum Admin
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789
User avatar
Oscar799
Level 18
Level 18
 
Posts: 8811
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: Audio player problems

Postby kwevej on Wed Sep 15, 2010 3:08 pm

the same problem here

Code: Select all
(decibel-audio-player.py:7986): GStreamer-CRITICAL **:
Trying to dispose object "sink", but it still has a parent "audiobin".
You need to let the parent manage the object instead of unreffing the object directly.
User avatar
kwevej
Level 5
Level 5
 
Posts: 624
Joined: Mon Mar 22, 2010 3:35 pm
Location: Delft / Prague [@ LMDE]

Re: Audio player problems

Postby craigevil on Thu Sep 16, 2010 1:57 am

Give Aqualung a try.
Aqualung Music Player : http://aqualung.factorial.hu/
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi
craigevil
Level 5
Level 5
 
Posts: 559
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole

Re: Audio player problems

Postby kwevej on Thu Sep 16, 2010 3:26 am

craigevil wrote:Give Aqualung a try.
Aqualung Music Player : http://aqualung.factorial.hu/


Looks like a school project player...
User avatar
kwevej
Level 5
Level 5
 
Posts: 624
Joined: Mon Mar 22, 2010 3:35 pm
Location: Delft / Prague [@ LMDE]

Re: Audio player problems

Postby kwevej on Sun Sep 26, 2010 6:38 am

bump
User avatar
kwevej
Level 5
Level 5
 
Posts: 624
Joined: Mon Mar 22, 2010 3:35 pm
Location: Delft / Prague [@ LMDE]

Re: Audio player problems

Postby timh on Wed Dec 01, 2010 6:29 pm

What's about this Gstreamer error? No help?
I don't want to live with aqualung - I want to go with Pogo a new player from Jendrik
https://launchpad.net/pogo
I like LMDE but this error is awful.
LMDE2 UP7
Image
Image Image
User avatar
timh
Level 3
Level 3
 
Posts: 133
Joined: Thu Oct 25, 2007 2:36 pm
Location: Spain

Re: Audio player problems

Postby kwevej on Thu Dec 02, 2010 6:00 am

uninstall python-gi
viewtopic.php?f=141&t=57716&hilit=+exaile


btw thx for mentioning the Pogo. It looks great. If it'd support last.fm i'd switch to that.
User avatar
kwevej
Level 5
Level 5
 
Posts: 624
Joined: Mon Mar 22, 2010 3:35 pm
Location: Delft / Prague [@ LMDE]

Re: Audio player problems

Postby timh on Thu Dec 02, 2010 10:54 am

kwevej wrote:uninstall python-gi


Thank you very much - now Pogo plays ♫♪ :lol:
LMDE2 UP7
Image
Image Image
User avatar
timh
Level 3
Level 3
 
Posts: 133
Joined: Thu Oct 25, 2007 2:36 pm
Location: Spain

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 6 guests