cannon power shot a495 camera not working on usb

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

cannon power shot a495 camera not working on usb

Postby wltdwiz on Tue Oct 26, 2010 2:07 am

hi all i just installed lmde wow its fast but my cannon power shot a495 camera is not working on usb & neither are my web cams
any ideas they worked fine on linux mint & ubuntu somethings missing but i cant seem to figure out what :oops:
thanks for any help
wltdwiz
Level 1
Level 1
 
Posts: 21
Joined: Mon Oct 29, 2007 7:19 pm

Linux Mint is funded by ads and donations.
 

Re: cannon power shot a495 camera not working on usb

Postby dawgdoc on Tue Oct 26, 2010 8:00 pm

How are you trying to use the a495? When you attach it does nothing happen or does a pop up window appear with an option to open as a folder or F-Spot or another application? Is it that the application shuts down instead of accessing the camera? Or, is there absolutely no indication that you connected the camera?

With the camera attached and turned on, open a terminal and enter
Code: Select all
lsusb
(that's a lowercase L) Please paste the output here, this should indicate if the camera is detected.

Is there a place in the camera's settings to determine how a USB connection is treated?

I have an Olympus Fe-4030 and I must choose from <Auto> <Storage> <MTP> and <Print>. When I connect my camera to the laptop with it set to Storage the dialog I mentioned above opens. if I select folder I can easily drag and drop files. I could then open F-Spot but it was a little fussy. If I connect the camera with it set to <Auto>, it has me choose from the other options from the camera display. When the camera USB is set to MTP and I connect the camera, there is no visible indication that the contact was successful. But, F-Spot will easily import photos from the camera. As an aside, lsusb returns different vendor IDs depending on which USB connection setting I have the camera set to. When it is set to MTP, the terminal output gives a model number of C-350Z, a model that came out 7 years ago. Mine came out in February this year, I believe.

OK, your camera seems to be newer than mine. so check it's set-up options.

As for the webcams, check them with lsusb also. I suggest only having one of these items connected at a time until you get this worked out. If any of them are detected with lsusb, install cheese and see if it can connect with the web cam(s) individually.
Image

SYSTEM: Compaq Presario CQ62 Dual-Boot: Mint 17 Cinnamon, LMDE
READING: Smoke Screen by Dick Francis
User avatar
dawgdoc
Level 9
Level 9
 
Posts: 2716
Joined: Mon Oct 05, 2009 12:53 am
Location: Kentucky, USA the land of Mint Juleps

Re: cannon power shot a495 camera not working on usb

Postby wltdwiz on Tue Oct 26, 2010 10:02 pm

thanks for getting back
heres the terminal readout

lsusb
Bus 005 Device 002: ID 058f:9360 Alcor Micro Corp. 8-in-1 Media Card Reader
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 047d:102d Kensington Pilot Optical
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 005: ID 04a9:31ef Canon, Inc.
Bus 001 Device 002: ID 0ecd:a100 Lite-On IT Corp. LDW-411SX DVD/CD Rewritable Drive
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

the cam loads fine in mint & ubuntu ive checked the package manager but cant fugure out whats missing
p.s nothing happens when i put the camera in & even fstop says cannot claim the usb device wile connecting to the camera
thanks for any help
wltdwiz
Level 1
Level 1
 
Posts: 21
Joined: Mon Oct 29, 2007 7:19 pm

Re: cannon power shot a495 camera not working on usb

Postby dawgdoc on Tue Oct 26, 2010 11:28 pm

I did find this reference to MTP transfer
NTERFACE

Computer
Hi-Speed USB (MTP, PTP) dedicated connector (Mini-B compatible)
HERE

There is a link to the camera's manual on THIS page. Page 35 of the manual says you can transfer files to a computer w/o using their software, but it will take longer and may cause trouble w/ some images.

You could always speed things up by taking the memory card out of the camera and place it in a reader. Until you can find a tutorial on the web. Because of the comment from the Canon page, we will probably find it has something to do with using the mtp-tools package from the repositories.
Image

SYSTEM: Compaq Presario CQ62 Dual-Boot: Mint 17 Cinnamon, LMDE
READING: Smoke Screen by Dick Francis
User avatar
dawgdoc
Level 9
Level 9
 
Posts: 2716
Joined: Mon Oct 05, 2009 12:53 am
Location: Kentucky, USA the land of Mint Juleps

Re: cannon power shot a495 camera not working on usb

Postby wltdwiz on Wed Oct 27, 2010 1:41 am

i tried the mtp-tools but still no cam
i appreciate all your help this is the only problem i haven't solved
ill keep working on it it works in mint & ubuntu something has to be missing
thanks again
wltdwiz
Level 1
Level 1
 
Posts: 21
Joined: Mon Oct 29, 2007 7:19 pm

Re: cannon power shot a495 camera not working on usb

Postby Bolle1961 on Thu Oct 28, 2010 3:33 pm

just install gtkam, that will recognize your canon camera.
this camera doesnot support usb mass storage
if you have more questions feel free to ask them, if necessary i'll make screenshots
Bolle1961
Level 4
Level 4
 
Posts: 212
Joined: Tue Jun 29, 2010 12:59 pm

Re: cannon power shot a495 camera not working on usb

Postby wltdwiz on Fri Oct 29, 2010 2:22 am

thanks for the info but no cam
the a 495 is not listed tried all of the cannons with no results
any ideas you have are more than welcome
mabie a screenshot will help
thanks
wltdwiz
Level 1
Level 1
 
Posts: 21
Joined: Mon Oct 29, 2007 7:19 pm

Re: cannon power shot a495 camera not working on usb

Postby Bolle1961 on Fri Oct 29, 2010 1:49 pm

just click add camera and then detect
then your camera will be detected
Bolle1961
Level 4
Level 4
 
Posts: 212
Joined: Tue Jun 29, 2010 12:59 pm

Re: cannon power shot a495 camera not working on usb

Postby wltdwiz on Sun Oct 31, 2010 1:57 am

clicked add camera but no cam
just cant get this cam to work on lmde
works fine on mint 10 ?
thanks for all the help

Bolle1961 wrote:just click add camera and then detect
then your camera will be detected
wltdwiz
Level 1
Level 1
 
Posts: 21
Joined: Mon Oct 29, 2007 7:19 pm

Re: cannon power shot a495 camera not working on usb

Postby Bolle1961 on Sun Oct 31, 2010 4:52 am

I made a small instruction with screenshots.

If its still not clear let me know

http://ariedejonge.wordpress.com/linux/ ... hot-gtkam/
Bolle1961
Level 4
Level 4
 
Posts: 212
Joined: Tue Jun 29, 2010 12:59 pm

Re: cannon power shot a495 camera not working on usb

Postby wltdwiz on Mon Nov 01, 2010 8:24 pm

still no go
it works fine in mint 10 rc
wltdwiz
Level 1
Level 1
 
Posts: 21
Joined: Mon Oct 29, 2007 7:19 pm

Re: cannon power shot a495 camera not working on usb

Postby Bolle1961 on Tue Nov 02, 2010 1:13 pm

weird

this week i'll make a lmde install and see how / if it works here

did you press the play / view button? it's the button just below the zoom button
Attachments
canon-play.png
canon-play.png (17.58 KiB) Viewed 3779 times
Bolle1961
Level 4
Level 4
 
Posts: 212
Joined: Tue Jun 29, 2010 12:59 pm

Re: cannon power shot a495 camera not working on usb

Postby Bolle1961 on Sat Nov 06, 2010 1:28 pm

installed LMDE and gtkam
and it does not work :(
and that is really strange, in Debian squeeze it just works
gtkam in LMDE and Debian squeeze have the same version number

error message in LMDE is " cannot initialize camera "

i suggest that you make a bugreport on launchpad, and in the meantime use a cardreader
Bolle1961
Level 4
Level 4
 
Posts: 212
Joined: Tue Jun 29, 2010 12:59 pm

Re: cannon power shot a495 camera not working on usb

Postby wltdwiz on Sat Nov 06, 2010 1:46 pm

bollie thanks for trying
wltdwiz
Level 1
Level 1
 
Posts: 21
Joined: Mon Oct 29, 2007 7:19 pm

Re: cannon power shot a495 camera not working on usb

Postby Bolle1961 on Sat Nov 06, 2010 3:16 pm

Tadaaaaaaaaaa :wink:

it works :!: :!: :!: :!:

you must install mtp-tools

Code: Select all
audo apt-get install mtp-tools

or just use synaptic / packet manager


strange thing is, on Debian squeeze i don't have to install mtp-tools, i'll adjust my little manual
Bolle1961
Level 4
Level 4
 
Posts: 212
Joined: Tue Jun 29, 2010 12:59 pm

Re: cannon power shot a495 camera not working on usb

Postby wltdwiz on Sun Nov 07, 2010 10:00 pm

tryed all that still no go
strange :?:
wltdwiz
Level 1
Level 1
 
Posts: 21
Joined: Mon Oct 29, 2007 7:19 pm

Re: cannon power shot a495 camera not working on usb

Postby dawgdoc on Sun Nov 07, 2010 10:10 pm

dawgdoc wrote:Because of the comment from the Canon page, we will probably find it has something to do with using the mtp-tools package from the repositories.
Image

SYSTEM: Compaq Presario CQ62 Dual-Boot: Mint 17 Cinnamon, LMDE
READING: Smoke Screen by Dick Francis
User avatar
dawgdoc
Level 9
Level 9
 
Posts: 2716
Joined: Mon Oct 05, 2009 12:53 am
Location: Kentucky, USA the land of Mint Juleps

Re: cannon power shot a495 camera not working on usb

Postby Bolle1961 on Mon Nov 08, 2010 2:18 am

wltdwiz wrote:tryed all that still no go
strange :?:

yes that's strange, here works the same camera works with Debian squeeze, Linux Mint 9 & 10 and LMDE ( using mtp-tools )
Bolle1961
Level 4
Level 4
 
Posts: 212
Joined: Tue Jun 29, 2010 12:59 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 4 guests