governor in your rc.local? in LMDE (solved)

Old threads created long before the LMDE forum restructuring

governor in your rc.local? in LMDE (solved)

Postby gnimmelf on Tue Nov 09, 2010 4:53 pm

Hi everybody
could someone please show me how to set the governor in your rc.local? (http://www.thinkwiki.org/wiki/How_to_ma ... cy_Scaling)
i found out to set it to "performance" for both of my cpu's, but it goes back to "ondemand" on reboot?
its easy on mint9 and 10 using
sudo gedit /etc/init.d/ondemand
but that doesnt work on LMDE. please describe in detail, im new to mint :D
kind regards gnimmelf
Last edited by gnimmelf on Wed Nov 10, 2010 5:07 pm, edited 1 time in total.
gnimmelf
Level 1
Level 1
 
Posts: 27
Joined: Tue Nov 09, 2010 4:36 pm

Linux Mint is funded by ads and donations.
 

Re: governor in your rc.local? in LMDE

Postby Oscar799 on Tue Nov 09, 2010 5:51 pm

Moved here from Newbie Questions
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789
User avatar
Oscar799
Level 18
Level 18
 
Posts: 8698
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: governor in your rc.local? in LMDE

Postby mads on Tue Nov 09, 2010 7:50 pm

Hi gnimmelf,
have you noticed this part in the article:

"Debian notes
Debian Etch now has rc.local (see package initscripts).
However, a better alternative for Debian, rather than modifying bootscripts, is to install the sysfsutils package. Then edit /etc/sysfs.conf (as root), where you can setup values to sysfs entries that you want to be modified automatically on boot."
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: governor in your rc.local? in LMDE

Postby gnimmelf on Wed Nov 10, 2010 3:01 pm

mads wrote:Hi gnimmelf,
have you noticed this part in the article:

"Debian notes
Debian Etch now has rc.local (see package initscripts).
However, a better alternative for Debian, rather than modifying bootscripts, is to install the sysfsutils package. Then edit /etc/sysfs.conf (as root), where you can setup values to sysfs entries that you want to be modified automatically on boot."


yes i saw that but it seamed like a rather "big" thing, il try it, but i dont no how to "edit /etc/sysfs.conf (as root)" from scratch ( how to find the right file and edit it etc) and what values im going to put in?

kind regards gnimmelf
gnimmelf
Level 1
Level 1
 
Posts: 27
Joined: Tue Nov 09, 2010 4:36 pm

Re: governor in your rc.local? in LMDE

Postby Elisa on Wed Nov 10, 2010 3:04 pm

gnimmelf wrote:...but i dont no how to "edit /etc/sysfs.conf (as root)...
Run in terminal:
gksudo gedit /etc/sysfs.conf
Linux/Unix is about freedom, Windows about slavery.

md5 / sha1 check [how-to for NEWBIES] :idea:

Image
Score: 43 I have some hippie in me. Cool, man 8)
Take the elitemrp.net "Are you a Hippie?" Test
User avatar
Elisa
Level 6
Level 6
 
Posts: 1425
Joined: Wed Aug 18, 2010 6:46 am

Re: governor in your rc.local? in LMDE

Postby gnimmelf on Wed Nov 10, 2010 3:07 pm

Elisa wrote:
gnimmelf wrote:...but i dont no how to "edit /etc/sysfs.conf (as root)...
Run in terminal:
gksudo gedit /etc/sysfs.conf



il try it thanks :D
gnimmelf
Level 1
Level 1
 
Posts: 27
Joined: Tue Nov 09, 2010 4:36 pm

Re: governor in your rc.local? in LMDE

Postby mads on Wed Nov 10, 2010 4:30 pm

Try this procedure:
1- Install sysfsutils, powernowd and cpufrequtils packages (cpufrequtils is probably already installed):
Code: Select all
sudo apt-get install --reinstall cpufrequtils powernowd sysfsutils

2- Edit /etc/sysfs.conf (as root)
Code: Select all
gksudo gedit /etc/sysfs.conf

3- Add (or edit if already there) these lines to /etc/sysfs.conf:
devices/system/cpu/cpu0/cpufreq/scaling_governor = performance
devices/system/cpu/cpu1/cpufreq/scaling_governor = performance
4- Reboot. Verify the result:
Code: Select all
cpufreq-info
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: governor in your rc.local? in LMDE

Postby gnimmelf on Wed Nov 10, 2010 4:43 pm

like this? it works! but should i have added the lines under "Examples:" instead?


# /etc/sysfs.conf - Configuration file for setting sysfs attributes.
#
# The sysfs mount directory is automatically prepended to the attribute paths.
#
# Syntax:
# attribute = value
# mode attribute = 0600 # (any valid argument for chmod)
# owner attribute = root:wheel # (any valid argument for chown)
#
# Examples:
#
# Always use the powersave CPU frequency governor
# devices/system/cpu/cpu0/cpufreq/scaling_governor = powersave
#
# Use userspace CPU frequency governor and set initial speed
# devices/system/cpu/cpu0/cpufreq/scaling_governor = userspace
# devices/system/cpu/cpu0/cpufreq/scaling_setspeed = 600000
#
# Set permissions of suspend control file
# mode power/state = 0660
# owner power/state = root:power

devices/system/cpu/cpu0/cpufreq/scaling_governor=performance
devices/system/cpu/cpu1/cpufreq/scaling_governor=performance
gnimmelf
Level 1
Level 1
 
Posts: 27
Joined: Tue Nov 09, 2010 4:36 pm

Re: governor in your rc.local? in LMDE

Postby mads on Wed Nov 10, 2010 4:54 pm

Looks good but may be "...scaling_governor = performance" instead of "...scaling_governor=performance", but if it works I guess it's ok.
And please add [Solved] to the topic title if everything is ok now.
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: governor in your rc.local? in LMDE

Postby gnimmelf on Wed Nov 10, 2010 5:06 pm

mads wrote:Looks good but may be "...scaling_governor = performance" instead of "...scaling_governor=performance", but if it works I guess it's ok.
And please add [Solved] to the topic title if everything is ok now.


Ok thanks
gnimmelf
gnimmelf
Level 1
Level 1
 
Posts: 27
Joined: Tue Nov 09, 2010 4:36 pm

Linux Mint is funded by ads and donations.
 

Return to Archive

Who is online

Users browsing this forum: No registered users and 1 guest