Screensavers...

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

Screensavers...

Postby tenfoot on Sat Nov 20, 2010 4:45 am

From time to time, when I'm downloading something which will take more than two hours, I go to the Control Centre and untick Activate Screensaver. At the end of the download, I tick it again.

However,the Screensaver doesn't work, unless I restart the computer.

Is anyone else experiencing the same thing?
User avatar
tenfoot
Level 5
Level 5
 
Posts: 593
Joined: Sun Jun 03, 2007 4:12 am
Location: Waipapa, Bay of Islands, New Zealand

Linux Mint is funded by ads and donations.
 

Re: Screensavers...

Postby ShexNivis on Sat Nov 20, 2010 10:01 pm

you get the same using that?
$ gnome-screensaver-command -a
best torrent client ever: http://www.tixati.com
User avatar
ShexNivis
Level 3
Level 3
 
Posts: 109
Joined: Mon Sep 21, 2009 10:25 pm

Re: Screensavers...

Postby tenfoot on Sun Nov 21, 2010 1:55 am

ShexNivis wrote:you get the same using that?
$ gnome-screensaver-command -a


Sorry, ShexNivis, but your answer is a little too cryptic for this old man :cry: Do you mean that if I go into a terminal and issue the command

$ gnome-screensaver-command -a

it is equivalent to restarting the computer?

If that is not what you mean, can you be a tad more explicit, please?
User avatar
tenfoot
Level 5
Level 5
 
Posts: 593
Joined: Sun Jun 03, 2007 4:12 am
Location: Waipapa, Bay of Islands, New Zealand

Re: Screensavers...

Postby ShexNivis on Sun Nov 21, 2010 3:07 am

That command will turn on screensaver on the moment you use it.
So if you going away from your pc and you want to enable the screensaver on it you can do it with Alt+F2 then type: "gnome-screensaver-command -a". Even better, you can create a launcher right-clicking your desktop and pressing create a launcher. Type that command in "command dialog" and type a name for it. You can now use that icon to turn on the screensaver. You can also drag that icon to the panel if you want it there.
Thats just another way of turning on screensaver temporarily. You wont need to open the control panel, change your settings or anything like that, and probably you wont face the problem of having to restart the computer.
If thats not what you want to be able to do I'm probably miss understanding you, if so, sorry about it.

edit: on the other post I meant do you have the 'restart' problem using this method?

edit2: I just realized that maybe what you want to do is exactly the opposite to what I thought. If you use the screensaver and you want to temporarily disable it for a while, open a terminal and type "gnome-screensaver-command -i" you will see that the terminal is 'locked', for the time that you keep that terminal open no screensaver should appear. When you done you can go back to that terminal and press Ctrl+C to stop the "inhibition" of the screensaver.
best torrent client ever: http://www.tixati.com
User avatar
ShexNivis
Level 3
Level 3
 
Posts: 109
Joined: Mon Sep 21, 2009 10:25 pm

Re: Screensavers...

Postby tenfoot on Sun Nov 21, 2010 1:45 pm

ShexNivis wrote:That command will turn on screensaver on the moment you use it.
<snip>
If thats not what you want to be able to do I'm probably miss understanding you, if so, sorry about it.


Nope! that wasn't what I wanted.

ShexNivis wrote:edit: on the other post I meant do you have the 'restart' problem using this method?


Haven't used that method - so don't know whether there would be any restart problems.

ShexNivis wrote:edit2: I just realized that maybe what you want to do is exactly the opposite to what I thought. If you use the screensaver and you want to temporarily disable it for a while, open a terminal and type "gnome-screensaver-command -i" you will see that the terminal is 'locked', for the time that you keep that terminal open no screensaver should appear. When you done you can go back to that terminal and press Ctrl+C to stop the "inhibition" of the screensaver.


Ah! that's the one I want. I'll try the commands you suggest next time I require to temporarily disable the screensaver during a long download. Thank you.
User avatar
tenfoot
Level 5
Level 5
 
Posts: 593
Joined: Sun Jun 03, 2007 4:12 am
Location: Waipapa, Bay of Islands, New Zealand


Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 3 guests