Enabling Compiz

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Enabling Compiz

Postby DarkRubySage on Sun Nov 28, 2010 12:21 pm

Hi, I just installed LMDE! Problem is I can't get compiz going.

compiz --replace generates this:

Xlib: extension "GLX" missing on display ":0.0".
compiz (core) - Fatal: Root visual is not a GL visual
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

Strange, as I can see that other people have no trouble enabling it in LMDE, and I don't with the LM10.
Thanks in advance.
DarkRubySage
Level 1
Level 1
 
Posts: 23
Joined: Sat Oct 31, 2009 7:07 am

Linux Mint is funded by ads and donations.
 

Re: Enabling Compiz

Postby gjringo on Sun Nov 28, 2010 7:42 pm

Xlib: extension "GLX" missing on display ":0.0".

this tells you that you that you do not have the required extension "GLX"

I did a 'Quick search" in (synaptic) package manager for "glx" and this is what I have listed/installed (running Nvidia graphics)in those specific search results:-

libgl1-mesa-glx
libgl1-mesa-dri
mesa-utils

If per chance you run Nvidia and you were to view your Nvidia X Server settings you would find under "Open GL/GLX Information", that Direct Rendering would be a negative or NO or not enabled or something similar

Hope this helps
Image
User avatar
gjringo
Level 1
Level 1
 
Posts: 27
Joined: Fri Sep 10, 2010 3:39 am
Location: Upwey,Victoria,Australia

Re: Enabling Compiz

Postby DJPhil on Mon Nov 29, 2010 9:22 am

I'm setting up LMDE as well, and figured I'd give compiz a try. I get the same error . . .
Code: Select all
Xlib:  extension "GLX" missing on display ":0.0".
compiz (core) - Fatal: Root visual is not a GL visual
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

Launching fallback window manager

This doesn't reload metacity though, and I haven't found a smooth way to start it again short of a logout/login.
I'm using an older ATI card (HD2600XT) with open drivers on two monitors, and somewhat of a noob myself so I'm not sure how to help.

I did some searching and found many folks using a script called compiz-check to troubleshoot. The authors blog entry with download instructions can be found here. My output from this script is as follows . . .

Code: Select all
Gathering information about your system...

 Distribution:          Linux Mint
 Desktop environment:   GNOME
 Graphics chip:         ATI Technologies Inc RV630 [Radeon HD 2600XT]
 Driver in use:         radeon
 Rendering method:      AIGLX

Checking if it's possible to run Compiz on your system...

 Checking for texture_from_pixmap...               [FAIL]
 Checking for non power of two support...          [FAIL]
 Checking for composite extension...               [ OK ]
 Checking for FBConfig...                          [FAIL]
 Checking for hardware/setup problems...           [FAIL]

There has been (at least) one error detected with your setup:
 Error: Another compositing manager in use.

Would you like to know more? (Y/n) Y

 The default window manager of GNOME has its own compositing manager to
 provide basic desktop effects.
 If this one is in use, Compiz will not be able to run.

Do you want to disable GNOME's compositing manager? (Y/n) n


I don't have time to dig very deep right now, but hopefully that will help somewhat.
I'm not too worried about getting compiz running for myself yet, I've got a lot more reading to do first. :)
User avatar
DJPhil
Level 1
Level 1
 
Posts: 9
Joined: Mon Nov 29, 2010 8:40 am

Re: Enabling Compiz

Postby richyrich on Mon Nov 29, 2010 9:58 am

You HAVE to have a graphics card that is capable of hardware 3d, openGL rendering.

http://wiki.compiz.org/Troubleshooting
User avatar
richyrich
Level 13
Level 13
 
Posts: 4635
Joined: Mon May 04, 2009 8:31 pm

Re: Enabling Compiz

Postby DJPhil on Tue Nov 30, 2010 8:59 am

More reading, more misadventure, and definitely more than I can remember, but I got it working. The short version is that I installed fglrx (ATI proprietary driver), worked with it to get back to a stable desktop, and followed this guide from the Debian Wiki (sort of).

I learned a lot as I went (I think). Fglrx seems to like to have an /etc/X11/xorg.conf, and I approve of this. It's neat that the open source drivers are autodetected, but I never did find a good guide explaining how to tweak things on an install with no (and I guess no need for) an xorg.conf.

An important note, compiz is up and running happily on my system and the output of compiz-config is as follows . . .
Code: Select all
Gathering information about your system...

 Distribution:          Linux Mint
 Desktop environment:   GNOME
 Graphics chip:         ATI Technologies Inc RV630 [Radeon HD 2600XT]
 Driver in use:         fglrx
 Rendering method:      None

Checking if it's possible to run Compiz on your system...  [SKIP]

 Checking for hardware/setup problems...           [SKIP]

At least one check had to be skipped:
 Error: No rendering method in use (AIGLX, Xgl or Nvidia)

If I did it again I'd try 'compiz --replace' as soon as the fglrx install was stable. I'd recommend trying without tinkering with xorg.conf as the above guide suggests first, as the hairiest moments came when I had to boot to recovery mode and comment out my alterations from the command line. I think I did a lot of extra fighting trying to make compiz-check happy when it wasn't necessary.

Everything I read suggests that the open source drivers are perfectly capable of running compiz, I just found a different way in my meanderings. I'm sure I've done it the hard way. I just thought to share what I could remember in case it helps someone later.
User avatar
DJPhil
Level 1
Level 1
 
Posts: 9
Joined: Mon Nov 29, 2010 8:40 am

Re: Enabling Compiz

Postby blowtorch on Tue Nov 30, 2010 3:06 pm

DJPhil wrote:This doesn't reload metacity though, and I haven't found a smooth way to start it again short of a logout/login.


Code: Select all
metacity --replace
User avatar
blowtorch
Level 3
Level 3
 
Posts: 101
Joined: Sun Sep 05, 2010 10:03 pm

Re: Enabling Compiz

Postby blowtorch on Tue Nov 30, 2010 3:10 pm

DJPhil wrote:More reading, more misadventure, and definitely more than I can remember, but I got it working. The short version is that I installed fglrx (ATI proprietary driver), worked with it to get back to a stable desktop, and followed this guide from the Debian Wiki (sort of).

I learned a lot as I went (I think). Fglrx seems to like to have an /etc/X11/xorg.conf, and I approve of this. It's neat that the open source drivers are autodetected, but I never did find a good guide explaining how to tweak things on an install with no (and I guess no need for) an xorg.conf.

An important note, compiz is up and running happily on my system and the output of compiz-config is as follows . . .
Code: Select all
Gathering information about your system...

 Distribution:          Linux Mint
 Desktop environment:   GNOME
 Graphics chip:         ATI Technologies Inc RV630 [Radeon HD 2600XT]
 Driver in use:         fglrx
 Rendering method:      None

Checking if it's possible to run Compiz on your system...  [SKIP]

 Checking for hardware/setup problems...           [SKIP]

At least one check had to be skipped:
 Error: No rendering method in use (AIGLX, Xgl or Nvidia)

If I did it again I'd try 'compiz --replace' as soon as the fglrx install was stable. I'd recommend trying without tinkering with xorg.conf as the above guide suggests first, as the hairiest moments came when I had to boot to recovery mode and comment out my alterations from the command line. I think I did a lot of extra fighting trying to make compiz-check happy when it wasn't necessary.

Everything I read suggests that the open source drivers are perfectly capable of running compiz, I just found a different way in my meanderings. I'm sure I've done it the hard way. I just thought to share what I could remember in case it helps someone later.


easiest way to install fglrx viewtopic.php?f=141&t=54885
User avatar
blowtorch
Level 3
Level 3
 
Posts: 101
Joined: Sun Sep 05, 2010 10:03 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 10 guests