Error installing new programs LMDE

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Error installing new programs LMDE

Postby veronicathecow on Sat Dec 11, 2010 9:22 am

Something strange. I have tried to install a number of different programs and am getting these errors.
Tried Abiword and Kompozer and both give the same problems
Any ideas appreciated. Thanks


dpkg: warning: 'ldconfig' not found in PATH or not executable
dpkg: warning: 'start-stop daemon@ not found in PATH or not executable
dpkg: warning: 'update-rc.d' not found in PATH or not executable

P.S. I am running as root, anyone who feel like giving me the lecture, with all due respect, please go and sit in a quiet dark room until the feeling goes away 8-) If I get an want to be nagged I still have my mother and my ex to call upon....
veronicathecow
Level 1
Level 1
 
Posts: 24
Joined: Mon Jul 12, 2010 2:46 am

Linux Mint is funded by ads and donations.
 

Re: Error installing new programs LMDE

Postby viking777 on Sun Dec 12, 2010 7:02 am

P.S. I am running as root


I wouldn't lecture you, imho ALL Linux distros should have a proper root account for use when necessary. But this is the thing, Mint doesn't have a root account, at least not by default. So if you really mean that you are running as root as opposed to just using a root terminal for example, then you must have added the root account yourself. I know this is perfectly possible and 'looks' simple to do, but in reality I have found that it rarely works as it should and this may be the cause of your problem.

My suggestion is that you log out and in again as a normal user and then run the Abiword install with sudo and see if that works. If it does then you can go back to your root account if you wish.

If that doesn't work, google 'exporting path variables'.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Error installing new programs LMDE

Postby veronicathecow on Sun Dec 12, 2010 7:46 pm

Hi viking777, thanks for taking time to reply. Unfortunately it was getting buggier and crashing a lot (I also had lots of problems with the normal x64 mint10) so I have reinstalled x32 gnome mint 10 which seems okay with root updates etc (so far)
I will try again when they release the next version. Am hoping for the speed of Sidux with the ease of use of Mint!
Cheers mate.
veronicathecow
Level 1
Level 1
 
Posts: 24
Joined: Mon Jul 12, 2010 2:46 am


Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 7 guests