Sharing Folders Over Network [SOLVED]

Old threads created long before the LMDE forum restructuring

Sharing Folders Over Network [SOLVED]

Postby Scorpio_Snake on Sun Dec 12, 2010 11:25 am

I am having a problem when I try to share my folders over my network. I shared a folder through nautilus. When I try to access this folder from another computer it is asking for a password. However I never set a password for the folder, nor do I see anywhere to set it or change it.
Last edited by Scorpio_Snake on Sun Dec 12, 2010 4:55 pm, edited 1 time in total.
Scorpio_Snake
Level 1
Level 1
 
Posts: 33
Joined: Sun Oct 31, 2010 10:22 am

Linux Mint is funded by ads and donations.
 

Re: Sharing Folders Over Network

Postby altair4 on Sun Dec 12, 2010 11:36 am

Please post the output of the following commands:
Code: Select all
testparm -s

Code: Select all
net usershare info --long

EDIT: From your description it sounds like you set a guest share in Nautilus so it shouldn't be asking for a password at all. It sounds like a Linux permissions issue not a Samba issue. The output of the two commands above will tell us how you are set up.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5523
Joined: Tue Feb 03, 2009 10:27 am

Re: Sharing Folders Over Network

Postby Scorpio_Snake on Sun Dec 12, 2010 12:15 pm

Code: Select all
Load smb config files from /etc/samba/smb.conf
rlimit_max: rlimit_max (1024) below minimum Windows limit (16384)
Processing section "[homes]"
Processing section "[printers]"
Processing section "[print$]"
Loaded services file OK.
Server role: ROLE_STANDALONE
[global]
   server string = %h server
   obey pam restrictions = Yes
   pam password change = Yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   unix password sync = Yes
   syslog = 0
   log file = /var/log/samba/log.%m
   max log size = 1000
   dns proxy = No
   panic action = /usr/share/samba/panic-action %d

[homes]
   comment = Home Directories
   valid users = %S
   create mask = 0700
   directory mask = 0700
   browseable = No

[printers]
   comment = All Printers
   path = /var/spool/samba
   create mask = 0700
   printable = Yes
   browseable = No

[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers



Code: Select all
[sudo] password for family:
[public]
path=/home/family/Public
comment=
usershare_acl=Everyone:R,Unix User\root:F,
guest_ok=n

[music]
path=/home/family/Music
comment=
usershare_acl=Everyone:R,Unix User\root:F,
guest_ok=n
Scorpio_Snake
Level 1
Level 1
 
Posts: 33
Joined: Sun Oct 31, 2010 10:22 am

Re: Sharing Folders Over Network

Postby Scorpio_Snake on Sun Dec 12, 2010 12:38 pm

Actually it won't let me set a guest share. The option is greyed out for me.
Scorpio_Snake
Level 1
Level 1
 
Posts: 33
Joined: Sun Oct 31, 2010 10:22 am

Re: Sharing Folders Over Network

Postby altair4 on Sun Dec 12, 2010 1:24 pm

Actually you have a lot of things that are discombobulated there. You must not have read my HowTo: viewtopic.php?f=42&t=23169#p135786 :wink:

[1] You need to do the following to the base Debian install in order for Nautilus-shares ( or even Classic Shares ) to work properly:
Linux Mint Debian Edition Preliminary Steps

Step 1: "Guest Access" is disabled.

Open smb.conf as root:
Code: Select all
gksu gedit /etc/samba/smb.conf

Add the following lines to the [global] section:
Code: Select all
usershare allow guests = yes
map to guest = Bad user

And restart samba:
Code: Select all
sudo service samba restart


Step 2: You do not have permissions to create a usershare because you are not included in the correct group.
Code: Select all
sudo gpasswd -a your_user_name sambashare

Then logoff and login again.


[2] As for the other problem - you did not create this share from Nautilus:
Code: Select all
[public]
path=/home/family/Public
comment=
usershare_acl=Everyone:R,Unix User\root:F,
guest_ok=n

You may have done it with a:
sudo net usershare add public /home/family/Public "public" Everyone:R,root:F guest_ok=n

That will work but you're in a catch-22. With no guest access all remote users will be forced to provide a username and password. With guest access enabled no one will be prompted and root will not be recognized and so no one will have write access. One way out of this with usershares is to create two shares on the same target with different names and permissions:
Code: Select all
sudo net usershare add public /home/family/Public "public" Everyone:R guest_ok=y

Code: Select all
sudo net usershare add publicroot /home/family/Public "publicroot" root:F guest_ok=n

BTW do you really want root's password to access that share to enable write.

Get the guest access grayed out problem cleared up first and go from there.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5523
Joined: Tue Feb 03, 2009 10:27 am

Re: Sharing Folders Over Network

Postby Scorpio_Snake on Sun Dec 12, 2010 4:54 pm

I am sorry. I didn't see your other post. Thank you! This worked. And no I don't want to give write access, just able to access and copy files in certain folders.
Scorpio_Snake
Level 1
Level 1
 
Posts: 33
Joined: Sun Oct 31, 2010 10:22 am


Return to Archive

Who is online

Users browsing this forum: No registered users and 3 guests