[Solved] Downgrading Gnome 3.5.3 to 3.4.1

Forum rules
Before you post please read this

[Solved] Downgrading Gnome 3.5.3 to 3.4.1

Postby Inathero on Wed Jul 11, 2012 6:14 pm

I have gnome 3.5.3 and I want to downgrade it to 3.4.1, I searched all over the internet to find out and I just couldn't. I tried switching to something that doesn't rely on gnome, such as ubuntu unity, and remove gnome-shell and gnome-session, then remove the gnome testing ppa, and try to reinstall, but it won't work, says I have missing dependencies, so I have to readd the ppa's and reinstall keeping me stuck on 3.5.3.

I don't mind if I can keep 3.5.3, but I really really want to use the extensions from https://extensions.gnome.org/ , I had 3.4.1 before and the extensions were lovely, but now I can no longer use them :_:

If anyone could help me on this issue, that would be fantastic, thanks!

-------------

For those having the same issues, scroll down 3-4 posts till you see my posts with a big code block, I wrote out exactly what I did to solve my issue =3
Last edited by Inathero on Thu Jul 12, 2012 12:01 am, edited 1 time in total.
Inathero
Level 1
Level 1
 
Posts: 7
Joined: Wed Jul 11, 2012 5:29 pm

Linux Mint is funded by ads and donations.
 

Re: Downgrading Gnome 3.5.3 to 3.4.1

Postby zerozero on Wed Jul 11, 2012 7:17 pm

don't know, you say that you looked all over the internet and couldn't find a way.
can you please post the output of
Code: Select all
inxi -Sr
so we know exactly what we are facing :lol: ?
and also
Code: Select all
apt policy libclutter-1.0-0 libcogl9 mutter libmutter0

tks
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: Downgrading Gnome 3.5.3 to 3.4.1

Postby Inathero on Wed Jul 11, 2012 7:55 pm

Thanks for the response to my hastily written post :D

Code: Select all
inathero@inathero-MacBookPro ~ $ inxi -Sr

System:    Host: inathero-MacBookPro Kernel: 3.2.0-26-generic x86_64 (64 bit) Desktop: Gnome Distro: Linux Mint 13 Maya
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ maya main upstream import
           deb http://archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ precise-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ precise partner
           deb http://packages.medibuntu.org/ precise free non-free
           deb http://archive.getdeb.net/ubuntu precise-getdeb apps
           Active apt sources in file: /etc/apt/sources.list.d/gnome3-team-gnome3-precise.list
           deb http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu precise main
           deb-src http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu precise main
           Active apt sources in file: /etc/apt/sources.list.d/mpodroid-mactel-precise.list
           deb http://ppa.launchpad.net/mpodroid/mactel/ubuntu precise main
           deb-src http://ppa.launchpad.net/mpodroid/mactel/ubuntu precise main
           Active apt sources in file: /etc/apt/sources.list.d/ricotz-testing-precise.list
           deb http://ppa.launchpad.net/ricotz/testing/ubuntu precise main
           deb-src http://ppa.launchpad.net/ricotz/testing/ubuntu precise main
           Active apt sources in file: /etc/apt/sources.list.d/webupd8team-gnome3-precise.list
           deb http://ppa.launchpad.net/webupd8team/gnome3/ubuntu precise main
           deb-src http://ppa.launchpad.net/webupd8team/gnome3/ubuntu precise main


Code: Select all
inathero@inathero-MacBookPro ~ $ apt policy libclutter-1.0-0 libcogl9 mutter libmutter0

libclutter-1.0-0:
  Installed: 1.11.7+git20120627.0ba2d1df-0ubuntu1~12.04~ricotz0
  Candidate: 1.11.7+git20120627.0ba2d1df-0ubuntu1~12.04~ricotz0
  Version table:
 *** 1.11.7+git20120627.0ba2d1df-0ubuntu1~12.04~ricotz0 0
        500 http://ppa.launchpad.net/ricotz/testing/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status
     1.10.6-1~precise1 0
        500 http://archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
     1.10.0-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
libcogl9:
  Installed: 1.10.3+git20120620.6bc94f9f-0ubuntu1~12.04~ricotz0
  Candidate: 1.10.3+git20120620.6bc94f9f-0ubuntu1~12.04~ricotz0
  Version table:
 *** 1.10.3+git20120620.6bc94f9f-0ubuntu1~12.04~ricotz0 0
        500 http://ppa.launchpad.net/ricotz/testing/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status
     1.10.0-0ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
mutter:
  Installed: (none)
  Candidate: 3.5.3+git20120708.255347f8-0ubuntu1~12.04~ricotz1
  Version table:
     3.5.3+git20120708.255347f8-0ubuntu1~12.04~ricotz1 0
        500 http://ppa.launchpad.net/ricotz/testing/ubuntu/ precise/main amd64 Packages
     3.4.1-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
libmutter0:
  Installed: 3.5.3+git20120708.255347f8-0ubuntu1~12.04~ricotz1
  Candidate: 3.5.3+git20120708.255347f8-0ubuntu1~12.04~ricotz1
  Version table:
 *** 3.5.3+git20120708.255347f8-0ubuntu1~12.04~ricotz1 0
        500 http://ppa.launchpad.net/ricotz/testing/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status
     3.4.1-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages

Inathero
Level 1
Level 1
 
Posts: 7
Joined: Wed Jul 11, 2012 5:29 pm

Re: Downgrading Gnome 3.5.3 to 3.4.1

Postby zerozero on Wed Jul 11, 2012 8:17 pm

i imagined that :lol: ricotz&gnome3-team ppa's i've seen that a few times
viewtopic.php?f=205&t=97963&hilit=+ricotz
viewtopic.php?f=208&t=106849&hilit=+ricotz
viewtopic.php?f=90&t=105774&hilit=+ricotz

- have you already tried ppa-purge?
- have you located the most problematic pkgs (libmutter0, the cogl-related ones) and tried a downgrade (force package version in synaptic?)
(sorry if i'm asking the obvious and going through steps that you already went but it's just to tick all the options)

tbh i'm not entirely sure that this can be done (not at the point you got it > with a fully functional 3.5 installed) and that because some of the pkgs/lib you need to downgrade are system-critic.

about extensions (yeahh without them the shell is a bit dry :lol: ) have you tried to visit the site with the shell version=all option
https://extensions.gnome.org/#shell_version=all
not sure if this will work (worth try) but i guess 3.5 is just too beta
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: Downgrading Gnome 3.5.3 to 3.4.1

Postby Inathero on Wed Jul 11, 2012 9:34 pm

I didn't have ppa-purge on my system, and I didn't know there existed such a thing xD Well then, here's my adventure with it, result still inconclusive:

Code: Select all
sudo ppa-purge ppa:ricotz/testing
sudo apt-get update //Just incase
sudo apt-get upgrade //Just incase
sudo apt-get remove gnome-shell
sudo apt-get remove gnome-session
sudo apt-get install gnome-session //fine
sudo apt-get install gnome-shell // no good

The following packages have unmet dependencies:
 gnome-shell : Depends: libmutter0 (< 3.5) but 3.5.3+git20120708.255347f8-0ubuntu1~12.04~ricotz1 is to be installed
               Depends: gnome-shell-common (= 3.4.1-0ubuntu2) but 3.5.3+git20120709.460cda2a-0ubuntu1~12.04~ricotz0 is to be installed
               Depends: gir1.2-gjsdbus-1.0 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

sudo apt-get -f install

he following packages were automatically installed and are no longer required:
  gir1.2-gck-1 mutter-common gir1.2-gcr-3 libmutter0 gir1.2-gdesktopenums-3.0
  gnome-contacts gir1.2-mutter-3.0
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

sudo apt-get autoremove //fine

sudo apt-get install gnome-shell

ckages have unmet dependencies:
 gnome-shell : Depends: gnome-shell-common (= 3.4.1-0ubuntu2) but 3.5.3+git20120709.460cda2a-0ubuntu1~12.04~ricotz0 is to be installed
               Depends: gir1.2-gjsdbus-1.0 but it is not going to be installed
               Recommends: gnome-contacts but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

installed gnome-shell-common was indeed 3.5.3, did complete remove in synaptic package manager, which removed gnome-tweak-tool as well

sudo apt-get install gnome-shell

ckages have unmet dependencies:
 gnome-shell : Depends: gir1.2-gjsdbus-1.0 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

gir1.2-gjsdbus-1.0 wasn't installed in synaptic, if i check to install it, it says that it'll remove:

cinnamon
gjs
gnome-sushi
libgjs0c
mint-meta-connamon
mint-meta-connamon-dvd


So I kinda stopped there, any suggestions on what to do? Or what I need to un-do xD
Inathero
Level 1
Level 1
 
Posts: 7
Joined: Wed Jul 11, 2012 5:29 pm

Re: Downgrading Gnome 3.5.3 to 3.4.1

Postby Inathero on Thu Jul 12, 2012 12:00 am

Code: Select all

ok, i tried to uninstall gir1.2 file, said it depends on libgjs0c and won't install

when to uninstall libgjs0c, said it'll remove the same stuff as gir1.2, said ok, it uninstalled

reinstalled libgjs0c, installed byitself, didn't add anything

went to install gnome-shell, it installed with it's needed dependences, synaptic says it's intalled version is 3.4.1, will check if extensions worked later

because it uninstalled cinnamon, i'm reinstalled it. It installed by itself no issues, didn't install mint-meta-connamon/dvd. Don't know if i need those so leaving as it is

---

ok loged out and logged back into gnome, checked gnome-shell --version, outputted 3.4.1

went to https://extensions.gnome.org, and low and behold, they appear!

Tried to install one, and it works!!

Woot, I managed to fix my problem XD, Thanks for the hint of ppa-purge lol :D



So yay, Everything's fixed, gonna label this as solved.

I'm guessing the issue is that, because cinnamon relies on gnome 3 and that gnome 3.5.3 and 3.4.1 are both.. gnome, they all share the same files, so when I tried to uninstall gnome 3.5.3, considering that cinnamon relies on the same libraries, it wouldn't fully uninstall until i removed cinnamon. After I removed cinnamon, I could uninstall gnome completely, reinstall gnome to 3.4.1, and reinstall cinnamon on top. Hopefully this helps out others with the same issue that I had :D
Inathero
Level 1
Level 1
 
Posts: 7
Joined: Wed Jul 11, 2012 5:29 pm

Re: [Solved] Downgrading Gnome 3.5.3 to 3.4.1

Postby zerozero on Thu Jul 12, 2012 6:33 pm

wow 8) very glad to see that you solved it (and in such a short time as well)
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Linux Mint is funded by ads and donations.
 

Return to Others

Who is online

Users browsing this forum: No registered users and 1 guest