Window manager not finding themes after gnome install

Window manager not finding themes after gnome install

Postby rimbaum on Sun Mar 17, 2013 11:11 am

I have an ASUS x501a that I installed Mint 14 Cinnamon 64-bit onto. After I ran updates, I attempted to install GNOME 3, and apparently attempting to install GNOME caused my window manager (presumably Metacity) to break. The first thing I tried was metacity --replace, and it returned me with
Code: Select all
becca@becca-notebook ~ $ metacity --replace
Window manager warning: Failed to load theme "Adwaita": Failed to find a valid file for theme Adwaita

And so on with each theme I'd installed, ending in
Code: Select all
Window manager error: Could not find a theme! Be sure /usr/share/themes exists and contains the usual themes.

I could only access anything on my desktop at all if I switched to fallback mode, and even then none of the windows had title bars. Interestingly enough, running "sudo metacity --replace" resulted in getting me the window title bars, but the gtk+ themes still aren't running. Also interestingly, opening a folder in Nemo as root gets everything looking normal.

I attached a screenshot so you can see the end result of what I have so far. If I can get any tips on how to get everything working properly again so I can actually use GNOME 3 (or even cinnamon!) instead of the fallback mode, it'd be greatly appreciated.
Attachments
Screenshot3.png
Nemo's root mode after running sudo --replace
Screenshot2.png
After running sudo --replace
Screenshot1.png
Before running sudo --replace


Last bumped by rimbaum on Sun Mar 17, 2013 11:11 am.
User avatar
rimbaum
Level 1
Level 1
 
Posts: 47
Joined: Thu Mar 14, 2013 6:36 pm

Linux Mint is funded by ads and donations.
 

Return to Gnome 3

Who is online

Users browsing this forum: No registered users and 2 guests