Get classic Mint desktop in Gnome shell

Forum rules
Before you post please read this

Re: Get classic Mint desktop in Gnome shell

Postby nidwow on Sat Nov 26, 2011 11:11 am

esteban1uy wrote:
If there is some kind of conflict between extensions, LookingGlass will give us a clue.

Something that nobody takes into account is that faulty extensions, even if they're not enabled, can interfere with the others.



Couldn't capture the text nor take a screenshort, may be there is a way to do it. At any rate too many things to write down so here is what I saw.

Image
nidwow
Level 2
Level 2
 
Posts: 53
Joined: Sat Mar 20, 2010 6:30 am

Linux Mint is funded by ads and donations.
 

Re: Get classic Mint desktop in Gnome shell

Postby esteban1uy on Sat Nov 26, 2011 11:40 am

Hmmm...
What I see there is that your weather extension loads AFTER the reflections. In my system that happens to be the opposite way.

Where are those extensions folders in your system?
Are all at the same place, or are some of them in /usr/share/gnome-shell/extensions/ and some others at .local/share/gnome-shell/extensions/?
Please check that, cause the priority for loading the extensions depends on where they are installed.

Update:

I managed to reproduce your symptoms and it all has to do with the order in which the extensions are loaded. It seems to be somehow important that the reflections extension gets loaded in the last place, and the most weird thing is that it depends on... the date the extension was installed!!! :roll:
So there is an easy way to fix the problem. First of all, be sure you have all your extensions in one of the usual folders. Then make a copy of the reflections folder somewhere else and delete the one in your extensions folder. Restart Gnome-shell, then move the copy you made to its original place, restart Gnome-shell again... ready!

Unbelievable...

I bet that the problem reported by Daniel4lm about the CPU temp. extension popping downwards is caused by the same weird implementation of the order of loading of the extensions. Gosh...
Last edited by esteban1uy on Sat Nov 26, 2011 12:42 pm, edited 1 time in total.
Sorry, I only speak Spanish
User avatar
esteban1uy
Level 5
Level 5
 
Posts: 734
Joined: Sat Nov 12, 2011 6:20 am

Re: Get classic Mint desktop in Gnome shell

Postby arker on Sat Nov 26, 2011 12:42 pm

Hi,
I have some problems with the mint menu and reflection extensions.
The mint menu doesn't show in the right direction, it shows down the bottom panel so I can't see it. When I turn off then turn on the reflection extension, the mint menu works correctly. But when I restart gnome shell or the pc, the mint menu return to show itself down the bottom panel (and not up the bottom panel).
What can I do? Thank you in advance!
arker
Level 1
Level 1
 
Posts: 4
Joined: Wed Feb 03, 2010 8:08 am

Re: Get classic Mint desktop in Gnome shell

Postby esteban1uy on Sat Nov 26, 2011 12:51 pm

arker wrote:Hi,
I have some problems with the mint menu and reflection extensions.
The mint menu doesn't show in the right direction, it shows down the bottom panel so I can't see it. When I turn off then turn on the reflection extension, the mint menu works correctly. But when I restart gnome shell or the pc, the mint menu return to show itself down the bottom panel (and not up the bottom panel).
What can I do? Thank you in advance!


First of all do the same I already recommended, check that all your extensions are in the same folder, then run LookingGlass and check the order the extensions are loaded using the Errors pane. If you see that reflections is loaded BEFORE some other extension, make a copy (do not move it, copy it) of the reflections folder somewhere else, delete the original and restart Gnome-shell (Alt+F2 r). Then move that copy you made back to the extensions folder and restart Gnome-shell again. That should "cure" the symptoms.

Please report the results.
Sorry, I only speak Spanish
User avatar
esteban1uy
Level 5
Level 5
 
Posts: 734
Joined: Sat Nov 12, 2011 6:20 am

Re: Get classic Mint desktop in Gnome shell

Postby nidwow on Sat Nov 26, 2011 3:19 pm

esteban1uy wrote:Hmmm...
What I see there is that your weather extension loads AFTER the reflections. In my system that happens to be the opposite way.

Where are those extensions folders in your system?
Are all at the same place, or are some of them in /usr/share/gnome-shell/extensions/ and some others at .local/share/gnome-shell/extensions/?
Please check that, cause the priority for loading the extensions depends on where they are installed.

Update:

I managed to reproduce your symptoms and it all has to do with the order in which the extensions are loaded. It seems to be somehow important that the reflections extension gets loaded in the last place, and the most weird thing is that it depends on... the date the extension was installed!!! :roll:
So there is an easy way to fix the problem. First of all, be sure you have all your extensions in one of the usual folders. Then make a copy of the reflections folder somewhere else and delete the one in your extensions folder. Restart Gnome-shell, then move the copy you made to its original place, restart Gnome-shell again... ready!

Unbelievable...

I bet that the problem reported by Daniel4lm about the CPU temp. extension popping downwards is caused by the same weird implementation of the order of loading of the extensions. Gosh...


All of the extensions are in /usr/share/gnome-shell/extensions/

Luckily I was able to read your post just right before the forums and mint web site blew up due to the release of another fine distro by Mint Team.

Did what you suggested and I was able to get the details weather above the panel.... :mrgreen: Very interesting :D

So order of installation made it different???

Going to update from RC to release 12 but I guess I have to wait awhile.
nidwow
Level 2
Level 2
 
Posts: 53
Joined: Sat Mar 20, 2010 6:30 am

Re: Get classic Mint desktop in Gnome shell

Postby arker on Sat Nov 26, 2011 4:08 pm

esteban1uy wrote:First of all do the same I already recommended, check that all your extensions are in the same folder, then run LookingGlass and check the order the extensions are loaded using the Errors pane. If you see that reflections is loaded BEFORE some other extension, make a copy (do not move it, copy it) of the reflections folder somewhere else, delete the original and restart Gnome-shell (Alt+F2 r). Then move that copy you made back to the extensions folder and restart Gnome-shell again. That should "cure" the symptoms.

Please report the results.


Thanks for the answer.
Sure, all my extensions are in /usr/share/gnome-shell/extensions/. In lookingGlass was not the first extension loaded by gnome-shell. However I did what you wrote but I still have the same symptoms :(
Edit: I looked on lookingGlass and noticed that now reflection is the first extension loaded (but the reflection folder creation date is the more recent).
arker
Level 1
Level 1
 
Posts: 4
Joined: Wed Feb 03, 2010 8:08 am

Re: Get classic Mint desktop in Gnome shell

Postby Monsta on Sat Nov 26, 2011 4:51 pm

esteban1uy wrote:Well, that Cardapio menu and its extension is some kind of an hybrid between a dock and an extension applet. It seems that the extension part works just like a "launcher" for the real Cardapio thingy, which, by the way, is not coded in javascript. I think it would be even easier to adapt the real MintMenu to the extensions system than trying to make that Cardapio resemble it.

Hmm, maybe I'll take a closer look at it.
Do this experiment: open a terminal and type mintmenu, wait a little and see what happens... aha!

Ah, you mean running the good old Gnome 2 MintMenu from the command line? :) Yeah, I remember I did that while playing around in Gnome Classic.
Monsta
Level 9
Level 9
 
Posts: 2502
Joined: Fri Aug 19, 2011 3:46 am

Re: Get classic Mint desktop in Gnome shell

Postby Daniel4lm on Sat Nov 26, 2011 5:08 pm

arker wrote:Hi,
I have some problems with the mint menu and reflection extensions.
The mint menu doesn't show in the right direction, it shows down the bottom panel so I can't see it. When I turn off then turn on the reflection extension, the mint menu works correctly. But when I restart gnome shell or the pc, the mint menu return to show itself down the bottom panel (and not up the bottom panel).
What can I do? Thank you in advance!


Whether you use, mine or esteban1uy extensions, first, in the Gnome tweak tool turn off bottom panel ext., windowlist and menu. Then turn on reflection, menu and windowlist. Then, restart Gnome shell.
Daniel4lm
Level 2
Level 2
 
Posts: 90
Joined: Tue May 24, 2011 7:14 am

Re: Get classic Mint desktop in Gnome shell

Postby Daniel4lm on Sat Nov 26, 2011 6:27 pm

Well, here are two little things that can be helpful to someone. For example, if you have too many extensions installed, their preview in Gnome tweak tool is relatively bad. You can edit: gksudo gedit /usr/share/gnome-tweak-tool/shell.ui and change a few property settings such as:

<property name="title" translatable="yes"> GNOME Tweak Tool </property>
<property name="resizable"> True </property>

Now the window is changable.

Windows minimizing in Gnome Shell goes to the upper left corner(hotcorner). Edit(gksudo gedit /usr/share/gnome-shell/js/ui/windowManager.js) code line 198 and changes such as;

Code: Select all
Tweener.addTween(actor,
                { scale_x: 0.0,
                  scale_y: 0.0,
                  x: global.screen_width / 2,
                  y: global.screen_height / 2,
                  time: WINDOW_ANIMATION_TIME,
                  transition: 'easeOutQuad',
                  onComplete: this._minimizeWindowDone,
                  onCompleteScope: this,
                  onCompleteParams: [shellwm, actor],
                  onOverwrite: this._minimizeWindowOverwritten,
                  onOverwriteScope: this,
                  onOverwriteParams: [shellwm, actor]
                 });


Save and restart Gnome shell. Differences in minimizing ?
Daniel4lm
Level 2
Level 2
 
Posts: 90
Joined: Tue May 24, 2011 7:14 am

Re: Get classic Mint desktop in Gnome shell

Postby esteban1uy on Sat Nov 26, 2011 7:10 pm

arker wrote:Thanks for the answer.
Sure, all my extensions are in /usr/share/gnome-shell/extensions/. In lookingGlass was not the first extension loaded by gnome-shell. However I did what you wrote but I still have the same symptoms :(
Edit: I looked on lookingGlass and noticed that now reflection is the first extension loaded (but the reflection folder creation date is the more recent).


So, do the "trick" made things go exactly the opposite of what was intented (reflections loading at last place)?
Are you sure you restarted Gnome-shell after deleting reflections folder and again after replacing it?

@Daniel4lm
Did you noticed some change in the extensions behaviour (menus popping downwards) after applying our "trick"?
Sorry, I only speak Spanish
User avatar
esteban1uy
Level 5
Level 5
 
Posts: 734
Joined: Sat Nov 12, 2011 6:20 am

Re: Get classic Mint desktop in Gnome shell

Postby arker on Sat Nov 26, 2011 8:27 pm

esteban1uy wrote:So, do the "trick" made things go exactly the opposite of what was intented (reflections loading at last place)?
Are you sure you restarted Gnome-shell after deleting reflections folder and again after replacing it?


Yes I'm sure. However now I got it working, tried again the trick after restoring all the MGSE from synaptic. Thank you!
But now, despite I chose extensions2.zip, I get the clock and not the user applet at bottom right corner. If I disable then enable the move clock extension I get the right layout (user applet at bottom right corner), but this lasts until I restart gnome shell.
Tried the same trick used for reflection but didn't work. Not a big issue though, I can live with that.
arker
Level 1
Level 1
 
Posts: 4
Joined: Wed Feb 03, 2010 8:08 am

Re: Get classic Mint desktop in Gnome shell

Postby esteban1uy on Sat Nov 26, 2011 9:15 pm

arker wrote: If I disable then enable the move clock extension I get the right layout (user applet at bottom right corner), but this lasts until I restart gnome shell.


Do you have the notifications extension enabled?
If not, enable it, restart Gnome shell and post the results.

I'm a little bit shocked about our "discovery" that the loading order of the extensions depends on the date each of them were installed. That weird implementation made by the Gnome developers can potentially lead to A LOT of problems.
As anyone can see, if two extensions change some specific configuration (for example, the position of the clock) there MUST be some way to stablish which one will do it first and wich latter. That's a very BASIC principle. But Gnome-shell does not have it!

So now it is very important to explain to the people the exact order in which available extensions must be installed.

At least we know that reflections extension must always be installed LAST.

I think this is the right time to start creating some kind of "knowledge base" about every extension we plan to use: how it works, how to install it, which previously installed extensions can be affected/affecting. Maybe a dedicated sub-forum...
Sorry, I only speak Spanish
User avatar
esteban1uy
Level 5
Level 5
 
Posts: 734
Joined: Sat Nov 12, 2011 6:20 am

Re: Get classic Mint desktop in Gnome shell

Postby arker on Sun Nov 27, 2011 7:21 am

esteban1uy wrote:Do you have the notifications extension enabled?
If not, enable it, restart Gnome shell and post the results.

Yes I had that extension enabled. Don't know why, but I repeated exactly what I done yesterday and now everything works flawless. In lookingGlass Reflection is the last extension loaded and Move to clock is the penultimate.
I find out that all depends on the "last changed" date, not the "date modified" (despite the name, I think date modified is the date of creation in both Gnome 2 and 3).

Daniel4lm wrote:Whether you use, mine or esteban1uy extensions, first, in the Gnome tweak tool turn off bottom panel ext., windowlist and menu. Then turn on reflection, menu and windowlist. Then, restart Gnome shell.


Just tried your extensions: now the menu works flawless also if reflection is not the last extension loaded in gnome-shell. Thank you all guys!
I think you should merge yours and esteban1uy extensions' in a single package.
Last edited by arker on Sun Nov 27, 2011 7:50 am, edited 1 time in total.
arker
Level 1
Level 1
 
Posts: 4
Joined: Wed Feb 03, 2010 8:08 am

Re: Get classic Mint desktop in Gnome shell

Postby esteban1uy on Sun Nov 27, 2011 7:50 am

arker wrote:
esteban1uy wrote:Do you have the notifications extension enabled?
If not, enable it, restart Gnome shell and post the results.

Yes I had that extension enabled. Don't know why, but I repeated exactly what I done yesterday and now everything works flawless. In lookingGlass Reflection is the last extension loaded and Move to clock is the penultimate.
I find out that all depends on the "last changed" date, not the "date modified" (despite the name, I think date modified is the date of creation in both Gnome 2 and 3).


That's right!!!

I did an experiment and confirmed that behaviour you noticed: you can modify, edit, etc, an extension and it doesn't affect the loading order. That changes only if you install or uninstall an extension (meaning adding or deleting its folder from /urs/share/gnome-shell/extensions/ and restarting gnome-shell).
On the other hand, carefully looking the output of LookingGlass reveals that certain extensions are loaded in alphabetic order: that's a really useful hint of what's going on...

It all depends on the moment that Gnome-shell has detected the presence of a change in the set of extensions, and that only seems to happen after a shell restart!

So this is my conclusion:

If you install an extension, then you restart Gnome-shell, then you install another extension and restart again, the order of loading will be purely chronological (FIFO).
But if you install two extensions and then you restart Gnome-shell, their relative order depends on their names... so weird!
Sorry, I only speak Spanish
User avatar
esteban1uy
Level 5
Level 5
 
Posts: 734
Joined: Sat Nov 12, 2011 6:20 am

Re: Get classic Mint desktop in Gnome shell

Postby d00med on Sun Nov 27, 2011 3:26 pm

I read through this thread and still don't know how to position the top bar at the bottom of the screen, and being able to change the font on it might make it a bit more tolerable. Would I have to edit a CSS file?
d00med
Level 4
Level 4
 
Posts: 333
Joined: Fri Nov 26, 2010 9:55 am

Re: Get classic Mint desktop in Gnome shell

Postby KBD47 on Sun Nov 27, 2011 5:58 pm

I quit wrestling with MGSE. Gnome Fallback/Classic is much easier to configure the way I like it. As I just posted elsewhere:
Why not use Mint 12 in fallback? It comes out of the box with fallback, you just need to log in. I installed Mint 12 to all 4 of our computers and all 4 are set up in Gnome Classic/Fallback mode. You just use the alt-right-click on the panel to move and adjust and add things, not really much different than Gnome 2. And you can adjust the panel to solid color which isn't solid at all but makes the bottom panel see through, which is nice. I have 2 of our computers with the traditional 2 panel set up like in Ubuntu 11.04 fallback, the other two I have set up with just one bottom panel.
KBD47
KBD47
Level 6
Level 6
 
Posts: 1028
Joined: Fri Jul 29, 2011 12:03 am

Re: Get classic Mint desktop in Gnome shell

Postby esteban1uy on Sun Nov 27, 2011 6:24 pm

d00med wrote:I read through this thread and still don't know how to position the top bar at the bottom of the screen, and being able to change the font on it might make it a bit more tolerable. Would I have to edit a CSS file?


Here we go...

To have just one "taskbar" (aka "main panel", "top bar", etc.) using Gnome 3.2 (not Classic nor MATE) you have to use a tweaked version of an extension named "reflections" (you'll find it at this thread).

And you can also use some other extensions to modify the look of the panel, because reflections is not able to change everything to resemble the old Gnome taskbar.

If you want better fonts you can use a nice shell-theme (for example: Minty). Some of the themes around work without a problem since you install them, a few need some tweaking to correct small flaws, because designers did't know that you can have only one panel at the bottom of the screen.
Sorry, I only speak Spanish
User avatar
esteban1uy
Level 5
Level 5
 
Posts: 734
Joined: Sat Nov 12, 2011 6:20 am

Re: Get classic Mint desktop in Gnome shell

Postby esteban1uy on Sun Nov 27, 2011 6:36 pm

KBD47 wrote:I quit wrestling with MGSE. Gnome Fallback/Classic is much easier to configure the way I like it. As I just posted elsewhere:
Why not use Mint 12 in fallback? It comes out of the box with fallback, you just need to log in. I installed Mint 12 to all 4 of our computers and all 4 are set up in Gnome Classic/Fallback mode. You just use the alt-right-click on the panel to move and adjust and add things, not really much different than Gnome 2. And you can adjust the panel to solid color which isn't solid at all but makes the bottom panel see through, which is nice. I have 2 of our computers with the traditional 2 panel set up like in Ubuntu 11.04 fallback, the other two I have set up with just one bottom panel.
KBD47


That's very reasonable indeed.

In Fallback/Classic mode you simply use Alt+Right Click to get what you want: move the panel to the bottom, change the position of every applet, add/remove/configure...

The problem is that Fallback/Classic is somehow "marked for deletion". Gnome people clearly said that this is the last release that will include Fallback mode.
So, why not start getting what we want using plain Gnome-shell?

At this very moment we have three "out-of-the-box" options (Gnome-shell, Fallback/Classic and Mate). In a near future we are going to have only two (bye bye Fallback). So the point is: get what you want (or the most of it) using whichever desktop environment you choose.

Here we (plain ordinary users) are trying to share with some other users some tricks, tweaks, workarounds, etc., that give us the freedom to move from desktop to desktop having what we want in any of them.
Last edited by esteban1uy on Sun Nov 27, 2011 6:55 pm, edited 1 time in total.
Sorry, I only speak Spanish
User avatar
esteban1uy
Level 5
Level 5
 
Posts: 734
Joined: Sat Nov 12, 2011 6:20 am

Re: Get classic Mint desktop in Gnome shell

Postby KBD47 on Sun Nov 27, 2011 6:44 pm

I'm hoping Fallback will make it to the LTS releases next Spring, or that by then both MGSE and MATE are much more mature and are ready to fully replace Gnome 2 and Gnome 3 Fallback.
KBD47
KBD47
Level 6
Level 6
 
Posts: 1028
Joined: Fri Jul 29, 2011 12:03 am

Re: Get classic Mint desktop in Gnome shell

Postby esteban1uy on Sun Nov 27, 2011 7:06 pm

d00med wrote:I read through this thread and still don't know how to position the top bar at the bottom of the screen, and being able to change the font on it might make it a bit more tolerable. Would I have to edit a CSS file?


By the way, looking at you avatar I'm fully convinced that you'll be delighted using THIS shell theme:

Image

And you can use THIS as Gtk+ theme for a more polished look.
Sorry, I only speak Spanish
User avatar
esteban1uy
Level 5
Level 5
 
Posts: 734
Joined: Sat Nov 12, 2011 6:20 am

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Others

Who is online

Users browsing this forum: No registered users and 2 guests