alt-key hijacked

Forum rules
Before you post please read this

alt-key hijacked

Postby mint-o-licious on Fri Feb 03, 2012 9:13 am

I use the alt-key in several apps. Now with gnome3 that key is mapped to drag window. Completely breaks functionality of many softwares.
How can I have it not do that and let me use the alt key as an alt-key?

I have tried System Tools>System Settings>Keyboard Layout>Layouts Tab>Options but haven't found any option there that let's me use alt-key normally.
mint-o-licious
Level 1
Level 1
 
Posts: 41
Joined: Thu Feb 10, 2011 10:48 am

Linux Mint is funded by ads and donations.
 

Re: alt-key hijacked

Postby xenopeek on Sat Feb 04, 2012 5:22 pm

Open a terminal, and run:
Code: Select all
gconftool-2 -t str --set /apps/metacity/general/mouse_button_modifier ""

This disables the right alt key as modifier to drag windows around.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14996
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: alt-key hijacked

Postby mint-o-licious on Mon Feb 06, 2012 4:41 am

I had no Metacity entries in gconfeditor.
I had /apps/marco/general/mouse_button_modifier which was set to <alt>. I removed that value but it did not help, alt is still dragging windows around.
mint-o-licious
Level 1
Level 1
 
Posts: 41
Joined: Thu Feb 10, 2011 10:48 am

Re: alt-key hijacked

Postby viking777 on Mon Feb 06, 2012 5:52 am

Try looking at it another way. The behaviour you describe is what most people want, and it can be very useful at times, so instead of trying to change that, why don't you try and change shortcuts you have that make use of it? For example make the shortcut Ctl/Alt instead of just Alt? I am sure that is going to be a whole lot easier and I have had to do it myself in one case.

Edit. Actually you might not even have to do that. If you go to System Settings>Keyboard>Shortcuts>Custom Shortcuts and create a new shortcut using the Alt key Gnome will show you a warning dialogue telling you that Alt is mapped to 'Resize Window' and ask you if you would like to reassign it.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: alt-key hijacked

Postby mint-o-licious on Mon Feb 06, 2012 5:59 am

viking777 wrote:..so instead of trying to change that, why don't you try and change shortcuts you have that make use of it?..

Because many of the softwares I'm using is heavily relying on the alt-key. some of them is proprietary where I cannot change it's alt-key behaviour.
So, thank you, but I do want to keep my alt-key used as an alt-key.
viking777 wrote:...The behaviour you describe is what most people want, and it can be very useful at times...

Yes, but I do want to choose myself what key-combo triggers moving windows. In compiz I had it set to ctrl+flag+alt-drag.
I feel gnome3 is very blunt and dumbed down compared to compiz where I can change pretty much what I want.
viking777 wrote:Edit. Actually you might not even have to do that. If you go to System Settings>Keyboard>Shortcuts>Custom Shortcuts and create a new shortcut using the Alt key Gnome will show you a warning dialogue telling you that Alt is mapped to 'Resize Window' and ask you if you would like to reassign it.

Can I map "alt" to "alt" that way?
Last edited by mint-o-licious on Mon Feb 06, 2012 6:04 am, edited 1 time in total.
mint-o-licious
Level 1
Level 1
 
Posts: 41
Joined: Thu Feb 10, 2011 10:48 am

Re: alt-key hijacked

Postby xenopeek on Mon Feb 06, 2012 6:01 am

mint-o-licious wrote:I had no Metacity entries in gconfeditor.
I had /apps/marco/general/mouse_button_modifier which was set to <alt>. I removed that value but it did not help, alt is still dragging windows around.

Erm, I didn't suggest you go look for the setting. I gave you a command to run :wink: Run the command, it works.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14996
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: alt-key hijacked

Postby mint-o-licious on Mon Feb 06, 2012 6:28 am

>Vincent. Sorry was to lazy to copy-paste as I read your post on another computer than the one having gnome3-problems...
Now I did it and it partially worked.
I now can use alt for keyboard-shortcuts but not for mouse-combinations. I can't alt-click on objects...
mint-o-licious
Level 1
Level 1
 
Posts: 41
Joined: Thu Feb 10, 2011 10:48 am

Re: alt-key hijacked

Postby xenopeek on Mon Feb 06, 2012 12:08 pm

Ah. That makes kinda sense. Perhaps it needs to be disabled at a different level for the right alt key still to be able to be bound to other mouse actions...

You should be able to bind the left alt to mouse actions though.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14996
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: alt-key hijacked

Postby mint-o-licious on Tue Feb 07, 2012 4:23 am

I switched to mate with compiz which solved this issue and all others I had with gnome3. It just feels so dumbed down, an enviroment for preschool, not suited for workstations at all.
mint-o-licious
Level 1
Level 1
 
Posts: 41
Joined: Thu Feb 10, 2011 10:48 am

Re: alt-key hijacked

Postby kjrunner on Tue Apr 17, 2012 12:44 pm

Has anyone found a solution to this? As above I am using mate on lmde and cannot get the windows manager from hijacking <Alt>Button1. Always tries to move the window. I have changed the setting in gconf-editor /apps/metacity/general/mouse_button_modifier; I have also disabled the setting in compiz manager. I also ran the command given earlier in this thread. After all this a <Alt> left mouse button still moves the window.

All help appreciated.
KJ
kjrunner
Level 1
Level 1
 
Posts: 3
Joined: Fri Apr 29, 2011 2:52 pm

Re: alt-key hijacked

Postby Kaetemi on Sat Aug 25, 2012 11:15 am

kjrunner wrote:Has anyone found a solution to this? As above I am using mate on lmde and cannot get the windows manager from hijacking <Alt>Button1. Always tries to move the window. I have changed the setting in gconf-editor /apps/metacity/general/mouse_button_modifier; I have also disabled the setting in compiz manager. I also ran the command given earlier in this thread. After all this a <Alt> left mouse button still moves the window.

All help appreciated.
KJ

Works when using mateconf-editor instead ;)
Kaetemi
Level 1
Level 1
 
Posts: 6
Joined: Fri Apr 27, 2012 6:23 am

Linux Mint is funded by ads and donations.
 

Return to Others

Who is online

Users browsing this forum: No registered users and 3 guests