Treat password dialog and run dialog as normal windows?

Forum rules
Before you post please read this

Treat password dialog and run dialog as normal windows?

Postby robbyb413 on Sat Mar 03, 2012 2:20 pm

Looking for help configuring Gnome 3 on Linux Mint 12. I need to disable screen grabbing when a password dialog or the run dialog are activated so that I can use an onscreen keyboard to enter my password or to enter the command I'd like to run.

In Gnome 2 this could be accomplished by going to Assistive Technologies and checking a box that would effect the desired change, but unless I am overlooking something I'm not seeing that functionality carried over to Gnome 3.

I do have OnBoard and Caribou enabled - neither works when a password dialog or run dialog is on the screen. OnBoard does have a check box for using it with password dialogs but enabling/disabling seems to do nothing. I have checked and unchecked that in OnBoard .96, as included with Mint 12, and also in OnBoard .97 installed from the Precise Pangolin repos, no change in behavior with either version.

I checked 'gsettings' and nothing jumped out at me as an obvious choice.

Does anyone have any idea where this setting was moved? Thanks in advance for any help and advice anyone offers.
robbyb413
Level 1
Level 1
 
Posts: 11
Joined: Sun Feb 19, 2012 5:13 pm

Linux Mint is funded by ads and donations.
 

Re: Treat password dialog and run dialog as normal windows?

Postby bimsebasse on Sat Mar 03, 2012 2:27 pm

Gnome Shell/Cinnamon has onscreen keyboard built in by default. In Cinnamon you need to enable the applet Accessibility in Cinnamon Settings (and enable On Screen Keyboard as seen in the top right corner here: http://cinnamon-spices.linuxmint.com/up ... 8-HL7N.png), In Gnome Shell (MGSE, what you seen in Mint 12 if you haven't changed login session) the Accessibility panel applet is already in the panel.
Thank you for this thread. That’s all I can say. You most definitely have made this forum into something special. You clearly know what you are doing, you’ve covered so many bases. Thanks!
User avatar
bimsebasse
Level 7
Level 7
 
Posts: 1709
Joined: Fri Nov 11, 2011 10:21 am
Location: Scandinavia

Re: Treat password dialog and run dialog as normal windows?

Postby robbyb413 on Sat Mar 03, 2012 2:46 pm

Hi bimsebasse,

Thanks for the response. Unfortunately that doesn't answer the question. I'm not having trouble enabling the assistive technologies and the keyboards (Caribou, to which I refer in my original post, is the defualt keyboard to with you refer in your post). The trouble is after they're enabled.

The issue is that by default in GNOME3 the shell will "grab" the screen when a password dialog box pops up as a security measure (and also when the run dialog comes up, as it happens) and as a by-product will not allow use of either Caribou or OnBoard to enter passwords. While the onscreen keyboards are present, touching the virtual keys does nothing to enter text in the dialog box. When the box is remove the onscreen keyboards return to functioning as normal.

There used to be an option within assistive technologies to treat password dialog boxes as regular windows, it was a check box, which kept GONOME from allong with windows to grab focus. This would allow a user to accomplish text entry with the on-screen keyboard of their choice. In GNOME 3 this seems to have disappeared as a check box, and I have not found a matching option in so I am looking for information as to where the ability has been moved.
robbyb413
Level 1
Level 1
 
Posts: 11
Joined: Sun Feb 19, 2012 5:13 pm

Re: Treat password dialog and run dialog as normal windows?

Postby bimsebasse on Sat Mar 03, 2012 3:07 pm

Ah, OK, well I can't get it to work with modal dialogs either and it seems it's a genuine Gnome Shell bug: https://bugzilla.gnome.org/show_bug.cgi?id=657986 - at least they're aware of it.
Thank you for this thread. That’s all I can say. You most definitely have made this forum into something special. You clearly know what you are doing, you’ve covered so many bases. Thanks!
User avatar
bimsebasse
Level 7
Level 7
 
Posts: 1709
Joined: Fri Nov 11, 2011 10:21 am
Location: Scandinavia

Re: Treat password dialog and run dialog as normal windows?

Postby robbyb413 on Sat Mar 03, 2012 3:20 pm

Ok, I was hoping it was a setting I missed, but guess not. Thanks for the help. I will review the bugzilla info later when I'm back at a computer.

Have a good one. :thumbup:

--[Tapatalk/Nexus One]--
robbyb413
Level 1
Level 1
 
Posts: 11
Joined: Sun Feb 19, 2012 5:13 pm

Re: Treat password dialog and run dialog as normal windows?

Postby robbyb413 on Thu Oct 04, 2012 6:41 pm

This still persists in Mint 13. In case any other Tablet users find this thread and are looking for the fix, I was able to partially fix it with advice in Mint 13 (but not Mint 12) from this thread:

http://gnomeshell.wordpress.com/2011/09 ... -behavior/

Code: Select all
gconftool-2 --set /desktop/gnome/shell/windows/attach_modal_dialogs false --type bool


Seems to work for all password dialogs. It does not seem to work for Alt+F2. Still working on that. If anyone has advice there it would be welcome.
robbyb413
Level 1
Level 1
 
Posts: 11
Joined: Sun Feb 19, 2012 5:13 pm


Return to Others

Who is online

Users browsing this forum: No registered users and 3 guests