Nautilus only using default theme

Forum rules
Before you post please read this

Nautilus only using default theme

Postby Ertain on Thu Mar 01, 2012 12:13 am

Hello Minty ones. About a month ago my desktop, and to a lesser extent Nautlius, was only using the default theme. I tried to change the theme using Advanced Settings but alas it didn't work. I also tried reinstalling Nautilus and a few of its data packs, but that didn't work, either. I went on to the Linux Mint IRC channel and asked them about it. Luckily, they told me how to fix it. Now I'm having the same problem, and I sadly can't figure out how to fix it again. Also, I'm using the Faenza-Radience icon theme, but it has changed the icon theme, as well.

Attached is a screenshot of Nautilus.
Attachments
Nautilus_improper_theme.png
Screenshot of Nautilus with improper theme.
Nautilus_improper_theme.png (41.04 KiB) Viewed 1652 times
Ertain
Level 1
Level 1
 
Posts: 14
Joined: Tue Jan 17, 2012 4:41 pm

Linux Mint is funded by ads and donations.
 

Re: Nautilus only using default theme

Postby bimsebasse on Thu Mar 01, 2012 1:57 am

Usually the explanation is that you have installed the theme into ~/.themes/ and go into root mode in nautilus, nautilus will then use the fallback theme. If you have your theme in that folder, try to put it into /usr/share/themes/ instead. I always put everything into usr/share... to avoid this kind of thing happening.
Thank you for this thread. That’s all I can say. You most definitely have made this forum into something special. You clearly know what you are doing, you’ve covered so many bases. Thanks!
User avatar
bimsebasse
Level 7
Level 7
 
Posts: 1709
Joined: Fri Nov 11, 2011 10:21 am
Location: Scandinavia

Re: Nautilus only using default theme

Postby Ertain on Thu Mar 01, 2012 3:08 pm

I think using Nautilus as root is a part of the problem, because I did use Nautilus as root. But there may be another thing I have to do, such as removing or just moving a directory.

Still, I'll try copying the theme into /usr/share/themes/.

Edit:
*Tries that*

Nope, didn't work.
Ertain
Level 1
Level 1
 
Posts: 14
Joined: Tue Jan 17, 2012 4:41 pm

Re: Nautilus only using default theme

Postby Ertain on Sat Mar 03, 2012 1:12 pm

I have read in this thread that using the command
Code: Select all
rm -vr ~/.gconf/apps/nautilus && killall nautilus

has worked for most people. While it worked for me before it didn't work this time. :(

Ninja edit:
So apparently gnome-settings-daemon is exiting before it can apply the proper theme. While using gnome-settings-daemon as root sets the theme it doesn't always stay that way. In other words it goes away after reboot.
Ertain
Level 1
Level 1
 
Posts: 14
Joined: Tue Jan 17, 2012 4:41 pm

Theme doesn't stay after reboot

Postby Ertain on Tue Jul 10, 2012 9:04 pm

Hello everyone. I have had this problem for months but even after updating to Maya it won't go away. I'm still having the problem where I have to keep using the commands
Code: Select all
killall nautilus
# then
gksu gnome-settings-daemon

just to keep my theme. Otherwise when I restart my computer (or even log out of Cinnamon) I lose my theme. Changing the system settings (Cinnamon or otherwise) doesn't work. I have tried using dconf-tools but that doesn't work. I have tried clearing out ~/.config/nautilus but that doesn't work. I have tried using the Ubuntu-Tweak-Tool but that doesn't work. I have tried using the command
Code: Select all
sleep 10; /usr/lib/gnome-settings-daemon/gnome-settings-daemon

in the desktop file for gnome-settings-daemon in /etc/xdg/autostart/ but that doesn't work. I have tried adding the script
Code: Select all
#!/bin/bash

pid=$(pgrep gnome-settings-)

while [ -n "$pid" ];
do
  pid=$(pgrep gnome-settings-)
  sleep 0
done

exit 0

to /etc/xdg/autostart/gnome-settings-daemon.desktop but that doesn't work, either.

I know it has something to do with the proprietary nVidia driver, but that actually makes my system work the way it was suppose to work. If anyone's wondering I'm using an Intel i7-2600 CPU at 3.4 Gigs with an nVidia GeForce GT 530 graphics card on Linux Mint 13 64-bit edition.
Ertain
Level 1
Level 1
 
Posts: 14
Joined: Tue Jan 17, 2012 4:41 pm

Re: Nautilus only using default theme

Postby viking777 on Wed Jul 11, 2012 11:46 am

Threads merged - same topic.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Nautilus only using default theme

Postby Ertain on Thu Jul 12, 2012 2:41 am

Thanks viking777.

...But it still doesn't help me. :(
Ertain
Level 1
Level 1
 
Posts: 14
Joined: Tue Jan 17, 2012 4:41 pm

Linux Mint is funded by ads and donations.
 

Return to Others

Who is online

Users browsing this forum: No registered users and 0 guests