failed to load session "ubuntu" at boot [SOLVED]

failed to load session "ubuntu" at boot [SOLVED]

Postby nspboarderdude on Mon Mar 04, 2013 12:57 am

Mint 14 Mate 64-bit is the system. Here is the situation:

I was trying to create a Docky launcher that brings up the MATE shutdown dialog. I now know the correct command to use is "mate-session-save --shutdown-dialog" however I tried to mimic the command I used on my Mint 14 Cinnamon machine, which is "gnome-session-quit --power-off." The command did not work and the terminal spit out something like "thats currently not installed, you can install it with sudo apt-get install gnome-session" which I foolishly did (I don't exactly remember the name). Now after login there is a single dialog box that says "failed to load session ubuntu" and at that point I cannot do anything except hit the power button.

I have all the data backed up so I am not worried about doing a fresh reinstall, if it comes to that, but it would still be a pain in the backside. Is there someway I could login via recovery mode to fix this? Some additional clues: I was using Compiz, and I believe it was acting as the window manager.

Any help would be appreciated.
Last edited by nspboarderdude on Mon Mar 04, 2013 10:38 am, edited 1 time in total.
nspboarderdude
Level 1
Level 1
 
Posts: 5
Joined: Sun May 27, 2012 1:26 pm

Linux Mint is funded by ads and donations.
 

Re: failed to load session "ubuntu" at boot

Postby catweazel on Mon Mar 04, 2013 1:13 am

There should be an option to choose a different session at the login screen. Try selecting one from there before troubleshooting further.
Mint Testing Team & Mint Donor #3606
KDE 4.12.0, custom preemptive kernel 3.12.5,
Intel i7 4770K @ 4.7GHz, 16GB 2666MHz XMP,
4 Samsung 840 PRO 512GB SSDs in RAID0,
6TB HW RAID10, dual 24" Acer X243H,
Gigabyte nVidia GTX 680 Super Overclock
User avatar
catweazel
Level 7
Level 7
 
Posts: 1656
Joined: Fri Oct 12, 2012 9:44 pm

Re: failed to load session "ubuntu" at boot

Postby nspboarderdude on Mon Mar 04, 2013 10:38 am

Thanks, that helped. It was actually an easier fix than I had thought. I simply used the graphical login to reset the default session back to MATE. The problem was that I had edited the /etc/default/grub file to disable MDM for a faster boot, so that solution hadn't even occurred to me. All I had to do was edit the grub file, log in, edit the file again, and now everything functions as it should. Easy 5 minute fix.
nspboarderdude
Level 1
Level 1
 
Posts: 5
Joined: Sun May 27, 2012 1:26 pm


Return to MATE

Who is online

Users browsing this forum: No registered users and 5 guests