MATE does not remember mp4 as file extension

MATE does not remember mp4 as file extension

Postby simplex on Sun Mar 31, 2013 10:27 am

When I open an mp4 file and I go through right click -> open with application -> choose VLC -> remember this association, I got Totem again and again. Every other file type works. This drives me nuts.

Greetings,
S.
simplex
Level 2
Level 2
 
Posts: 97
Joined: Sat Oct 06, 2012 2:32 pm

Linux Mint is funded by ads and donations.
 

Re: MATE does not remember mp4 as file extension

Postby Skara Brae on Mon Apr 08, 2013 4:39 pm

Maybe a useless question, but - what if you right-click on an mp4 and choose "properties" (That's how it works in Windows, too) and then VLC Media Player? Double-clicking on an mp4 now starts VLC automatically; before, it used to be "Movie player".

Or starting the Control Center and then choosing "Preferred applications", and there VLC as "Multimedia player"?
Codename "PUMA": Intel Core i5-3450 // Gigabyte GA-H77-D3H // 1 x 4 GB DDR3-RAM // Gigabyte Geforce GT 630 // WD Caviar Blue 500 GB (S-ATA) // Samsung WriteMaster DVD-rw // Aopen QF50C PC case
--
Registered Linux User #495429
Skara Brae
Level 1
Level 1
 
Posts: 48
Joined: Sat Jun 09, 2012 10:45 am

Re: MATE does not remember mp4 as file extension

Postby simplex on Tue Apr 09, 2013 5:24 am

Skara Brae wrote:Maybe a useless question, but - what if you right-click on an mp4 and choose "properties" (That's how it works in Windows, too) and then VLC Media Player? Double-clicking on an mp4 now starts VLC automatically; before, it used to be "Movie player".

Or starting the Control Center and then choosing "Preferred applications", and there VLC as "Multimedia player"?


If VLC is already selected as the player in the properties pane, it is used. But I have to do this for each and every file manually again. Changing the settings in the Control Center does not help for the general problem.

Maybe it is a problem of Caja, the file browser?

S.
simplex
Level 2
Level 2
 
Posts: 97
Joined: Sat Oct 06, 2012 2:32 pm

Re: MATE does not remember mp4 as file extension

Postby overthetop on Wed Apr 10, 2013 3:42 pm

As a workaround you can try to open ~/.local/share/applications/mimeapps.list and replace the word 'totem' with 'vlc' where appropriate.
Image
"A wise man can learn more from a foolish question than a fool can learn from a wise answer." -- Bruce Lee
User avatar
overthetop
Level 4
Level 4
 
Posts: 368
Joined: Thu Oct 06, 2011 10:25 am
Location: /home/overthetop

Re: MATE does not remember mp4 as file extension

Postby dhm on Sat Apr 13, 2013 12:22 pm

Thank you, overthetop. I had a different problem with a wrong extension. Mate has no way to edit these. That is something that should be added to a future edition. My question would have been "Where are the file extension definitions stored?" and you answered, ~/.local/share/applications/mimeapps.list.

That's a start. It doesn't directly address my problem and I will have to post a question on the forum.
dhm
Level 1
Level 1
 
Posts: 5
Joined: Fri Nov 02, 2012 11:28 am


Return to MATE

Who is online

Users browsing this forum: No registered users and 1 guest