[Solved] Editing or Disabling the Volume Meter/ OSD/ Pop-Up

[Solved] Editing or Disabling the Volume Meter/ OSD/ Pop-Up

Postby Onsen on Tue Oct 08, 2013 1:45 pm

Solution:
w009 wrote:Assigned to Volume Up key: XF86AudioRaiseVolume
Code: Select all
sh -c "pactl set-sink-mute 0 false ; pactl set-sink-volume 0 +1%"

and to Volume down key XF86AudioLowerVolume
Code: Select all
sh -c "pactl set-sink-mute 0 false ; pactl -- set-sink-volume 0 -1%"


I used 3% though. It feels more responsive that way.
------------------------------------------------------------------------------------------------------------------------
Problem:

I tried searching the Internet for how to disable the OSD, but that usually was quite fruitless. Best answer I could find somewhere was also the worst, because the quintessence was, it can't be done and I shouldn't try. But everytime I'm watching a movie I'm reminded that I want it to be done and that I need to try.

So here I am. I want this pop-up disabled.

Image

At the very least I want to edit it to pop up somewhere that isn't the middle of the screen and to be much, much smaller. After all, the information is kind of neat. Only, 180x100px is way too big.


Additionally, it would be cool to go beyond "100%", like you can in the Sound Preferences.

Any ideas where to look to get this done?

------------------------------------------------- 2013-09-27 ---
Found a bunch of pictures that resemble the one I want to get rid of under /usr/share/icons/gnome/48x48/status
Image Image Image Image

Didn't find the one bothering me, though. So that approach didn't work out.

------------------------------------------------ 2013-09-28 ---

-- history of what I checked to no avail
------- search term: "linux volume pop-up"
2013-02 - viewtopic.php?f=90&t=124896
2010-01 - http://ubuntuforums.org/showthread.php? ... ost9307325
------ search term: "disable volume meter linux"
2009-11 - http://ubuntuforums.org/showthread.php?t=1314578
------ search term: "linux disable volume osd"
2013-09 - viewtopic.php?f=18&t=144277
2013-07 - http://askubuntu.com/questions/322345/d ... untu-12-04
2008-01 - http://ubuntuforums.org/showthread.php?t=816791
Last edited by Onsen on Sun Jan 26, 2014 8:47 am, edited 2 times in total.
My introduction. Free Games for Linux.
User avatar
Onsen
Level 1
Level 1
 
Posts: 33
Joined: Tue Sep 11, 2012 9:54 am

Linux Mint is funded by ads and donations.
 

Re: Editing or Disabling the Volume Meter/ OSD/ Pop-Up

Postby TheDynamicHamza21 on Thu Oct 10, 2013 8:54 pm

You posted in wrong section this is not MATE problem it's a Cinnamon problem. Mate doesn't have volume notification by default in the middle of the screen.

viewtopic.php?f=90&t=126157
"I rock project yards and township youth
I make the people listen,boogie down and move"
Rakaa Iriscience - Triple Optics


www.domeshotsandfatlaces.com
User avatar
TheDynamicHamza21
Level 5
Level 5
 
Posts: 643
Joined: Thu Oct 04, 2012 7:24 pm

Re: Editing or Disabling the Volume Meter/ OSD/ Pop-Up

Postby Onsen on Fri Oct 11, 2013 3:54 pm

I don't have Cinnamon, though. I have Linux Mint 13 with Mate.

But maybe it's not a Mate thingie, because I remember having this Volume Meter back with Gnome 2.0. And even before that, I vaguely remember having this with KDE 3.x around 2006. Only it never bothered me, because until recently, I never used these keyboard shortcuts.
My introduction. Free Games for Linux.
User avatar
Onsen
Level 1
Level 1
 
Posts: 33
Joined: Tue Sep 11, 2012 9:54 am

Re: Editing or Disabling the Volume Meter/ OSD/ Pop-Up

Postby TheDynamicHamza21 on Fri Oct 11, 2013 5:51 pm

so your problem is that everytime you use a shortcut to raise the volume the volume meter displays in the middle of screen? I hate state the obvious but don't use the shortcut and your annoyance will disappear.
"I rock project yards and township youth
I make the people listen,boogie down and move"
Rakaa Iriscience - Triple Optics


www.domeshotsandfatlaces.com
User avatar
TheDynamicHamza21
Level 5
Level 5
 
Posts: 643
Joined: Thu Oct 04, 2012 7:24 pm

Re: Editing or Disabling the Volume Meter/ OSD/ Pop-Up

Postby Onsen on Mon Oct 14, 2013 1:25 pm

Obviously that isn't the solution I'm looking for, because I want to use shortcuts. Or maybe there are other shortcuts to control sound that won't cause the volume meter to pop up?

I'm using a remote for watching movies on my pc. (It's really only one of those ultra small keyboards.) Not using shortcuts would defeat the point of owning this remote.
My introduction. Free Games for Linux.
User avatar
Onsen
Level 1
Level 1
 
Posts: 33
Joined: Tue Sep 11, 2012 9:54 am

Re: Editing or Disabling the Volume Meter/ OSD/ Pop-Up

Postby igoru-san on Fri Oct 18, 2013 7:03 pm

I would add here that my current issue with MATE is even worse, because my volume OSD looks like this:

Image

As you can see by the text size, it's pretty huge (aka 1/3 of the screen height) and quite annoying. I've noticed it has nothing to do with the desktop theme, such as controls or icons (although changing the icon pack changes the icon in the middle, but the transparency or size does not change).
Core2Duo E7400 (2.8GHz) | 8GB RAM | GF GTS 450 + LCD 21.5" @ 1920x1080 + LCD 20" @ 1600x900 | 500GB (linux + windows + data) + 120GB (backup) + 1.5TB (backup and data)
igoru-san
Level 1
Level 1
 
Posts: 9
Joined: Mon Jul 14, 2008 9:30 am
Location: Rio de Janeiro - Brazil

Re: Editing or Disabling the Volume Meter/ OSD/ Pop-Up

Postby Onsen on Tue Oct 22, 2013 4:06 pm

That's pretty harsh.

But you're right, it's style changes with the theme. "Colors" also affects the OSD,.. that's probably where your transparency is coming from (Windows, Background)? As for the huge icon... maybe you somewhere (caja?) specified to use huge icons. Because under /usr/share/icons/gnome-wise/scalable/status/audio-volume* I found your exact icon. <klick1> Deleting that affects my OSD. (Needed to select something else under "Icons" and then reselect GNOME-Wise to see the effects.)

Image

Wonder if I can change the icon to something else using inkscape, because it's a vector graphic..

Image

I can,... but it's pointless,.. I need to change the size of the background frame. Any ideas?

-----------------------------------
EDIT: Interestingly, after reboot it looks like this:
(I deleted the icon and changed the background from 48*48 to 10*2)

Image
My introduction. Free Games for Linux.
User avatar
Onsen
Level 1
Level 1
 
Posts: 33
Joined: Tue Sep 11, 2012 9:54 am

Re: Editing or Disabling the Volume Meter/ OSD/ Pop-Up

Postby w009 on Wed Jan 22, 2014 6:17 am

Hi,
I have found a solution, and I want to share it. I post here because this thread seems to be the most recent with similar question.

I am not sure that will work for you because I have XFCE4 (debian with xfce). But the problem was almost the same, and beside this when any application was using sound, the notification popup was appearing...

I have managed to solve my problem in a way. Initially I linked this problem with system notification daemon ( in my case xfce4-notifyd ). Only this is not related to the notification daemon but to the volume change daemon. For XFCE, according to https://wiki.archlinux.org/index.php/xfce#Xfce4-volumed, xfce4-volumed is daemon that maps keyboard volume keys to audio mixer.

I tried and killed the xfce4-volumed daemon then tested. Volume change notification is not appearing anymore - good, but with this my laptop volume keys don't work also.

I have done the following:

I disabled XFCE Volume Daemon from "Application Autostart" in "Session and Startup" ( can be launched by executing xfce4-session-settings in terminal)

Assigned to Volume Up key: XF86AudioRaiseVolume
Code: Select all
sh -c "pactl set-sink-mute 0 false ; pactl set-sink-volume 0 +1%"

and to Volume down key XF86AudioLowerVolume
Code: Select all
sh -c "pactl set-sink-mute 0 false ; pactl -- set-sink-volume 0 -1%"


Now I can work in peace while listening to the music , notification is not stealing my attention anymore :)
w009
Level 1
Level 1
 
Posts: 1
Joined: Wed Jan 22, 2014 5:56 am

Re: Editing or Disabling the Volume Meter/ OSD/ Pop-Up

Postby Onsen on Sun Jan 26, 2014 8:43 am

Reassigning the shortcuts worked for me. Many Thanks!
My introduction. Free Games for Linux.
User avatar
Onsen
Level 1
Level 1
 
Posts: 33
Joined: Tue Sep 11, 2012 9:54 am

Linux Mint is funded by ads and donations.
 

Return to MATE

Who is online

Users browsing this forum: No registered users and 6 guests