MDM and audio won't work after trying to install Guitar Pro6

MDM and audio won't work after trying to install Guitar Pro6

Postby otacon14112 on Fri Aug 15, 2014 1:36 am

I have Linux Mint Qiana. Everything was perfect, until I tried to install the .deb package for Guitar Pro 6. I used bash as sudo to install it, and it said there were dependencies and it failed. So then I went into Synaptic Package Manager to fix the broken package. It removed GP6, and other packages, and installed others. I tried to install it again on the cli, but same thing happened. The only difference was that there was only one package that GP6 needed, so I used apt-get install to install it. Then I tried to install it using dpkg -i filename.deb like before, and I can't remember what happened. It failed, but I don't remember what the output was. So I went back into Synaptic to fix the broken package, and then I restarted.

The computer boots into Qiana, but it hangs when it shows the leaf logo. So I hit a button, and it says:
Code: Select all
* Starting MDM Display Manager fail

Code: Select all
* Starting NetBIOS Name Server fail


There have been fails regularly in the past, which was normal. It was stuff I didn't use. Samba also failed, so I uninstalled it, in case it was preventing it from booting up, but it didn't affect anything.

I have to Ctrl-Alt to a tty, log in on the cli, then do: startx

That enables me to use the GUI perfectly fine. The only problem after this, is that now I have no audio. I went into sound preferences, and there was no audio hardware device listed. I'm using a Dell Inspiron 15 laptop, with an intel CORE i3, 6 GB RAM, 500 GB HD, HDMI output.

I typed
Code: Select all
which alsa
hit tab, and found that alsa-base and alsa-utils were installed. I apt-get removed them, and restarted. I had to go to a tty and log in on the cli, type startx, and then apt-get install(ed) alsa-base alsa-utils

Now I saw the integrated audio device, and the HDMI device in sound preferences, but I still had no audio, so I went to test the speakers for analog stereo duplex, sound preferences crashes, and I still have no sound.

I even tried
Code: Select all
sudo update-rc.d mdm defaults


But that didn't fix it.

I went into syslog to find anything, and I am pasting this:
Code: Select all
Aug 15 00:19:18 inspiron pulseaudio[2347]: [pulseaudio] sink-input.c: Failed to create sink input: sink is suspended.
Aug 15 00:26:15 inspiron kernel: [ 1385.213422] waiting module removal not supported: please upgrade
Aug 15 00:26:15 inspiron kernel: [ 1385.213863] waiting module removal not supported: please upgradewaiting module removal not supported: please upgrade
Aug 15 00:26:40 inspiron kernel: [ 1385.214521] waiting module removal not supported: please upgradewaiting module removal not supported: please upgrade
Aug 15 00:26:40 inspiron kernel: [ 1410.824196] waiting module removal not supported: please upgradewaiting module removal not supported: please upgrade
Aug 15 00:26:40 inspiron kernel: [ 1410.824745] waiting module removal not supported: please upgradewaiting module removal not supported: please upgrade
Aug 15 00:30:43 inspiron wpa_supplicant[949]: message repeated 15 times: [ wlan0: CTRL-EVENT-SCAN-STARTED ]


Code: Select all
[pulseaudio] sink-input.c: Failed to create sink input: sink is suspended.
is highlighted with a red background, and white text.

Apparently, there are no ~/.pulse* directories in my home.

I then did this:
Code: Select all
root@inspiron ~ # apt-get remove pulseaudio pulseaudio-utils
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  mate-media-gstreamer mate-settings-daemon-gstreamer
The following packages will be REMOVED:
  libcanberra-pulse mate-media-pulse mate-settings-daemon-pulse pulseaudio
  pulseaudio-module-bluetooth pulseaudio-module-x11 pulseaudio-utils
The following NEW packages will be installed:
  mate-media-gstreamer mate-settings-daemon-gstreamer
0 upgraded, 2 newly installed, 7 to remove and 18 not upgraded.
Need to get 529 kB of archives.
After this operation, 3,971 kB disk space will be freed.
Do you want to continue? [Y/n] y
Get:1 http://packages.linuxmint.com/ qiana/import mate-media-gstreamer amd64 1.8.0-0+qiana [317 kB]
Get:2 http://packages.linuxmint.com/ qiana/import mate-settings-daemon-gstreamer amd64 1.8.1-0+qiana [212 kB]
Fetched 529 kB in 1s (359 kB/s)                         
(Reading database ... 191862 files and directories currently installed.)
Removing libcanberra-pulse:amd64 (0.30-0ubuntu3) ...
dpkg: mate-media-pulse: dependency problems, but removing anyway as you requested:
 mate-media depends on mate-media-gstreamer | mate-media-pulse; however:
  Package mate-media-gstreamer is not installed.
  Package mate-media-pulse is to be removed.

Removing mate-media-pulse (1.8.0-0+qiana) ...
Processing triggers for libc-bin (2.19-0ubuntu6.1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for mime-support (3.54ubuntu1) ...
Processing triggers for man-db (2.6.7.1-1) ...
Selecting previously unselected package mate-media-gstreamer.
(Reading database ... 191784 files and directories currently installed.)
Preparing to unpack .../mate-media-gstreamer_1.8.0-0+qiana_amd64.deb ...
Unpacking mate-media-gstreamer (1.8.0-0+qiana) ...
Processing triggers for libglib2.0-0:i386 (2.40.0-2) ...
Processing triggers for libglib2.0-0:amd64 (2.40.0-2) ...
Processing triggers for mate-icon-theme (1.8.0-0+qiana) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for mime-support (3.54ubuntu1) ...
dpkg: mate-settings-daemon-pulse: dependency problems, but removing anyway as you requested:
 mate-settings-daemon depends on mate-settings-daemon-gstreamer (>= 1.8.1-0+qiana) | mate-settings-daemon-pulse (>= 1.8.1-0+qiana); however:
  Package mate-settings-daemon-gstreamer is not installed.
  Package mate-settings-daemon-pulse is to be removed.

(Reading database ... 191992 files and directories currently installed.)
Removing mate-settings-daemon-pulse (1.8.1-0+qiana) ...
Processing triggers for mate-icon-theme (1.8.0-0+qiana) ...
Processing triggers for man-db (2.6.7.1-1) ...
Processing triggers for libglib2.0-0:i386 (2.40.0-2) ...
Processing triggers for libglib2.0-0:amd64 (2.40.0-2) ...
Selecting previously unselected package mate-settings-daemon-gstreamer.
(Reading database ... 191875 files and directories currently installed.)
Preparing to unpack .../mate-settings-daemon-gstreamer_1.8.1-0+qiana_amd64.deb ...
Unpacking mate-settings-daemon-gstreamer (1.8.1-0+qiana) ...
Processing triggers for libglib2.0-0:i386 (2.40.0-2) ...
Processing triggers for libglib2.0-0:amd64 (2.40.0-2) ...
Processing triggers for mate-icon-theme (1.8.0-0+qiana) ...
(Reading database ... 191976 files and directories currently installed.)
Removing pulseaudio-module-x11 (1:4.0-0ubuntu11) ...
Removing pulseaudio-module-bluetooth (1:4.0-0ubuntu11) ...
Removing pulseaudio (1:4.0-0ubuntu11) ...
Removing pulseaudio-utils (1:4.0-0ubuntu11) ...
Processing triggers for man-db (2.6.7.1-1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.1) ...
Setting up mate-media-gstreamer (1.8.0-0+qiana) ...
Setting up mate-settings-daemon-gstreamer (1.8.1-0+qiana) ...
root@inspiron ~ #


I then restarted, and reinstalled pulseaudio and pulseaudio-utils. I restarted. Now I have no sound preferences in the control panel.

This is now the last several lines of my syslog:
Code: Select all
Aug 15 01:00:24 inspiron dbus[845]: [system] Successfully activated service 'org.freedesktop.SystemToolsBackends.NFSConfig'
Aug 15 01:00:24 inspiron dbus[845]: [system] Activating service name='org.freedesktop.SystemToolsBackends.Platform' (using servicehelper)
Aug 15 01:00:24 inspiron dbus[845]: [system] Successfully activated service 'org.freedesktop.SystemToolsBackends.Platform'
Aug 15 01:02:02 inspiron acpid: input device has been disconnected, fd 7
Aug 15 01:02:02 inspiron acpid: input device has been disconnected, fd 14
Aug 15 01:02:02 inspiron acpid: input device has been disconnected, fd 15
Aug 15 01:02:02 inspiron acpid: input device has been disconnected, fd 6
Aug 15 01:02:02 inspiron kernel: [  182.879606] waiting module removal not supported: please upgrade
Aug 15 01:02:02 inspiron kernel: [  183.047975] waiting module removal not supported: please upgradewaiting module removal not supported: please upgrade
Aug 15 01:02:02 inspiron kernel: [  183.048493] waiting module removal not supported: please upgradewaiting module removal not supported: please upgrade
Aug 15 01:02:02 inspiron kernel: [  183.049028] waiting module removal not supported: please upgradeHDA driver get symbol successfully from i915 module
Aug 15 01:02:02 inspiron kernel: [  183.079589] snd_hda_intel 0000:00:1b.0: irq 65 for MSI/MSI-X
Aug 15 01:02:02 inspiron kernel: [  183.083665] snd_hda_intel 0000:00:03.0: irq 66 for MSI/MSI-X
Aug 15 01:02:02 inspiron kernel: [  183.087096] SKU: Nid=0x1d sku_cfg=0x40e00001
Aug 15 01:02:02 inspiron kernel: [  183.087099] SKU: port_connectivity=0x1
Aug 15 01:02:02 inspiron kernel: [  183.087101] SKU: enable_pcbeep=0x0
Aug 15 01:02:02 inspiron kernel: [  183.087103] SKU: check_sum=0x00000000
Aug 15 01:02:02 inspiron kernel: [  183.087104] SKU: customization=0x00000000
Aug 15 01:02:02 inspiron kernel: [  183.087106] SKU: external_amp=0x0
Aug 15 01:02:02 inspiron kernel: [  183.087107] SKU: platform_type=0x0
Aug 15 01:02:02 inspiron kernel: [  183.087108] SKU: swap=0x0
Aug 15 01:02:02 inspiron kernel: [  183.087110] SKU: override=0x1
Aug 15 01:02:02 inspiron kernel: [  183.087359] autoconfig: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
Aug 15 01:02:02 inspiron kernel: [  183.087361]    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
Aug 15 01:02:02 inspiron kernel: [  183.087363]    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
Aug 15 01:02:02 inspiron kernel: [  183.087364]    mono: mono_out=0x0
Aug 15 01:02:02 inspiron kernel: [  183.087366]    inputs:
Aug 15 01:02:02 inspiron kernel: [  183.087368]      Headset Mic=0x19
Aug 15 01:02:02 inspiron kernel: [  183.087370]      Headphone Mic=0x1a
Aug 15 01:02:02 inspiron kernel: [  183.087372]      Internal Mic=0x12
Aug 15 01:02:02 inspiron kernel: [  183.087374] realtek: No valid SSID, checking pincfg 0x40e00001 for NID 0x1d
Aug 15 01:02:02 inspiron kernel: [  183.087376] realtek: Enabling init ASM_ID=0x0001 CODEC_ID=10ec0283
Aug 15 01:02:02 inspiron kernel: [  183.092726] input: HDA Intel HDMI HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:03.0/sound/card0/input17
Aug 15 01:02:02 inspiron kernel: [  183.092855] input: HDA Intel HDMI HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:03.0/sound/card0/input16
Aug 15 01:02:02 inspiron kernel: [  183.092959] input: HDA Intel HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:03.0/sound/card0/input15
Aug 15 01:02:02 inspiron kernel: [  183.093456] input: HDA Intel PCH Headphone Mic as /devices/pci0000:00/0000:00:1b.0/sound/card1/input18


What can I undo to correct what has been done? Should I just reinstall Qiana?

Thanks in advance.
otacon14112
Level 1
Level 1
 
Posts: 3
Joined: Sun Apr 21, 2013 11:43 pm

Linux Mint is funded by ads and donations.
 

Re: MDM and audio won't work after trying to install Guitar

Postby PatH57 on Fri Aug 15, 2014 3:38 am

Hi,

you managed to put yourself in dependency hell.
Must have started with a small driver problem at beginning but now you are far away and it could take hours getting you back to start.
My advise boot from live dvd or usb, backup the files you really need and install a new copy of qiana.
Then check if everything works . Some messages are misleading , like samba could not start is often normal if you didn't configure it or are not using it.
If you see something and you are not sure, it's better to come back here and ask before trying to "install" other packages witch could break your system again.
Always a good idea to make regular backups so you can go back to an earlier stage.
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.
User avatar
PatH57
Level 13
Level 13
 
Posts: 4603
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: MDM and audio won't work after trying to install Guitar

Postby otacon14112 on Fri Aug 15, 2014 5:15 am

Alright, thanks for your advice and prompt reply. I figured it could be fixable, but if it will take that long to fix it, it's probably not worth it. This is so weird, because I was able to use GP6 on Ubuntu (before the Unity bs), and it installed perfectly. I'll try installing it again after I install Qiana again. Once again, thanks :)
otacon14112
Level 1
Level 1
 
Posts: 3
Joined: Sun Apr 21, 2013 11:43 pm


Return to MATE

Who is online

Users browsing this forum: No registered users and 4 guests