display keeps dimming, "dim screen to save power" unchecked

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon

display keeps dimming, "dim screen to save power" unchecked

Postby m-pescador on Sat Dec 29, 2012 6:30 pm

There are a number of issues concerning the dimming of display function in a number of distributions, as I have learned in my search for an answer to my problem.

Many remain unresolved, including this. :?:

It is happening in Linux Mint 14 w/Cinnamon.

No matter what the settings in "brightness and lock", the display will dim after about 2 minutes when idling. This does not happen when watching full screen VLC, by the way, but otherwise as soon as there is no user input for 1-2 minutes (I haven't timed it, but it is quite quick).

This is the card:
Code: Select all
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device 0645
   Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
   Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
   Latency: 0
   Interrupt: pin A routed to IRQ 42
   Region 0: Memory at c0000000 (64-bit, non-prefetchable) [size=4M]
   Region 2: Memory at b0000000 (64-bit, prefetchable) [size=256M]
   Region 4: I/O ports at 2000 [size=64]
   Expansion ROM at <unassigned> [disabled]
   Capabilities: <access denied>
   Kernel driver in use: i915
   Kernel modules: i915


The kernel:
Code: Select all
Linux XXX 3.5.0-19-generic #30-Ubuntu SMP Tue Nov 13 17:48:01 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux


I have tried:

Code: Select all
xset s off


That makes no difference.

I have enabled "dim screen to save power", no difference either, but then there is no timer option for that setting?!?

Initially, the dim function didn't work at all, so I added:
Code: Select all
GRUB_CMDLINE_LINUX_DEFAULT="acpi_backlight=vendor"


And the dimmer works.

What's next? What can I try to either disable the dimming or set it to 60 minutes or something? Dconf didn't reveal anything, but I could have missed it.

Lost! :shock:
m-pescador
Level 1
Level 1
 
Posts: 3
Joined: Wed Jun 20, 2012 11:40 am

Linux Mint is funded by ads and donations.
 

Re: display keeps dimming, "dim screen to save power" unche

Postby friflaj on Sun Feb 10, 2013 4:15 pm

try turning off screensaver...
friflaj
Level 1
Level 1
 
Posts: 1
Joined: Sat Feb 02, 2013 9:45 am


Return to Cinnamon

Who is online

Users browsing this forum: nascar64 and 5 guests