Problem after updates no startmenu + more :(

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon

Problem after updates no startmenu + more :(

Postby benny999 on Tue Mar 05, 2013 3:52 am

hi guys im new to linux mint and im running it in vmware i have been mucking around with now i updated it and after i have done that and restarted it now i have no start menu and i cant click anything also the only shortcut that works is ctrl+alt+backspace back to the login screen were i can login via gnome and that works fine i did notice while i was random clicking in the Cinnamon then transferred to gnome that i had made a bunch of new folders so i think its still click just not showing it up. i have tried uninstallign Cinnamon and reinstalling it via syntaics .

i have attached a picture to show you what it looks like thanks very much for any help


spec
vmware 9.0
linux mint 14.1 Cinnamon
all the latest updates(after this is what caused this starting to happen)



edit: Cinnanmon 2d works fine also
Attachments
linux mint2.jpg
benny999
Level 1
Level 1
 
Posts: 7
Joined: Tue Mar 05, 2013 3:38 am

Linux Mint is funded by ads and donations.
 

Re: Problem after updates no startmenu + more :(

Postby AlqasimO on Tue Mar 05, 2013 2:25 pm

Please post the output of inxi -Gx

There have been reports of this happening after an update for people with proprietary graphics drivers installed. Usually solved by reinstalling the drivers.

Can you get to the terminal by pressing Ctrl + Alt + t
AlqasimO
Level 1
Level 1
 
Posts: 18
Joined: Sat Mar 02, 2013 3:51 pm
Location: United Kingdom

Re: Problem after updates no startmenu + more :(

Postby benny999 on Thu Mar 07, 2013 4:56 am

thanks but that didn't fix it :( not sure what's going on I installed the 32bit version and updated it didn't have a issue I'm not sure what's going on
benny999
Level 1
Level 1
 
Posts: 7
Joined: Tue Mar 05, 2013 3:38 am

Re: Problem after updates no startmenu + more :(

Postby benny999 on Thu Mar 07, 2013 4:56 am

thanks but that didn't fix it :( not sure what's going on I installed the 32bit version and updated it didn't have a issue I'm not sure what's going on
benny999
Level 1
Level 1
 
Posts: 7
Joined: Tue Mar 05, 2013 3:38 am

Re: Problem after updates no startmenu + more :(

Postby catweazel on Thu Mar 07, 2013 5:05 am

benny999 wrote:thanks but that didn't fix it :( not sure what's going on I installed the 32bit version and updated it didn't have a issue I'm not sure what's going on

What's going on is you didn't take the advice you were given.
Mint Testing Team & Mint Donor #3606
KDE 4.12.0, custom preemptive kernel 3.12.5,
Intel i7 4770K @ 4.7GHz, 16GB 2666MHz XMP,
4 Samsung 840 PRO 512GB SSDs in RAID0,
6TB HW RAID10, dual 24" Acer X243H,
Gigabyte nVidia GTX 680 Super Overclock
User avatar
catweazel
Level 7
Level 7
 
Posts: 1656
Joined: Fri Oct 12, 2012 9:44 pm

Re: Problem after updates no startmenu + more :(

Postby benny999 on Thu Mar 07, 2013 5:12 am

oops didnt see that part sorry all have to reinstall it again because I stuffed it trying to fix it
benny999
Level 1
Level 1
 
Posts: 7
Joined: Tue Mar 05, 2013 3:38 am

Re: Problem after updates no startmenu + more :(

Postby benny999 on Fri Mar 08, 2013 3:20 am

the inxi -Gx
command returns "\inxi-gx: command not found" with out quotes


i also grabbed a copy of my .xsession-errors file


Code: Select all
/etc/mdm/Xsession: Beginning session setup...
localuser:ben being added to access control list
Setting IM through im-switch for locale=en_AU.
Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/default.
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
GNOME_KEYRING_CONTROL=/run/user/ben/keyring-9ZiBrz
GNOME_KEYRING_CONTROL=/run/user/ben/keyring-9ZiBrz
GNOME_KEYRING_CONTROL=/run/user/ben/keyring-9ZiBrz
SSH_AUTH_SOCK=/run/user/ben/keyring-9ZiBrz/ssh
GNOME_KEYRING_CONTROL=/run/user/ben/keyring-9ZiBrz
SSH_AUTH_SOCK=/run/user/ben/keyring-9ZiBrz/ssh
GPG_AGENT_INFO=/run/user/ben/keyring-9ZiBrz/gpg:0:1

(gnome-settings-daemon:3579): color-plugin-WARNING **: failed to get edid: unable to get EDID for output

(gnome-settings-daemon:3579): color-plugin-WARNING **: unable to get EDID for xrandr-Virtual1: unable to get EDID for output
access control disabled, clients can connect from any host
** Message: applet now removed from the notification area
** Message: using fallback from indicator to GtkStatusIcon

** (nemo:3632): WARNING **: Can not get _NET_WORKAREA

** (nemo:3632): WARNING **: Can not determine workarea, guessing at layout
      JS LOG: About to start Cinnamon
Window manager warning: Log level 16: Unable to register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject
Window manager warning: Log level 16: Error registering polkit authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject (polkit-error-quark 0)
      JS LOG: Cinnamon started at Fri Mar 08 2013 18:29:12 GMT+1100 (EST)

(gnome-settings-daemon:3579): media-keys-plugin-WARNING **: Unable to get default sink
      JS LOG: network applet: Cannot find connection for active (or connection cannot be read)
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
** Message: applet now embedded in the notification area
failed to create drawable
failed to create drawable
failed to create drawable
failed to create drawable
      JS LOG: Unable to mount volume Floppy Disk: Gio.IOErrorEnum: Error mounting system-managed device /dev/fd0: Command-line `mount "/media/floppy0"' exited with non-zero exit status 32: mount: /dev/fd0 is not a valid block device
      JS LOG: Unable to mount volume Floppy Disk: Gio.IOErrorEnum: Error mounting system-managed device /dev/fd0: Command-line `mount "/media/floppy0"' exited with non-zero exit status 32: mount: /dev/fd0 is not a valid block device
      JS LOG: network applet: Found connection for active

benny999
Level 1
Level 1
 
Posts: 7
Joined: Tue Mar 05, 2013 3:38 am

Re: Problem after updates no startmenu + more :(

Postby Fed03 on Sat Mar 09, 2013 12:54 pm

I've opened an issue on github about this problem a week ago....https://github.com/linuxmint/Cinnamon/issues/1763
Fed03
Level 1
Level 1
 
Posts: 4
Joined: Tue Feb 12, 2013 12:38 pm

Re: Problem after updates no startmenu + more :(

Postby benny999 on Sun Mar 10, 2013 10:48 pm

cool I did check it out wouldnt mind sorting out the problem.im getting the feel of linux before I remove Windows
benny999
Level 1
Level 1
 
Posts: 7
Joined: Tue Mar 05, 2013 3:38 am

Re: Problem after updates no startmenu + more :(

Postby boekhold on Tue Mar 19, 2013 2:06 am

Fed03 wrote:I've opened an issue on github about this problem a week ago....https://github.com/linuxmint/Cinnamon/issues/1763


Does anybody have any further progress on this? I tried upgrading to cinnamon-1.7.2-20130319045211 from the nightlies PPA, but it didn't fix the issue. Instead it broke Cinnamon 2D as well. Downgraded to 1.6.7+nadia again so at least 2D works again.

Maarten
boekhold
Level 1
Level 1
 
Posts: 25
Joined: Thu Nov 10, 2011 8:10 am

Re: Problem after updates no startmenu + more :(

Postby Raen on Wed Apr 03, 2013 5:51 pm

I also have this problem when using VMware Workstation, if I do the priority Mint updates after installation.

You can workaround by disabling 3D Acceleration on VMware, and Cinnamon will start correctly, or alternatively choose Cinnamon 2D.

The real solution for now is to not update Mint/Cinnamon, by doing the priority updates (marked as "1"), as Cinnamon and VMware 3D Acceleration appear to be incompatible for the moment.

Has anyone come up with a solution, or noticed if there are newer updates that don't break Cinnamon when using VMware?
Raen
Level 1
Level 1
 
Posts: 4
Joined: Wed Apr 03, 2013 5:44 pm

Re: Problem after updates no startmenu + more :(

Postby Fed03 on Wed Apr 10, 2013 12:17 pm

Fed03
Level 1
Level 1
 
Posts: 4
Joined: Tue Feb 12, 2013 12:38 pm

Re: Problem after updates no startmenu + more :(

Postby joksim on Sat Apr 13, 2013 1:10 pm

I messed up all my GUI with the instruction form the last post :(
Can I restor it in someway?
Please help, newbee writing here !

Tnx
joksim
Level 1
Level 1
 
Posts: 8
Joined: Sun Mar 24, 2013 9:32 am

Re: Problem after updates no startmenu + more :(

Postby Raen on Sun May 12, 2013 9:12 pm

Update on my previous post.
I remember that after discovering that the level 1 updates caused conflicts between Cinnamon and VMware Workstation's 3D Acceleration, I did a fresh Mint VM install and haven't done a single update ever since.

But after seeing that a solution was found, I decided to finally update Mint, installing the updates marked as levels 1 and 2 first and then the level 3 updates after a restart.
To my surprise, this time Mint and Cinnamon appear to be working with VMware Workstation (3D Acceleration enabled) at 100%, so the actual (newer?) Mint level 1 updates seem to have fixed the problem.

So if like me, you have waited on updating your Mint install until better level 1 updates came along, it seems that you can update safely now and the solution posted on GitHub won't be needed.

And by the way, this topic's subject is the same as http://forums.linuxmint.com/viewtopic.php?f=208&t=131100 and http://forums.linuxmint.com/viewtopic.php?f=208&t=127018.
Raen
Level 1
Level 1
 
Posts: 4
Joined: Wed Apr 03, 2013 5:44 pm

Linux Mint is funded by ads and donations.
 

Return to Cinnamon

Who is online

Users browsing this forum: No registered users and 5 guests

cron