Can't get new themes in Cinnamon to appear

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon

Can't get new themes in Cinnamon to appear

Postby austin1237 on Sun Mar 17, 2013 7:24 pm

I've been having an issue with trying to get a new theme working with Cinnamon. I installed Cinnamon using the following commands:

Code: Select all
sudo add-apt-repository ppa:gwendal-lebihan-dev/cinnamon-stable
sudo apt-get update
sudo apt-get install cinnamon

I've tried adding themes by adding creating a .themes folder in my home directory (and moving the extracted theme files there), as well as moving the new themes to usr/share/themes folder as well.

After attempting both of these solutions the only theme in Cinnamon setting is still "Cinnamon".

I know this is a forum for mint but I'm running Ubuntu. I posted this on both askubuntu and the Ubuntu forums and haven't gotten a response. I'm having this issue on both my desktop that is running 12.04 64 bit and my laptop that is running 12.10 32 bit.

What could be causing this issue?
austin1237
Level 1
Level 1
 
Posts: 9
Joined: Sun Jul 10, 2011 6:16 pm

Linux Mint is funded by ads and donations.
 

Re: Can't get new themes in Cinnamon to appear

Postby bimsebasse on Sun Mar 17, 2013 7:48 pm

Can you give a screenshot of your open folder and the Cinnamon Settings Themes page?
Thank you for this thread. That’s all I can say. You most definitely have made this forum into something special. You clearly know what you are doing, you’ve covered so many bases. Thanks!
User avatar
bimsebasse
Level 7
Level 7
 
Posts: 1709
Joined: Fri Nov 11, 2011 10:21 am
Location: Scandinavia

Re: Can't get new themes in Cinnamon to appear

Postby austin1237 on Sun Mar 17, 2013 9:54 pm

Here is the screenshot you requested the window on the top is the .themes folder in my home directory and the window on the left is the themes folder in the user/share/ directory.
Attachments
mythemes.png
Screenshot of my desktop
austin1237
Level 1
Level 1
 
Posts: 9
Joined: Sun Jul 10, 2011 6:16 pm

Re: Can't get new themes in Cinnamon to appear

Postby ThatGuyFromHighRolls on Tue Mar 19, 2013 1:16 pm

I have installed LMDE and am having the same problem. I did have Linux Mint 14 installed and it worked fine. Does anyone have an answer as to why this is happening.

Thanks for your assistance. :D
ThatGuyFromHighRolls
Level 1
Level 1
 
Posts: 2
Joined: Tue May 01, 2012 1:34 pm
Location: New Mexico, USA

Re: Can't get new themes in Cinnamon to appear

Postby ThatGuyFromHighRolls on Tue Mar 19, 2013 3:18 pm

After a little troubleshooting I found the problem on my system. It appears that the Cinnamon Themes were not installed as a part of the initial installation.

I opened the Software Manager and searched for the Cinnamon Themes and found that the package was not installed. After installing the Themes package all is working fine now. :!:

I hope this might help anyone else having this problem.
ThatGuyFromHighRolls
Level 1
Level 1
 
Posts: 2
Joined: Tue May 01, 2012 1:34 pm
Location: New Mexico, USA

Re: Can't get new themes in Cinnamon to appear

Postby austin1237 on Tue Mar 19, 2013 11:11 pm

So i must be missing a package. Can somone point me to the ppa I needs to get? I thought this was it
Code: Select all
sudo sh -c 'echo "deb http://packages.linuxmint.com/ nadia main" >> /etc/apt/sources.list.d/mint.list'
sudo apt-get install linuxmint-keyring
sudo apt-get install Cinnamon-Themes


I was mistaken it was just a collection of themes that appeared in my usr/share/themes folder. My two original themes didn't show up, and the .themes folder in my home directory still isn't working.
austin1237
Level 1
Level 1
 
Posts: 9
Joined: Sun Jul 10, 2011 6:16 pm

Re: Can't get new themes in Cinnamon to appear

Postby austin1237 on Wed Mar 20, 2013 12:17 am

Well it looks like I got somemyself into trouble. Now I have some depencey issues, when trying to perform sudo apt-get install cinnamon
Code: Select all
The following packages have unmet dependencies:
 cinnamon : Depends: gir1.2-muffin-3.0 but it is not going to be installed
            Depends: libgjs0-libmozjs185-1.0 but it is not installable
            Depends: libgjs0c (>= 1.34.0) but 1.32.0-1ubuntu1 is to be installed
            Depends: libgnome-desktop-3-4 (>= 3.2.0) but it is not installable
            Depends: libmuffin0 (>= 1.1.1) but it is not going to be installed
            Recommends: nemo but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
austin1237
Level 1
Level 1
 
Posts: 9
Joined: Sun Jul 10, 2011 6:16 pm

Linux Mint is funded by ads and donations.
 

Return to Cinnamon

Who is online

Users browsing this forum: semicolon and 16 guests