Screen Tearing on Linux Mint 17 Cinnamon

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon

Screen Tearing on Linux Mint 17 Cinnamon

Postby tj007 on Wed Aug 13, 2014 6:01 pm

I have a computer that is a year or so old. It has a Core i5 with onboard Intel HD Graphics 2000. I know it doesn't have a video card and onboard video sucks, etc...But it should still be able to play videos fullscreen without tearing.

I loaded Linux Mint 17 Cinnamon on it a few days ago. I absolutely love the OS so far except for this one issue. Videos whether streamed from YouTube or Played from VLC locally have some bad screen tearing going on. I don't think there are any intel video drivers I could download as I tried and it said there are none compatible for my OS and my Intel HD Graphics 2000, so I'm just using the default ones that linux mint automatically used.

I read online to do the following...

/etc/enviroment
CLUTTER_PAINT=disable-clipped-redraws:di­sable-culling
CLUTTER_VBLANK=True

I've added those two lines to /etc/environment and rebooted. It seemed to help a little, but I'm still getting some tearing. The tearing seems the worst or most noticeable when the videos are fullscreen.

I've heard some people saying to disable compositing? I've heard some people say to use https://wiki.archlinux.org/index.php/Compton

I just feel like there should be a way to fix this just using Cinnamon...or is this a bug in the software?

Note: I don't get screen tearing with Windows 7, but I enjoy using and playing with Ubuntu and Linux Mint.

Please Help, Thanks.
tj007
Level 1
Level 1
 
Posts: 2
Joined: Wed Aug 13, 2014 5:49 pm

Linux Mint is funded by ads and donations.
 

Re: Screen Tearing on Linux Mint 17 Cinnamon

Postby nomko on Thu Aug 14, 2014 3:12 am

First of all, there are much more threads on this forum with similar complaints/questions/issues regarding screen tearing. Before posting a new thread, it is wise and recommended (see the forum rules) to search the forum first for potst with similar problems/issues/questions.
Secondly: Also read the forum rules about providing detailed info as much as possible. It is not like we have a magical crystal ball here to look in to see what the specifications of your system is. So, to provide us with relevant info, please run this terminal command and paste the output here:
Code: Select all
inxi -Fxz



Check this: https://www.google.com/?gws_rd=ssl#q=Sc ... uxmint.com
You should find a solution here.

Good luck!
MSI GE70-2PE*Quad core Intel Core i7-4710HQ*Kingston 16 GB RAM*Intel 4th Gen. Integr. GPU/NVidia GeForce GTX860M*Qualcomm Atheros Killer E2200/Intel Wireless 3160*Sitecom X5-N600 Router (WLR-5100)

Visit my website:
My personal website
User avatar
nomko
Level 9
Level 9
 
Posts: 2920
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: Screen Tearing on Linux Mint 17 Cinnamon

Postby tj007 on Thu Aug 14, 2014 7:51 pm

System: Host: mediacenter-p7-1423w Kernel: 3.13.0-24-generic x86_64 (64 bit, gcc: 4.8.2)
Desktop: Gnome Distro: Linux Mint 17 Qiana
Machine: System: Hewlett-Packard product: p7-1423w
Mobo: Foxconn model: 2ADA version: 1.00 Bios: AMI version: 8.12 date: 12/14/2012
CPU: Quad core Intel Core i5-2320 CPU (-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 23944.7
Clock Speeds: 1: 1600.00 MHz 2: 3001.00 MHz 3: 1600.00 MHz 4: 1600.00 MHz
Graphics: Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller bus-ID: 00:02.0
X.Org: 1.15.1 drivers: intel (unloaded: fbdev,vesa) Resolution: 1920x1080@60.0hz
GLX Renderer: Mesa DRI Intel Sandybridge Desktop GLX Version: 3.0 Mesa 10.1.0 Direct Rendering: Yes
Audio: Card: Intel 6 Series/C200 Series Chipset Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture ver: k3.13.0-24-generic
Network: Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 ver: 2.3LK-NAPI port: e000 bus-ID: 04:00.0
IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Card-2: Ralink Device 539b driver: rt2800pci ver: 2.3.0 bus-ID: 03:00.0
IF: wlan0 state: down mac: <filter>
Drives: HDD Total Size: 150.0GB (3.9% used) 1: id: /dev/sda model: WDC_WD1500ADFD size: 150.0GB
Partition: ID: / size: 130G used: 5.5G (5%) fs: ext4 ID: swap-1 size: 8.47GB used: 0.00GB (0%) fs: swap
RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors: System Temperatures: cpu: 29.8C mobo: 27.8C
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 166 Uptime: 5 min Memory: 643.7/7865.4MB Runlevel: 2 Gcc sys: 4.8.2 Client: Shell inxi: 1.8.4
tj007
Level 1
Level 1
 
Posts: 2
Joined: Wed Aug 13, 2014 5:49 pm


Return to Cinnamon

Who is online

Users browsing this forum: No registered users and 4 guests