No title bar when Compiz enabled

Forum rules
Before you post please read how to get help

No title bar when Compiz enabled

Postby Jade Tiki Puku on Sun Sep 09, 2012 2:00 am

I enabled compiz on a new install of Mint 11 and the title bar is missing. I cannot drag windows and have no wobbly windows. How can I get it back?
Jade Tiki Puku
Level 1
Level 1
 
Posts: 17
Joined: Sat May 29, 2010 12:18 pm

Linux Mint is funded by ads and donations.
 

Re: No title bar when Compiz enabled

Postby massimo7000 on Sun Sep 09, 2012 4:12 am

I think that at the time I fixed by installing compiz manager, then in the settings there should be a flag to activate the edges of the windows.
massimo7000
Level 1
Level 1
 
Posts: 1
Joined: Sun Sep 09, 2012 3:59 am

Re: No title bar when Compiz enabled

Postby wyrdoak on Sun Sep 09, 2012 11:11 am

In the compiz setting manager you need to activate the Windows Decoration plug. If you want wobbly windows activate it while your there.

If you wish, for a quickie open the compiz setings manager go to preferences

Open gedit, create "whatever you want.profile" by copy and pasting this into gedit:
Code: Select all
wallpaper]
s0_bg_image = ;
s0_bg_color1 = #00000000;
s0_bg_color2 = #00000000;

[grid]
s0_top_edge_threshold = 5
s0_outline_color = #00b2fb9f
s0_fill_color = #00c3fb4f

[winrules]
s0_size_matches = ;

[thumbnail]
s0_thumb_color = #0000007f

[cube]
s0_top_color = #ffffff00
s0_bottom_color = #ffffff00

[animation]
s0_open_effects =
s0_open_durations =
s0_open_matches =
s0_open_options =
s0_close_effects =
s0_close_durations =
s0_close_matches =
s0_close_options =
s0_close_random_effects = ;
s0_minimize_effects =
s0_minimize_durations =
s0_minimize_matches =
s0_minimize_options =
s0_minimize_random_effects = ;
s0_focus_effects =
s0_focus_durations =
s0_focus_matches =
s0_focus_options =
s0_rollup_fixed_interior = true
s0_zoom_springiness = 0.000000

[ezoom]
s0_zoom_in_button = <Super>Button4
s0_zoom_out_button = <Super>Button5

[expo]
s0_expo_edge = TopLeft
s0_expo_immediate_move = true
s0_selected_color = #0093fbff
s0_reflection = true
s0_ground_color1 = #010f12cc
s0_ground_color2 = #010f1200

[place]
s0_position_matches = ;
s0_mode_matches = ;
s0_viewport_matches = ;

[rotate]
s0_edge_flip_window = false

[core]
s0_active_plugins = core;composite;opengl;imgjpeg;compiztoolbox;decor;move;regex;commands;gnomecompat;imgpng;imgsvg;text;resize;mousepoll;grid;workarounds;vpswitch;kdecompat;place;shift;wobbly;session;fade;cube;scale;rotate;td;cubeaddon;expo;ezoom;switcher;
s0_outputs = 1025x600+0+0;
s0_hsize = 4
s0_vsize = 1

[decor]
s0_active_shadow_color = #00000080
s0_active_shadow_x_offset = 2
s0_active_shadow_y_offset = 2
s0_inactive_shadow_color = #000000ff
s0_inactive_shadow_x_offset = 2
s0_inactive_shadow_y_offset = 2
s0_command = gtk-window-decorator --replace

[wall]
s0_thumb_highlight_gradient_shadow_color = #dfdfdfff
s0_arrow_base_color = #e6e6e6d9
s0_arrow_shadow_color = #dcdcdcd9

[showmouse]
s0_color = #ffdf3fff

[firepaint]
s0_fire_color = #ff3305ff

[shift]
s0_ground_color1 = #b3b3b3cc
s0_ground_color2 = #b3b3b300

[obs]
s0_opacity_matches = class=Firefox;;
s0_opacity_values = 96;90;
s0_brightness_matches = ;
s0_saturation_matches = ;

[gnomecompat]
s0_run_key = <Alt>F3

[wobbly]
s0_maximize_effect = false

[cubeaddon]
s0_ground_color1 = #010f12cc
s0_ground_color2 = #02101300
s0_mode = 2
s0_deformation = 2
s0_top_images = /usr/share/backgrounds/Rays.png;
s0_bottom_images = /usr/share/backgrounds/Rays.png;

[resize]
s0_mode = 3
s0_border_color = #00a2fb9f
s0_fill_color = #00c1fb19

[group]
s0_autotab_windows = ;

[animationaddon]
s0_beam_color = #7f7f7fff
s0_fire_color = #ff3305ff
s0_fire_direction = 1
s0_domino_direction = 0

[resizeinfo]
s0_gradient_1 = #cccce6cc
s0_gradient_2 = #f3f3f3cc
s0_gradient_3 = #d9d9d9cc


Save it as something like wyrdoak.profile
Now point your compiz setting manager / pereferences / profile / import to it
It should work now after you restart your windows Manager
In terminal type compiz --replace

I think I remember everything :?
-Dell Mini Netbook-Atom CPU-N270-1.60ghz; 16gbs mini ePCI PATA SSD
RAM- 1gbs-(Maya-Xfce) LInux 3.2.0.57-generic(i686)
SolydX (32bit)
User avatar
wyrdoak
Level 6
Level 6
 
Posts: 1313
Joined: Thu May 19, 2011 1:32 pm
Location: USA

Re: No title bar when Compiz enabled

Postby xenopeek on Mon Sep 10, 2012 4:41 am

Moved the topic here as it is about Compiz. You may want to consider upgrading soon, as Linux Mint 11 reaches end of support next month :shock: http://www.linuxmint.com/oldreleases.php
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15433
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands


Return to Compiz, Conky, Docks, & Widgets

Who is online

Users browsing this forum: No registered users and 2 guests