conky @ startup?

Forum rules
Before you post please read how to get help

conky @ startup?

Postby Rita G. on Wed Nov 12, 2008 5:47 am

conky does not launch from terminal:

rp@M1 ~ $ conky

Conky: missing text block in configuration; exiting

rp@M1 ~ $


will not launch from alt+f2 either.

but will launch from root terminal!

anyone know how to make it launch automatically at startup?
Rita G.
Level 2
Level 2
 
Posts: 65
Joined: Tue Oct 14, 2008 5:32 pm

Linux Mint is funded by ads and donations.
 

Re: conky @ startup?

Postby msuggs on Wed Nov 12, 2008 6:16 am

You have an error in the .conyrc config file in your home directory that is preventing it loading as a normal user. As root you are using the default config file so it starts ok. Open the default config file found at /etc/conky/conky.conf and then save it in your home directory as .conkyrc.

Once that is working okay you can make make conky start by adding it to the sessions manager. Preferences-->Sessions
msuggs
Level 5
Level 5
 
Posts: 882
Joined: Thu Jul 10, 2008 8:25 am
Location: non-local

Re: conky @ startup?

Postby msuggs on Wed Nov 12, 2008 6:29 am

There are lots of different ways to configure conky. A good starting point are the example config files on the conky site itself.

http://conky.sourceforge.net/screenshots.html
msuggs
Level 5
Level 5
 
Posts: 882
Joined: Thu Jul 10, 2008 8:25 am
Location: non-local

Re: conky @ startup?

Postby Rita G. on Wed Nov 12, 2008 9:18 am

omns wrote:Open the default config file found at /etc/conky/conky.conf and then save it in your home directory as .conkyrc.


can someone explain this a little more clearly,

i just spent about an hour trying this & getting nowhere.

thanks
Rita G.
Level 2
Level 2
 
Posts: 65
Joined: Tue Oct 14, 2008 5:32 pm

Re: conky @ startup?

Postby sputty01 on Wed Nov 12, 2008 9:35 am

You should have a hidden file in your home directory called .conkyrc which contains the settings for conky, the error message you are getting appears to indicate that there are some problems with it. If you do not know how to manually fix the configuration file then you will need to overwrite it with the default settings file located at /etc/conky/conky.conf to restore the default settings.

If you have trouble with that then fill the file with the following:
Code: Select all
# Conky configuration
background yes
use_xft yes
xftfont FreeSans:size=8
xftalpha 0.8
out_to_console no
update_interval 2
total_run_times 0
own_window yes
own_window_type normal
own_window_transparent yes
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
double_buffer yes
draw_shades no
draw_outline no
draw_borders no
draw_graph_borders yes
stippled_borders 5
border_margin 4
border_width 1
default_color grey
default_shade_color black
default_outline_color black
alignment top_right
gap_x 10
gap_y 10
no_buffers no
uppercase no
cpu_avg_samples 2
net_avg_samples 2
override_utf8_locale yes
use_spacer no

TEXT
${color white}$alignc$sysname $kernel on $machine
${color white}$alignc${exec whoami} @ $nodename
$color$stippled_hr
${color}Date: ${color white}${time %A,%d %B}
${color}Time: ${color white}${time %k:%M:%S}${alignr}${color}Uptime: ${color white}$uptime
$color$stippled_hr
${color}CPU:${color white} ${cpu cpu1}% ${cpubar cpu1}
${color}RAM:${color white} $memperc%  $mem/$memmax $membar
${color}Swap: ${color white}$swapperc% $swap/$swapmax ${swapbar}


Once you get conky to start without sudo then you will need to go into Preferences->Sessions and add conky to the list, this will make it start up when you log in :) too see what i mean take a look at this screenshot.
sputty01
Level 2
Level 2
 
Posts: 67
Joined: Fri Jun 06, 2008 7:51 pm
Location: Sheffield, UK

Re: conky @ startup?

Postby msuggs on Wed Nov 12, 2008 3:28 pm

Rita G. wrote:
omns wrote:can someone explain this a little more clearly


Sure :)

Open your Home Direcotory. Click on File Systems-->etc-->conky then double click on the file called conky.conf.

After this opens go to the file menu and choose Save as.

Save the file in your Home directory and rename it as .conkyrc (the dot before the name makes it a hidden config file). You will be asked if you want to replace the existing file. Do it. Close the File. (To see hidden files in your home directory go to View-->Show Hidden Files)

Now try conky again and it should be working :)

To add it to the Session Manger go the Mint Menu then Preferences-->Sessions

In the Control Panel that opens click on the 'Add' button. In the name field you can put whatever you want (like Conky) and in the command field just enter conky (all lowercase). Next time you log in conky should automatically start.

Once you have this all working it is possible to make conky look different and work in different ways. The examples on the website I gave you before give you some examples and I'm sure there are lots more out there with some searching. To change things just open the .conkyrc file in your home directory and edit to your liking.

Between this and Sputty's explanation you should get things up and running. Good luck with it :)
msuggs
Level 5
Level 5
 
Posts: 882
Joined: Thu Jul 10, 2008 8:25 am
Location: non-local

Re: conky @ startup?

Postby Rita G. on Thu Nov 13, 2008 8:31 am

can't seem to find this “home directory”.

have a “home” folder.

is that what you mean?
Rita G.
Level 2
Level 2
 
Posts: 65
Joined: Tue Oct 14, 2008 5:32 pm

Re: conky @ startup?

Postby Rita G. on Thu Nov 13, 2008 9:18 am

ok, got it now.

had to use gedit /etc/conky/conky.conf as root.

....and put it in startup....works nicely.

thank you all for help!
Rita G.
Level 2
Level 2
 
Posts: 65
Joined: Tue Oct 14, 2008 5:32 pm

Re: conky @ startup?

Postby msuggs on Thu Nov 13, 2008 3:03 pm

Rita G. wrote:can't seem to find this “home directory”.

have a “home” folder.

is that what you mean?


Yes, your Home folder is what I mean. You shouldn't really be using these types of programs as root. If you mess up the default settings in root then it will be difficult to fix. Try again to save the .conkyrc config file to your home folder then add conky to your session manager as a normal user.
msuggs
Level 5
Level 5
 
Posts: 882
Joined: Thu Jul 10, 2008 8:25 am
Location: non-local

Re: conky @ startup?

Postby Rita G. on Thu Nov 13, 2008 5:31 pm

sorry..........was running a little late this morning.

what i meant was,

had to access /etc/conky/conky.conf as root in order to make changes; it was giving me some permissions problem.

and “put it in startup” meant i added conky to startup programs in sessions.

thanks again.
Rita G.
Level 2
Level 2
 
Posts: 65
Joined: Tue Oct 14, 2008 5:32 pm

Re: conky @ startup?

Postby msuggs on Fri Nov 14, 2008 2:32 am

ok, glad all is well :D
msuggs
Level 5
Level 5
 
Posts: 882
Joined: Thu Jul 10, 2008 8:25 am
Location: non-local

Linux Mint is funded by ads and donations.
 

Return to Compiz, Conky, Docks, & Widgets

Who is online

Users browsing this forum: No registered users and 2 guests