a tricky conky/sound problem

Forum rules
Before you post please read this

a tricky conky/sound problem

Postby zerozero on Tue Jan 25, 2011 4:05 pm

This weekend (by request) i added a Gmail-checker to my conky ( viewtopic.php?f=60&t=30209&start=100 ); works great, no problems, all sorted, BUT...
...i went for troubles :lol: ; later i saw a new script that does the same but plays a sound on incoming mails

Code: Select all
#!/bin/bash

gmail_login="888888888888" 
gmail_password="88888888888"

nbmail="$(wget --secure-protocol=TLSv1 --timeout=3 -t 1 -q -O - \
https://${gmail_login}:${gmail_password}@mail.google.com/mail/feed/atom \
--no-check-certificate | grep 'fullcount' \
| sed -e 's/.*<fullcount>//;s/<\/fullcount>.*//' 2>/dev/null)"

if [ -z "$nbmail" ]; then
echo "Error"
else
  if [ $nbmail != 0 ]; then
    echo "$nbmail message(s)"
    aplay ~/scripts/phone.wav
  else
  echo "$nbmail message(s)"
  fi
fi


Let's see:
1- the script works just fine;
2- plays the sound on the incoming mails;
3-Terminal gives no errors at all;
all good, isn't it? well no!!
After i start listening to music in the player or in the browser, conky goes mute and if i stop the music wont start it again, but the terminal still doesn't give any error and says every 60 seg that the sound is played.

- Sound preferences are all good during that time;
- before putting the script into conky i could with no problem play 2 sound sources at the same time and now that is disabled (went back to the first one) can also;

So, what is my problem exactly?
- I would like to understand why this happen; :mrgreen:
- where do i start looking to debug this issue?
- why this aplay command mutes my system and how it interferes with alsa?

Habitual? :lol:
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Linux Mint is funded by ads and donations.
 

Return to Compiz, Conky, Docks, & Widgets

Who is online

Users browsing this forum: No registered users and 3 guests