Can't build conky from source

Forum rules
Before you post please read this

Can't build conky from source

Postby Slaggagary on Thu Feb 03, 2011 8:49 pm

So, I'm trying to install Conky 1.8.1. Whenever I put in the command ./configure the terminal informs me that:

checking for LUA... no
checking for LUA51... no
checking for LUA51... configure: error: Package requirements (lua5.1 >= 5.1) were not met:

No package 'lua5.1' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LUA51_CFLAGS
and LUA51_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

The problem is that I already have lua5.1 installed.

I'm pretty new with Linux and I'm not sure how to work my way around this. What do?
Slaggagary
Level 1
Level 1
 
Posts: 3
Joined: Thu Feb 03, 2011 8:38 pm

Linux Mint is funded by ads and donations.
 

Re: Can't build conky from source

Postby Roken on Thu Feb 03, 2011 8:54 pm

Try installing liblua5.1-0-dev
Kernel Linux Tex 3.2.2-1 (64 bit) xfce , burg
Arch
ATI Radeon HD 4670, 1GB
OSS4
AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked)
8Gb RAM
Image
User avatar
Roken
Level 5
Level 5
 
Posts: 747
Joined: Fri Nov 19, 2010 4:55 pm
Location: Oldham, UK

Re: Can't build conky from source

Postby Slaggagary on Thu Feb 03, 2011 8:59 pm

Roken wrote:Try installing liblua5.1-0-dev


What would that do?
Slaggagary
Level 1
Level 1
 
Posts: 3
Joined: Thu Feb 03, 2011 8:38 pm

Re: Can't build conky from source

Postby Habitual on Thu Feb 03, 2011 9:02 pm

allow you to .configure conky.

liblua5.1-0-dev - Simple, extensible, embeddable programming language <--- It's LUA
What's a landing but a take off in reverse?
My DorkBlog
User avatar
Habitual
Level 8
Level 8
 
Posts: 2067
Joined: Sun Nov 21, 2010 8:31 pm
Location: Undecided

Re: Can't build conky from source

Postby Slaggagary on Thu Feb 03, 2011 9:05 pm

Well... it worked. Thank you.

Would you explain to me, -very simply, as it were- how installing the previously listed package was any different from having plain Lua5.1 installed?
Slaggagary
Level 1
Level 1
 
Posts: 3
Joined: Thu Feb 03, 2011 8:38 pm

Re: Can't build conky from source

Postby Roken on Fri Feb 04, 2011 6:55 am

It's the development package for lua. If you are building a program from source then you will frequently require the development package rather than the binary to build the package. It isn't always made clear in the documentation for self-build.
Kernel Linux Tex 3.2.2-1 (64 bit) xfce , burg
Arch
ATI Radeon HD 4670, 1GB
OSS4
AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked)
8Gb RAM
Image
User avatar
Roken
Level 5
Level 5
 
Posts: 747
Joined: Fri Nov 19, 2010 4:55 pm
Location: Oldham, UK


Return to Compiz, Conky, Docks, & Widgets

Who is online

Users browsing this forum: No registered users and 6 guests