Conky in gnome

Forum rules
Before you post please read this

Conky in gnome

Postby mick_swagger on Sat Mar 26, 2011 3:30 am

How do I get rid of this shaddow?

http://i.imgur.com/Nuhqb.jpg
mick_swagger
Level 2
Level 2
 
Posts: 63
Joined: Thu Sep 23, 2010 6:36 pm

Linux Mint is funded by ads and donations.
 

Re: Conky in gnome

Postby Seca on Sat Mar 26, 2011 4:15 am

paste your .conkyrc file
User avatar
Seca
Level 1
Level 1
 
Posts: 42
Joined: Tue Oct 19, 2010 7:03 pm
Location: Cocoa, Florida

Re: Conky in gnome

Postby feed3 on Sat Mar 26, 2011 6:50 am

open your .conkyrc, under window specifications, should be like these;
Code: Select all
own_window yes
own_window_type desktop
own_window_transparent yes
own_window_hints undecorated,sticky,skip_taskbar,skip_pager,below


and after that, put "no" to some other settings as below;

Code: Select all
draw_shades no
draw_outline no
draw_borders no
draw_graph_borders no
feed3
Level 4
Level 4
 
Posts: 442
Joined: Sat Jan 09, 2010 12:52 am

Re: Conky in gnome

Postby Aging Technogeek on Sat Mar 26, 2011 9:00 am

The one setting that feed3 posted that you need to change is

Code: Select all
own_window_type desktop


Make sure your .conkyrc says this and not something else like

Code: Select all
own_window_type normal
Image

Registered Linux User 483387
User avatar
Aging Technogeek
Level 13
Level 13
 
Posts: 4604
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here

Re: Conky in gnome

Postby mick_swagger on Sat Mar 26, 2011 2:05 pm

Seca wrote:paste your .conkyrc file


I made the changes they said. And now it keeps closing by it self. Does anybody know what's wrong with my .conkyrc ?

Code: Select all
# UBUNTU-CONKY
# A comprehensive conky script, configured for use on
# Ubuntu / Debian Gnome, without the need for any external scripts.
#
# Based on conky-jc and the default .conkyrc.
# INCLUDES:
# - tail of /var/log/messages
# - netstat connections to your computer
#
# -- Pengo (conky@pengo.us)
#

# Create own window instead of using desktop (required in nautilus)
own_window yes
own_window_type desktop
own_window_transparent yes
own_window_hints undecorated,below,skip_taskbar
background no

# Use double buffering (reduces flicker, may not work for everyone)
double_buffer yes

# fiddle with window
use_spacer yes
use_xft yes

# Update interval in seconds
update_interval 3.0

# Minimum size of text area
minimum_size 400 5

# Draw shades?
draw_shades no

# Text stuff
draw_outline no # amplifies text if yes
draw_borders no
draw_graph_borders no

uppercase no # set to yes if you want all text to be in uppercase

# Stippled borders?
stippled_borders 8

# border margins
border_margin 4

# border width
border_width 1

# Default colors and also border colors, grey90 == #e5e5e5
default_color white
default_shade_color black
default_outline_color white

own_window_colour brown
own_window_transparent yes

# Text alignment, other possible values are commented
#alignment top_left
alignment top_right
#alignment bottom_left
#alignment bottom_right

# Gap between borders of screen and text
gap_x 10
gap_y 10

# stuff after 'TEXT' will be formatted on screen

override_utf8_locale no
xftfont Terminus:size=8
xftalpha 0.8

TEXT

${offset 240}${color slate grey}${time %a, } ${color }${time %e %B %G}
${offset 240}${color slate grey}${time %Z,    }${color }${time %H:%M:%S}
${offset 240}${color slate grey}UpTime: ${color }$uptime
${offset 240}${color slate grey}Kern:${color }$kernel
${offset 240}${color slate grey}CPU:${color } $cpu% ${acpitemp}C
${offset 240}${cpugraph 20,130 000000 ffffff}
${offset 240}${color slate grey}Load: ${color }$loadavg
${offset 240}${color slate grey}Processes: ${color }$processes 
${offset 240}${color slate grey}Running:   ${color }$running_processes

${offset 240}${color slate grey}Highest CPU:
${offset 240}${color #ddaa00} ${top name 1}${top_mem cpu 1}
${offset 240}${color lightgrey} ${top name 2}${top cpu 2}
${offset 240}${color lightgrey} ${top name 3}${top cpu 3}
${offset 240}${color lightgrey} ${top name 4}${top cpu 4}

${offset 240}${color slate grey}Highest MEM:
${offset 240}${color #ddaa00} ${top_mem name 1}${top_mem mem 1}
${offset 240}${color lightgrey} ${top_mem name 2}${top_mem mem 2}
${offset 240}${color lightgrey} ${top_mem name 3}${top_mem mem 3}
${offset 240}${color lightgrey} ${top_mem name 4}${top_mem mem 4}

${offset 240}${color slate grey}MEM:  ${color } $memperc% $mem/$memmax
${offset 240}${membar 3,100}
${offset 240}${color slate grey}SWAP: ${color }$swapperc% $swap/$swapmax
${offset 240}${swapbar 3,100}

${offset 240}${color slate grey}ROOT:    ${color }${fs_free /}/${fs_size /}
${offset 240}${fs_bar 3,100 /}
${offset 240}${color slate grey}HOME:  ${color }${fs_free /home}/${fs_size /home}
${offset 240}${fs_bar 3,100 /home}
${offset 240}${color slate grey}SLACK:  ${color }${fs_free /mnt/slack}/${fs_size /mnt/slack}
${offset 240}${fs_bar 3,100 /mnt/slack}
${offset 240}${color slate grey}NET:
${offset 240}${color}Up: ${color }${upspeed eth0} k/s
${offset 240}${upspeedgraph eth0 20,130 000000 ffffff}
${offset 240}${color}Down: ${color }${downspeed eth0}k/s${color}
${offset 240}${downspeedgraph eth0 20,130 000000 ffffff}
mick_swagger
Level 2
Level 2
 
Posts: 63
Joined: Thu Sep 23, 2010 6:36 pm

Re: Conky in gnome

Postby feed3 on Sun Mar 27, 2011 5:45 am

I'm not in linux nor mint rite now so can't test it further although i'm a bit curious on why/how it behave like that as i'm using conky most of time time. here is one of my conkyrc that i use previously and it just work fine in my desktop at my workplace. Can you see if it is working fine for you as well? just change some settings to fit your needs e.g: positions,size, colors, fonts etc.
Code: Select all
# Conky settings  #
background no
update_interval 1
override_utf8_locale yes
double_buffer yes
no_buffers yes
text_buffer_size 1024
imlib_cache_size 0

#  Window specifications  #
own_window yes
# change desktop to override can fix some issues as well #
own_window_type desktop
own_window_transparent yes
own_window_hints undecorated,sticky,skip_taskbar,skip_pager,below
border_inner_margin 0
border_outer_margin 0
#change your size
minimum_size 200 575
maximum_width 200
alignment top_right
gap_x 16
gap_y 16

#  Graphics settings  #
draw_shades no
draw_outline no
draw_borders no
draw_graph_borders no

#  Text settings  #
use_xft yes
# change to your font
xftfont Oloron\ Tryout:size=8
xftalpha 0
use_spacer left
uppercase no

#  Color settings  #
default_color ffffff
color1 bbbbbb
color2 999999
color3 eeeeee

#Taken from your conkyrc#
TEXT

${offset 240}${color slate grey}${time %a, } ${color }${time %e %B %G}
${offset 240}${color slate grey}${time %Z,    }${color }${time %H:%M:%S}
${offset 240}${color slate grey}UpTime: ${color }$uptime
${offset 240}${color slate grey}Kern:${color }$kernel
${offset 240}${color slate grey}CPU:${color } $cpu% ${acpitemp}C
${offset 240}${cpugraph 20,130 000000 ffffff}
${offset 240}${color slate grey}Load: ${color }$loadavg
${offset 240}${color slate grey}Processes: ${color }$processes 
${offset 240}${color slate grey}Running:   ${color }$running_processes

${offset 240}${color slate grey}Highest CPU:
${offset 240}${color #ddaa00} ${top name 1}${top_mem cpu 1}
${offset 240}${color lightgrey} ${top name 2}${top cpu 2}
${offset 240}${color lightgrey} ${top name 3}${top cpu 3}
${offset 240}${color lightgrey} ${top name 4}${top cpu 4}

${offset 240}${color slate grey}Highest MEM:
${offset 240}${color #ddaa00} ${top_mem name 1}${top_mem mem 1}
${offset 240}${color lightgrey} ${top_mem name 2}${top_mem mem 2}
${offset 240}${color lightgrey} ${top_mem name 3}${top_mem mem 3}
${offset 240}${color lightgrey} ${top_mem name 4}${top_mem mem 4}

${offset 240}${color slate grey}MEM:  ${color } $memperc% $mem/$memmax
${offset 240}${membar 3,100}
${offset 240}${color slate grey}SWAP: ${color }$swapperc% $swap/$swapmax
${offset 240}${swapbar 3,100}

${offset 240}${color slate grey}ROOT:    ${color }${fs_free /}/${fs_size /}
${offset 240}${fs_bar 3,100 /}
${offset 240}${color slate grey}HOME:  ${color }${fs_free /home}/${fs_size /home}
${offset 240}${fs_bar 3,100 /home}
${offset 240}${color slate grey}SLACK:  ${color }${fs_free /mnt/slack}/${fs_size /mnt/slack}
${offset 240}${fs_bar 3,100 /mnt/slack}
${offset 240}${color slate grey}NET:
${offset 240}${color}Up: ${color }${upspeed eth0} k/s
${offset 240}${upspeedgraph eth0 20,130 000000 ffffff}
${offset 240}${color}Down: ${color }${downspeed eth0}k/s${color}
${offset 240}${downspeedgraph eth0 20,130 000000 ffffff}


http://conky.sourceforge.net/config_settings.html this site help me a lot during my early days of conky usage..
Hope it can help you out..
feed3
Level 4
Level 4
 
Posts: 442
Joined: Sat Jan 09, 2010 12:52 am

Re: Conky in gnome

Postby mrpeachy on Sun Mar 27, 2011 11:16 am

it might not be your conkyrc at all
compiz will draw a shadow for the conky box
go here for the fix
http://conky-pitstop.wikidot.com/howto-s#toc11
mrpeachy
Level 4
Level 4
 
Posts: 262
Joined: Sat Dec 18, 2010 11:52 pm

Re: Conky in gnome

Postby mick_swagger on Sun Mar 27, 2011 3:25 pm

Well the compiz setting didn't help. When add own_window_type desktop that makes conky close by itself when i close any windows.
mick_swagger
Level 2
Level 2
 
Posts: 63
Joined: Thu Sep 23, 2010 6:36 pm

Re: Conky in gnome

Postby pluraldave on Sun Mar 27, 2011 7:11 pm

You can't use own_window_type desktop in Gnome because it conflicts with Nautilus. You have to use own_window_type normal for what you want.

border_margin should be border_inner_margin or border_outer_margin

use_spacer should be "left", "right" or "none" not "yes".

Apart from that your conky.rc is fine. The "border" is a shadow being drawn by Compiz. If changing the setting hasn't worked you've not followed the instructions properly. Try making the Compiz shadow fully transparent and see if you still have the issue.
User avatar
pluraldave
Level 5
Level 5
 
Posts: 709
Joined: Mon Sep 01, 2008 8:05 am

Linux Mint is funded by ads and donations.
 

Return to Compiz, Conky, Docks, & Widgets

Who is online

Users browsing this forum: No registered users and 4 guests